Old computer game, called maybe "Star Lanes"?

When I was a kid I played this game on my IBM XT wherein the idea of the game was that somehow you were involved both in the creation of trade routes between stars, and in purchasing stock in them. Your main objective was not to make trade routes, but rather to use them to increase your portfolio.

Haha, those crazy eighties computer games!

Anyway, I loved it. But I can’t quite rememebr what the game was called, nor can I find it on the net. Does it ring a bell with anyone here?

I recall that on each round you were given a choice of five spots on the map to develop, and you tried to pick spots each round which were positioned in the right relationship with the stars on the map (an ASCII map of course, BTW) such that somehow trade routes would form which you owned stock in and you would get more funds in your portfolio. Or something like that.

Sound familiar to anyone?


I found a copy of it–two similar games, actually. One called “Star Traders” and one called “Star Lanes.” “Star Traders” is “modified for Altair Basic 4.0”.

They are at the following two locations on the net:

oldcomputers.dyndns.org/public/pub/rechner/conitec/ prof80/prof80.uwe/disk_j/basic.013/lanes.bas

www.retroarchive.org/cpm/cdrom/ ENTERPRS/CPM/GAME/TRADE.BAS

Both files are old Basic files, (TRADE.BAS and LANES.BAS) though I can’t read them with a text reader–it comes out looking like ASCII gibberish.

I have doxbox, but I don’t know what sort of basic compiler or interpreter I would need to use to run either of these programs. I’m guessing if I can run either of them it would be “lanes.bas” since “trade.bas” seems to be intended for an Altair computer running CP/M.

Any ideas for how to run either of these programs?


I downloaded GWBasic, and tried to run lanes.bas. It actually ran a couple of lines, asking me how many players there were to be. But it then gave me a syntax error. I “listed” the program and what it listed looked like a BASIC program all right, but apparently it is using some commands GWBasic doesn’t know.


My QuickBASIC might be able to open them. Go ahead and email the files to me, and if it can, I can compile them to executables for you.

I can also fix any syntax errors. If GWBASIC can open them, I can, too.

GWBasic is interpreting alot of stuff in both trade.bas and lanes.bas as an “xor” operation, for some reason.

I get lines like “FOR I XOR 1 TAB( P1”

Most of the program’s lines make sense, but there are a lot of these wierd gibberish lines and many, maybe all, of them have an “XOR” in them where it doesn’t make sense to have one.


You can download the two files very quickly from teh following two locations:

oldcomputers.dyndns.org/public/pub/rechner/conitec/ prof80/prof80.uwe/disk_j/basic.013/lanes.bas

www.retroarchive.org/cpm/cdrom/ ENTERPRS/CPM/GAME/TRADE.BAS

(copy/paste the last one, since it does something funky with the board’s HTML here…)


Altair BASIC is really old. I’d be surprised if anything can open them completely correctly, but I’ll still take a whack at it.

This google search shows locations for both files.

trade.bas is the Altair version. Lanes.bas is the other version.


Ugh. LANES.BAS is wrecked. I might be able to get something out of TRADE.BAS, but the garbage characters won’t make it easy. Maybe I can find an Altair bASIC emulator.

I found an Altair simulator at http://www.schorn.ch/cpm/intro.html, but though I can get the simulator program to run, I can’t get it to load teh CP/M 2 OS.


I assume you downloaded the CP/M OS? I’ll give it a try shortly.

Yep, I downloaded it. It looks like there’s just a problem with the cpm2.dsk file, because it loads other OS files (like mbasic) just fine. Unfortunately, there is another more serious problem–I don’t think we have a way to transfer trade.bas to the proper “.dsk” format.

So this may be a dead end. Oh well…


No, I got it to load just fine. Now I just have to figure out how to load .BAS files into the simulator. Unfortunately, the alcohol is kicking in, and I can’t quite work it out at the moment. Tune in tomorrow!

Thanks for your help. Strange that “do cpm2” works for you but not for me. I’m absolutely certain I’m not doing anything “wrong.” After all, “do mbasic” works for me, and there’s no relevant difference between “do mbasic” and “do cpm2” which would make it plausible that one should work and the other not.


Anyway, I think the thing about putting trade.bas into the simulators .dsk format is going to render our task pretty much impossible. But tell me if you find anything…


I’m pretty sure lanes.bas is in Turbo-Basic, because I remember I used to have turbo basic and I’m pretty sure I remember running this game as an exe file, not from a basic interpreter.