one site's URLs not working in Firefox

Just today I’ve tried to navigate around the Sky and Telescope site, and Firefox (13.0.1) will not let me. The browser just displays a blank page.

It appears they’ve started using some kind of link tracker. I can access the site fine in IE, which must mean that some setting I’m using in Firefox is what’s causing the problem. However, I can’t figure out what that setting might be, and my Googling hasn’t turned up anything.

Here’s a link that didn’t work. I’ve disabled it just in case it really is some malware problem on my machine (which I doubt): h ttp:// the add-ons I’m using are Adblock Plus, DoNotTrackPlus, Greasemonkey, and Noscript. However, I’ve turned them off and the problem still exists.

Any ideas?

I’m getting a bit tired of Firefox myself. They seem to have problems opening sites or videoclips which use Adobe Flash. And the problem seems to be getting more prevalent. That could be your problem, I’m not sure. Having to constantly close Firefox constantly and switching to IE all the time has me fed up enough to just screw it and use IE all the time pretty soon.

The link you posted looks like an intermediate step in their link tracking. Is that really the link you clicked?

Try this one, which appears to be the intended destination and works fine for me in FF 12:

I see no sign of malware on either link.

I’m on FF 13.0.1 and the url worked for me. There has been some recent problems in FF for anyone who’s upgraded to Adobe Flash 11.3.300.257, but it does not appear to be affecting your url.

It appears to be Do Not Track+. With DNT+ enabled I got the same behavior. When I disabled it, I got through fine, after the intermediary redirect page to which your link brought me.

If so, that’s not a problem with Firefox, but a problem with the site. All DNT+ does is send a note telling the site you don’t want to be tracked. It shouldn’t have any behavioral differences.

And the thing with Firefox 13 and Flash is very clearly Flash’s fault. There’s no excuse for them not testing their new sandbox on Firefox 13.

The stuff that is Firefox’s fault is usually much worse.

I’m using the most recent version of Firefox and your link is working fine for me.

The link you posted has a space between the h and t in the http:// part of the link and will work fine once that space is removed. :slight_smile:

Photoplasties from the Cracked site never seem to work for me in Firefox (even when I turn off all of my Flashblocking addons).

For photoplasties, click the little link that says “article view”: much better in any browser.

I would agree, that SHOULD be the case, but I think it actively BLOCKS requests to tracking sites as well. Here’s the HTTP header trace when trying to access the link in the OP:

GET /r?19=961&43=225842&44=159744325&32=3186&7=162446& HTTP/1.1
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20100101 Firefox/13.0.1
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip, deflate
DNT: 1
Cookie: click_mobile=0; cc=t; 8305106666=1
Connection: keep-alive

HTTP/1.0 302 Moved Temporarily
Date: Sat, 23 Jun 2012 20:34:51 GMT
Server: Apache
Cache-Control: no-store, no-cache
Vary: Accept-Encoding
Content-Encoding: gzip
X-Server-Name: va-c1-r1-u24-b1
Content-Type: text/plain; charset=UTF-8
Via: 1.0 va-c1-r4-u21-b2:3128 (squid)
Connection: close

So it’s attempting a redirect to Clickability directly – which is listed in DNT+ as a tracking site – and I suggest is blocking that redirect, eliciting the behavior seen.

Firefox 13.0.1 on my Mac won’t open the page, even with do not track turned off, quitting Firefox then restarting it and the errant space in http deleted.

Safari opens it, then is redirected to

Firefox opens when it’s typed into the URL strip, but a warning appears across the top saying “Firefox prevented this site from opening a popup window,” because I disabled popups. (I have popups disabled in Safari, too, but no warning appears with Safari when they’re blocked.)

So the problem appears to be cross-platform.

I fixed it.

The link I had was from its RSS feed. The trouble was that, on the blank page that displayed, DNT+ showed 0 trackings, and thus did not let me allow! I got around this by going to their home page and allowing tracking there.

Thanks for everyone’s help.

Well, then, they lied about what it’s supposed to do. The entire point of it was supposed to be that it woudln’t block anything. The blocking was supposed to be done server side.

Plus, if that’s the case, why in the world would that be the only problematic site? Even the Dope uses link trackers. Unless, of course, your site is using something much worse.

I’ve been having numerous, persistent problems with the new double-digit versions of Firefox. (I don’t know what it’s up to: I’m away from that computer.) Pages show up blank or are created with no URL. Flash has seemingly stopped working entirely on many sites, if not all.

I’d say your problems are a general Firefox problem, not a site or computer problem. How does one fix the Flash issue?