Please help me with Adobe Premiere before I kill myself

So I’m unhappy with the results of a video I recently made to put on YouTube, mainly because though the resolution was kinda low in the original clips (digital camera, not a camcorder), the program I used (VideoMach) really pixelated it MUCH further when saving the video after I’d pieced it together. So I’m trying out Adobe Premiere 6.5, but apparently I’m far too stupid to figure out how to use it.

I’m looking through the help, and it has passages like this:
Drag the jog tread left or right, past the edge of the controller if necessary, until you reach the frame you want. If you drag the cursor to the edge of the screen without reaching the end of the clip or program, you can continue from the same time position by starting another drag from the jog tread.
The problem? They talk about the “jog tread” several times, but never tell you WHAT THE HELL IT IS or WHAT THE HELL IT LOOKS LIKE so I have absolutely no idea how to follow their instructions. It also never gives a specific definition of what “the controller” is, though it tells you all kinds of details as to what its function is. The HELP seems to be written for people who already know everything about the program. I want to bludgeon to death whoever wrote it.

My next problem… in VideoMach, you could select a spot in a video clip either by time or by frame number. So I might have a clip where the starting point is frame #2383 and the ending point is frame #2552. I have yet to be able to see where to go to a specific frame in Premiere, other than by time. In my original program I adjusted the display to show time instead of frame number, and I find that the above frame numbers correspond to the times 00:01:35.280 and 00:01:42.040. So I go into the same video clip in Premiere and tell it to go to 00:01:35.280. The problem? Well, first, when I enter 00:01:35.280 it changes it to 00:01:36.030, and while it is close to the same, it is not the exact same frame.

But what is even worse is that I can’t FIND the frame I need. I use the “previous frame” button because I know the frame I want is just a tad before the one that it is showing me…but the “previous frame” when navigating it in Premiere is not the same. In fact, in VideoMach I have to back up 23 frames to see the frame that Premiere says is the one right before it! So there is, in fact, NO FREAKIN’ WAY to get to the frame I need when using Premiere. In fact, the frame doesn’t even appear to EXIST. It’s the same exact file, so I don’t see how this is possible.

I tried to hit “play” hoping that it would show me the frames between when playing, but while the little slider underneath moves along showing that it is playing, the picture in the clip only changed like 2 or 3 times in the 5 seconds or so that I let it play. So while in VideoMach the frame rate is 25 frames per second (I verified this by counting the frames and watching the time counter; I triple checked to be sure I was right), in Premiere it seems the frame rate is less than one per second. How the hell can that be? Why is this fancy-ass piece of software a million times shittier than the $35 crappy software I’ve been using?

I Googled for a tutorial, but while I found lots of tutorials on how to do specific fancy tricks, the only one that looked like it was just a basic “starter manual” on how to use Premiere was an article on which, when I clicked the link to it, redirected me to the main index page for that area of, and I couldn’t for the life of me find the article anywhere.

I’m seriously so frustrated I’m on the verge of crying. I am sure this program can do what I want it to do, but I’ve been working on it for an hour and a half and I’ve made ZERO progress and I feel like I must be the stupidest person on the planet.

Can somoene PLEASE help me? :frowning: :frowning: :mad: :mad: :frowning: :frowning:

Whoa… it ain’t your fault! Premiere is a very complicated program, and it’s easy to get overwhelmed if you jump in blind. Have you considered getting a book?

Anyway, I’m not too familiar with it myself, but I think I can answer a few of those questions:

The “jog tread” is a dial in the Monitor window. You see the play/step forward/step back buttons in the middle of that window? Right below that is a horizontal slider, the shuttle, which moves you forward or backward through the clip quickly. And directly below that is the jog dial, which moves you slowly. Hover your mouse over either thing for a second or two and you’ll get a tooltip with the name.

As for the frame rate, did you set the rate to 25 FPS when you created the project? By default, Premiere assumes that you’re going to be working with DV video, not computer/camera video, so it assumes you’re going to be using NTSC 29.97 FPS video. If you import a 25 FPS clip, Premiere will convert it to 29.97 FPS and all your times will be off. Make a new project and make it 25 FPS if necessary.

To go to a specific frame, click the left timer beneath one of the preview displays in the Monitor window. You can enter a frame number there, like 2383, and Premiere will automatically jump to it.

Lastly, did you know that 00:01:35.280 is not “1 min 35.28 sec” but rather “1 min 35 sec 28 frames”? That might cause some confusion if you’re expecting decimal time.

Oh, and are you familiar with video compression? If it looks much worse after you save it, your editing program (is that what VideoMach is?) is probably using a poor codec. YouTube recommends DivX, which isn’t a bad choice.

Let me know if you need more info on that.

Thanks for the reply, Reply

Yes, I created it as 25fps when I created the project. And I didn’t bother saving the project since I accomplished nothing in the time I worked on it.

And yes, I figured that the last number is frame number, which made me curious since the VideoMach had frame numbers above 25 in that position… but I know it’s 25fps because I entered 00:00:01 as the in point and 00:00:02 as the end point and then looked and it had 26 frames. I also set it at the very beginning of the clip, and hit the “next frame” button over and over until it got to 1 second, and it had been 25 frames during the first second, with the 26th frame being the starting point of the next second. I’m not sure why the numbers in VideoMach go higher than the 25, but the conversion doesn’t work across to Premiere. (Actually, on a second look, in VideoMach it says the numbers are hh:mm:ss:msec so apparently it actually does it in milliseconds and not frame numbers.)

I finally found the “jog tread” but it wasn’t in the same place you said. It was above all that. Anyway, for reference, here is a screencap of the VideoMach window where you set in/out points:
and here is the window in Premiere:

both are set at “00:01:39:24” though as we now know, that represents something different in each program. The frame that is showing in Premiere is located at “00:01:39.920” in VideoMach.

I don’t see where I am supposed to go to enter a frame number. I want to go to frame 2838… can you tell me where, in that screenshot, I enter that? The only place that lets me type anything is the time box on the right, but when I put “2838” there it translates that as “00:00:29:13” which is completely different.

Oh, weird, sorry, I’m using Premiere Pro 1.5 and it looks completely different (yet vaguely similar). What version are you using?

In your Premiere screenshot, try clicking the timer that says “1:42:15”. On mine, that lets me enter a frame.

The green 1:42:15, I mean.

That box doesn’t let me click into it, or enter numbers. This is Premiere 6.5

I’m not sure then, sorry :frowning:

But two things: If Premiere is set at 25 FPS, how did the timer ever get up to 00:01:36.030? There shouldn’t be a 30th frame.

And also, what are you trying to do with the clip? If you just want to do some light editing, VideoMach, Windows Movie Maker, or some other similar program might be enough for the job and still get you a high-quality video if you save it with a good codec.

Where are you seeing 00:01:36.030?

What I am trying to do is redo the video that I did in VideoMach… but since I want to learn Premiere anyway I figure it will be cool that I can actually do some of the things that VideoMach can’t do (like transitions. I wanted them in a number of places but VM doesn’t do them). Here is the current video on YouTube:
Part of the problem is that a couple of times, because of the way that VideoMach works, I had to take a bunch of clips and edit them together, and then save that as an mpg, then use that mpg in the next step… so the final version is actually like a 3rd generation output from VideoMach, and I guess it loses a little quality each time. I’m really hoping to be able to learn Premiere because it is something I’ve wanted to do for a long time. I have a real interest in video editing and always have.

Ok next issue. (sigh)

I am manually finding the proper frames using the joggy thing (though it still seems to jump over places where I know there are intermediate frames). Part of what I did in VM was, for example, when I wanted to fade in from black but wanted to have a totally black screen for a second before the picture started to fade in, I’d set the in point for a place in the clip earlier than I wanted to show, then set a brightness effect with the brightness turned all the way down and have that effect last for the duration that I wanted black, then start the fade-in from the end of the black segment… kinda clunky. I figure with Premiere I can either have it just show a black screen or I can stick in a still image of black and do it that way. Except now I can’t figure out how to stick something in the timeline except at the beginning (or directly following a previous element). Do I have to set the black chunk first, and then add the next one, or is there a way to place a clip at a specific starting location? This should be easy but I just totally don’t see how.

I really feel stupid :frowning:

Ok now what is this thing? I downloaded the trial version of Adobe Premiere Pro 2.0. I needed to zoom in on the timeline so I clicked on the little magnifying glass, but when I clicked into the timeline it put a red line with a little blue thing at the top that looks like an upside down teardrop with little lines in it. I don’t know what it is or what it does but I can’t make it go away, so I’m starting over. GARRRR!!!

Buh??? I just tried to import my clips (mpg) into a bin in 2.0 and it says they are damaged or unsupported files. To check if they were damaged I opened them in Winamp, which played them fine. 6.5 opened them ok…

00:01:36.030 was from your first post, but it doesn’t matter anymore if you already found the right frame.

To place a clip at a specific location, you can either drag it from the project window and into the timeline, or…

You use that “red line with a little blue thing at the top that looks like an upside down teardrop with little lines in it” (that’s the BEST description of it I’ve heard!), which is nothing more than a cursor indicating your current position :slight_smile: It’s like the little blinking text cursor that shows you where you’re typing when you reply to a post here, 'cept that one is for video, of course.

Instead of dragging the clip directly into Premiere 2.0, did you try importing it with File -> Import? I can’t download the 2.0 trial right now since my connection is too slow, but I’ll do it when I get home.

And don’t save to MPEG (.mpg) at ANY time. Even doing that once will kill the quality. MPEG1 is horrible… stick with uncompressed AVIs if you can until the end, and then convert your final product to DivX, WMV, QuickTime, or Flash Video.

Lastly… it’s really cool that you want to learn Premiere. I’m taking an intro to film class and making/editing your own videos can be a lotta fun, but we use iMovie (which is a whole lot easier to use).

And did you download the Elements trial or the Pro trial?

I downloaded Adobe Premiere Pro 2.0. My digital camera saves video as mpg, so that’s what I started with. I didn’t know you could drag videos into Premiere, I only knew about importing them into the bin, so that’s what I’ve been doing.

Ok so after trying unsuccessfully with a few other programs I downloaded to convert my mpgs to avi files that Pro 2.0 would read… (they would convert but still said unsupported. Or in one odd case, said the audio was unsupported. Since the clip didn’t have audio, I’m confused…) …so now I’m using Premiere 6.5 to convert each mpg into .avi, which I tested and those do indeed import into Pro 2.0. sigh it is taking forever. I’ve already been doing this for about 4 hours.

I’m so disgusted with my inability to figure out this software… because of the stuff I’m filming, I had my camera mounted sideways on the tripod, so my aspect ratio is 240 wide by 320 high, rather than vice-versa. I have the project aspect ratio set to the correct proportions and it’s working ok with the stuff that I had already rotated using VideoMach… but I am now trying to use a new clip that I took today, and figured I’d rotate it in Premiere. Oh how wrong I was. This is damned near impossible!!! I’ve Googled. I’ve searched the help. I’ve tried everything. Camera angle/roll… doesn’t work. Transform…doesn’t work. When I apply stuff to the clip, I occassionally get some sort of change in the preview window, but what I get is the clip rotated, but now it’s distorted aspect-ratio-wise to the opposite dimensions! Which is so retarded I can’t even describe it. So instead of an image filling the 240w x 320h box, I get a fat-ass-wide version of my video that is cut off on both sides and is only 240 high. WTF. That makes no sense at all. I cannot for the freakin’ life of me find a way to just say “take this video, and turn it on its end. Keep everything else the same.” I would think this would be a COMMON THING for people to want to do, so why is it so impossible??? Hell it’s a two-clicks-poof process in VideoMach!

I still want to cry. This is effin’ ridiculous :frowning:

Oh I forgot to mention… I’ll see a change briefly in the preview, but when I move the slidey thing back and forth to view the clip in motion, any changes that the effect I’d applied were set to make don’t show up in the preview anymore. And when I do a test save (about 50 frames worth just to see what it’s doing) none of the effect has been applied, and I just get my video, still sideways, but now squished to the wrong h/w proportions. bangs head on keyboard

You need to render the files to see any changes you make. This creates “preview” clips that will have all effects applied. To render a preview, hit the Enter key, and it will render everything under the Work Area Bar, which is the yellow bar with sliders at each end, just above the timeline timecode.

I have Premiere 6.0 on my computer, and have been using various versions of it for the past four years, if you need any more help.

Oh, rotation in Premiere Pro 2.0 is done by selecting the clip, and in the Effect Controls for that clip, is a Motion section. Make sure the keyframe icon (a tiny stopwatch image) is hollow, and then adjust the rotation to 90 degrees. Or 270, or whatever. It will rotate the whole clip for its entire length. You can then select the word Motion and Ctrl-C copy, and Ctrl-V paste those settings to all your other clips.

Cool, thanks. I am so frustrated :frowning: