Problems with MacBook Pro recently upgraded to Yosemite

This “upgrade” is really pissing me off. One thing at a time:

  1. All my pictures now show as thumbnails, not full sized images. I’ve tried everything I know, I can’t access the full sized pics. Before “upgrading” the full sized pics were alway what I got whenever I opened iPhoto. And when I copy a pic from iPhoto and paste it into one of my folders, it shows up listed as “thumb” instead of “img” like it used to. And instead of being 2-4Megs, it’s typically 300K.

Any advice? Is there some setting I need to set properly to view the full sized pics? When I do a “get info” on the thumbnails, it shows the full size of the pic, but it doesn’t give me a directory trace to where they actually are.

And just a note… this operating system is WAY more unstable that what i had before. I get application crash a couple times a day now as opposed to maybe once a week before. ACK!!!

If you can remember the name of a particular pic, type it into Spotlight. It might show up.

Anytime I upgrade to a different-name operating system, I do a clean install. The screwups when installing over the old one are a pain.

You might also trying restarting while holding down the shift key. Restart it first, then quickly hold down Shift until the logo and progress bar show up. The OS goes into “safe mode,” which tosses all non-Apple extensions and whatever else non-Apple is in there, then runs a repair.

It takes a long time and after it restarts on its own you may have to click the mouse a couple of times to get the menu back across the top.

Then restart it again to get out of safe mode.

Edit: When I say it tosses non-Apple extensions, I mean the OS doesn’t load them. It doesn’t trash them.

Are your running iPhoto or Photos?
I don’t like some limitations in Photos, so I’m running iPhoto in Yosemite. You can have it re-build your library by following the instructions here.

I assume you did a complete backup before you upgraded, so that if something got trashed, you have a recent copy of your iPhoto library…

What Apps are crashing? I find Yosemite rock-sold.

Thanks much. I know you’re one of our local experts on these matters so thanks in advance for offering advice. I’ll give that a try in the morning. I’m using iPhoto, not Photos.

You know what happens when you assume? You make an ass out of me…

No, I didn’t do a back up. I guess I never thought that upgrading my operating system, which they’ve been hounding me to do for months, would wipe out my photos. Lesson learned.

Applications. Excel, for one. SketchUp especially. It’s seems to be prompted by clicking on too many commands too quickly. Reminds me of the days when my old Windows computer was on its last legs…

It’s possible that you have a flaky hard drive, which might explain everything
Take a look in Disk Utility, and see what the SMART status of the drive is.

For what it’s worth . . . the problem is with your system, not with Yosemite. I upgraded to Yosemite on both my Mac Pro and my MacBook Pro, with no problems whatsoever.

Could it be that I’m using the Cloud and that I now have too many pics to be stored properly in the Cloud? I’m still befuddled, though, why the pics “info” show the full size, but no info on where the “full sized pics” are residing.

“S.M.A.R.T. status: Verified”

I’m assuming that means it’s OK…?

Well, it at least means it’s not failing in some blatant fashion…

If you go into iPhoto, and click on a photo, you can then go to File -> Reveal in Finder -> Original. If this works for a bunch of random photos, but iPhoto is only able to display the thumbnails, you need to rebuild your library.

I don’t have “reveal in finder”, but I do have “show referenced file in finder”, but it’s always unshaded, and thus non-functioning.

I am able to export original, and that puts the full-sized photo in a folder of my choice. Not the best solution, but it does work.

There are two things you need to distinguish, firstly in your own mind and then in your investigation of this issue:

a) The quality of the image FILES THEMSELVES. There is a small but not entirely dismissable possibility that upgrading your OS (or some other process that came along with doing so) actually modified your files and degraded the amount of info stored in them. I doubt it but it isn’t impossible.

b) The viewing experience, the display OF the files as images. You’re using iPhoto. iPhoto is absolutely part of the OS package insofar as it is a standard Apple application that gets overwritten with the new version when you upgrade.

Making this distinction in your investigation is complicated a bit by your own uncertainty as to where the hell your files actually are:

I have never understood and still don’t understand how people can tolerate being unaware of their computer environment on a file-and-folder level, but it’s clearly the way things are headed overall. But here’s what I would do:
a) Download GraphicConverter. You may need to first change your own security settings if you’re running the default Yosemite setting that says only applications downloaded from the anointed App Store can be installed. Launch it.

b) Do a ⌘-F to bring up the advanced file-search screen and search for one of your files by file name. (I assume that iPhoto does at least deign to display file names?) Anyway, once having located the file in that window, double-click the enclosing folder of that file where it appears at the bottom of your search window. Aha!, you say, here is my file! (Presumably not on the “Cloud”)

c) Right-click your file and select Open With and specify GraphicConverter or, alternatively, launch GraphicConverter first and then navigate to the location at which you found your file and open it in the standard File:Open dialog

d) At lower left you can specify the % of actual size to display in the window. Switch to 100%. You can also invoke the Information window by doing a Command-Shift-I, and the Info window will display your image’s size in pixels. Like so. If your image size looks normal and the Info windows indicates a reasonable non-thumbnaily number of pixels, your image file is fine (and most likely the rest of them are too) and it’s just a change in default behavior of iPhoto (which is a misbegotten monstrosity which you are not stuck with, but if you’re used to it, fiddle with its application preferences until you figure out how to make it display images at a useful size).

That part of “the Apple experience” drives me absolutely bonkers. It’s not as bad on the Laptop as on the iPhone, but you can tell they want to push it more and more in that direction.

OK, this implies that you are running Photos, not iPhoto!

Please check - what does the Menu item next to the Apple say?

Shit, you’re right. I didn’t even notice. That damn little “i” is easy for us old folks to miss!! I don’t even remember there being a “Photo” App before. It was the App that showed up in exactly the same spot where I had iPhoto before I did the upgrade, so I just assume the icon changed.

But I just tried to open iPhoto, and it said I need to update to the latest version, then provided a link. When I clicked on the link I got a screen that said “this item not available in the US”. Fun with computers… You’d think when I did the upgrade, it would have upgraded the Apps, too.

Maybe I’ll just go directly to the App store and download the latest version.

Photos was a stealth “upgrade” to iPhoto after 10.10.3.
It can be difficult to upgrade iPhoto, because unless it’s registered with the App store, there’s no way to download it.

Your iPhoto library should still be intact - if you can do the iPhoto upgrade, you should be able to disable Photos and go back to iPhoto. Note that there are a lot of good things about Photos, and you might want to just continue using it (once you get the database straightened out) - I don’t like it because I work in RAW, and I use iPhoto as a “slide sorter” and then use Photoshop to edit the photos. Photos doesn’t support external editors (yet).

OK, I guess the wikipedia article says it all:

*iPhoto was a digital photograph manipulation software application developed by Apple Inc. *

Emphasis added. I guess I shouldn’t fight the power and just start using Photos. I now see how to export the full images, but I sure would like Apple to tell me where my damn photos are actually stored so I can access them in Finder, like any ordinary file.

Yeah, Photos is even worse than iPhoto in that respect…

I would guess that Apple will make it easier to work with external editors in the future, but until they do, I’m not giving up iPhoto!

Kind of a PITA, but I guess I need to start filing photos as I take them, and not rely on this application to manage them. Then I’ll know where the actual, full sized files are.

Something a bit suspicious, though. I just exported all the full sized photos in my photo stream to a thumb drive. They are all in the 1.0M - 1.5M range. I’m certain that my photos were all in the 2.5M - 3.0M range before. These are photos taken on a iPhone 6, so I feel like I’m being cheated of some resolution.

I think that Photos doesn’t store full-resolution versions on iCloud.
You might want to look into this - I think you can have full-res versions locally, and smaller versions in the Cloud.

Yeah, and that’s another F’ed up thing Apple does. There isn’t an easy way to transfer photos between a phone and a Mac except by using the cloud.