problems with USB port and external hard drive

I got a new Buslink external hard drive but my computer doesn’t recognize either USB port. After discussions with both Buslink and Gateway it seems the problem is the USB Root Hub for the AMD 756 PCI to USB Open Host Controller - “the NTKERN.VCD device loader for this device cannot load the device driver”. I tried to update the driver and Windows told me it did so successfully, but after rebooting there is still that damned yellow exclamation point. According to the Gatway rep, the only way to fix it is to reinstall Windows.

I did a Google search and found that this is a common problem. One solution was to restore the following files which were missing from the computer - Hidclass.sys, Hidparse.sys or Hidusb.sys files. I found them on one site and put them into the System 32 folder and reinstalled the driver but no luck, and then I got a copy of my brothers Win XP installation disc and restored them from there and still no good.

Am I going about this in the wrong way?

Anyone? Anyone? Bueller?

Well, try reinstalling Windows. The worst that can happen is you miss 30 minutes out of your life.

But make sure you pick to repair your XP installation, don’t install fresh. Installing XP fresh involves a format, and I don’t think you want to resort to that quite yet.

Does it load the driver if you restart with the external drive unplugged from the USB port?

After you restored the files, did you try deleting the device from the Device Manager and rebooting?

1: Power down

2: Remove any non-critical accessory PCI cards (ie modem, sound card, SCSI etc)

3: Check the BIOS setup and make sure the USB port(s) are set to be “on” and are not defeated, and are in “legacy mode” if that option exists in BIOS setup.

4: Delete all the USB ports on the system via the control panel hardware setup and then re-boot and let Windows re-recognize them.

Needed to add

5: If all goes well re-install the PCI cards after Windows recognizes and installs the USB ports.

Wouldn’t you want to do this part before Step 1?

I thought about that, but I thought it might be best to stabilize the hardware (if possible) and emiminate any potential IRQ fights before asking the system to delete then re-recognize and re-assign addresses for the USB ports. It would probably work either way, however, I’m making a WAG that by sorting the hardware out beforehand it’s just less work for the system to diagnose and solve potential conflicts when re-installing the USB ports.

It is entirely possible that your mobo is shot.

Naw, you might have turned off the USB ports in the BIOS, did you look there?

Thanks for all the suggestions but nothing worked. I think I did the BIOS thing correctly (never done it before), I went into the setup utility before rebooting and restored all the system defaults - I didn’t see any specific mention of USB ports. Anyway I’m sure we checked when I was one the phone with technical support.

Anyway, I then deleted the USB ports and when I restarted Windows recognized them and reinstalled the drivers but I still have the same problem.

Had one moment of excitement when I saw an old driver for a mouse which I believe was USB and deleted that - thought there might be some conflict but NOOOOOOO!

Are the USB ports just physically bad?

See if there is a BIOS update for your mobo available. If so download and apply it.

Is it a Via chipset board? Cuz you need the Bios update for sure, as mentioned above.