External Hard drive Mystery

I’ve got a Toshiba 500gb portable hard drive. Used to work flawlessly, then suddenly- nothing. The little blue light comes on, but the laptop doesn’t recognize the drive- no bleep noise of recognition. Going the the control panel and hitting “add a devise” does nothing. Today I fired up an old web book I had stashed in the closet, and the drive was recognized immediately. I could feel it spinning, which it doesn’t do anymore when plugged into the laptop. I’m guessing the easiest thing to do would be to plug a new harddrive into the webbook and copy over from the Toshiba.
Why does it work on one computer but not on the other?:confused:

Maybe it’s the USB port that’s faulty. Have you tried different USB ports? Have you tried connecting other devices on the port?

No problems with the USB ports- everything else I’ve plugged in works ok. I was thinking maybe it was the hard drive’s cable, until I plugged into the old web book and it worked ok.

To be clear, have you tried more than one USB port on the laptop? They are finicky.

That was the first thing I tried. Also, I have two old web books. The drive works ok on one, and on the other it acts just like my lap top- nothing. Weird.

Strange, a similar thing happened to me today. I was using a USB drive to carry files back and forth between my WinXP primary PC at work and a device that we sell with an integrated Win7 tablet. The drive suddenly stopped working on my desktop but was seen by all the other computers I tried. I think it started working again after I properly ejected the drive from the Win7 tablet. I’m not sure that was the fix but it is something to try.

Might be a power issue. Can you try a powered hub / double-ended cable?

Try the following.

  1. Right click on Computer.

  2. Select Manage

  3. Go to Storage>Disk Management.

  4. Wait while disk configuration information loads.

  5. Once it has loaded, go to Action>Rescan Disks.
    See if the disk appears on the list of drives.

Thanks for the detailed instructions. No, it didn’t show. I think I’m going to get a new drive and copy over using the computer that it* does* work on, before I lose everything altogether.

One further suggestion. It could be a USB issue.

Go to Computer>Manage>System Tools>Device manager.

Open Universal Serial Bus Controllers.

For each device listed there, right click and select Uninstall.

The computer will reinstall them in a couple of minutes. Doing this may resolve USB issues.

These external drives are just a laptop SATA disk within an enclosure with the circuitry to convert SATA to USB.

Sometimes the USB circuitry will go south while the HD is still functioning. You can take the whole thing apart and either connect the disk to a sata cable on the computer motherboard or buy a new enclosure

Some of the WD Elements drives are natively USB - the drive’s logic board only has a USB port.

What has changed on your system? Have you plugged in any other drives? Windows XP has some definite drive letter sharing issues. How it allocates drive letters is a bit of a mystery to me.

External hard drives have some of the highest power demands of any USB device, and laptops are kinda famous for underpowering USB ports to save battery power.

Is your laptop plugged in when you try?

Are your power settings set to some kind of “power saver” level?

If not you may have some minor failure in power delivery to USB ports that is no longer able to deliver the full USB spec power to the ports. A powered hub would be a workaround for this or using an USB drive that uses multiple USB ports to spread out the load.

Another possibility - do you have any mapped network drives?

I’ve seen issues where a network drive is mapped to a lower level drive letter and the USB drive connects on that same drive. That can cause all kinds of weird issues.