Question for Mac users

Re: Using ‘Safari’,
Is there any way to keep the drop down history from showing all the places I’ve typed into the address bar when typing in a new address? Or to ‘clear’ that history?
Thanks in advance.

There is a “Clear History” item on Safari’s History menu.

Can’t say whether or not it works…personally, I’m kind of fond of my history…

‘Clear History’ does not clear the drop down history. Click on the address icon and type in a common letter, the menu will give (and show anyone looking) your hand typed history.

It did mine, just now…

Mine too. (Except for the ones that Apple sticks in there for money.)

I believe what Hombre is asking is how do you prevent the address window from “auto-filling” in a previously visited web address when you begin to type one in. For instance, if you just type in “www.”, you should get a long drop-down menu of various sites you’ve visited, typing “www.a” will give a list of sites whose addresses started with “a”. Selecting Clear History from the History menu doesn’t get rid of this “auto-fill” list. I think the only way to get rid of this history is to select Reset Safari… from the Safari menu. Not the best way of doing it, because that’ll also delete any other settings, cookies and saved names you may want to keep. I’d be interested to know if there’s a more elegant solution.

Oh, just go to preferences Pull down the edit dropdown for other forms, remove all, or just what you want and un-click auto fill in that field…

Web Browser
Browser Display
Toolbar Settings. Unclick autocomplete.

Like the nice Nurse said. :smiley:

I’m a ninny!
Sorry, I can’t find it. Would someone hold my hand?
I’m running 10.3.3.
Thanks ever so…

To clairify, I went to ‘Safari’, ‘Preferences’, ‘AutoFill’, ‘other Forms’ (edit), ‘Webesite’, ‘Remove All’, ‘Done’ and…nothing happens.
If I start to type in an address (in the address bar) after one letter I still get the drop down history.

Do what nurse says, then clear your history.

If that doesn’t work, you need to lock the history file. Go clear your history (and your cookies and other stuff too, while you’re at it). Quit the program, then find the file that holds the history of where your surfed to (it’s in one of the Library folders, IIRC), ‘Get Info’, and lock the file so it can’t be rewritten.

There is no way to turn it off, Hombre. The term you’re looking for is “autocomplete” (autocomplete addresses), not “autofill” (autofill forms). Other browsers let you turn it off. Safari does not. Search for “Safari autocomplete turn off” to see lots of griping about Apple’s bad design on this one.

The most you can do is empty your cache and clear your history; that way, the only URLs it will suggest for autocompletion are those that are in your permanent bookmarks.

toadspittle is correct…there is more discussion about some specific ways to reduce autocompletion at Apples discussion forum (and here)

There are many bookmarks that come already installed with Safari…the discussion forum suggests getting rid of those if you don’t use them.

The only other suggestion I would make is to consider using another browser like Firefox or Camino (which both allow you to input Safari bookmarks…saving you that hassle).