Redhat Linux vs. Compaq Internet Keyboard

Okay, here goes…

Compaq Presario 7AP170
900 mHz Athlon
42.9 GB HDD
4X CD-RW Drive
8X DVD Drive
SB PCI 128
Riva TNT2 16MB
Accton EN1207D Fast Ethernet Card
PCTel V.90 Modem
Compaq Internet Keyboard
Microsoft Intellimouse Explorer
Viewsonic A70 Monitor
Motorola Cable Modem w/3Com Router

Blah, blah blah…

Anyway, here’s my problem. I’m running Windows XP Pro right now, which works perfectly. However, recently I decided to install Redhat 7.2 on the computer. I used Partition Magic 7.0 to create enough space for Redhat, and everything was going smoothly. I put the first CD in, and rebooted the computer. Redhat’s setup program presented me with the different boot options (GUI, text, expert, etc.) and I chose GUI*. While loading the GUI, my keyboard dies and becomes completely useless for the rest of setup. I need the keyboard in order to complete setup, and also if I am going to, God forbid, USE this OS once it does get installed.

Does anyone know of any way to fix this conflict between Redhat and my keyboard? I’ve Googled, Yahooed, Altavistaed, and checked Redhat’s and Compaq’s support websites. Nada. Maybe you smart people will have better luck. Thank you in advance for anything you can do to help. :slight_smile:

*I have also tried the text installer, with similar results. This OS hates my keyboard.

Is it a usb or ps/2 keyboard?

If it’s usb, did it come with a little adapter to make it ps/2? You might want to try that. Also, with usb, you might need to go into the bios and turn on a setting like “use usb keyboard”.

Also, what selection are you using in the setup when it asks you what keyboard you have?

It’s a USB Keyboard, and it didn’t come with a PS/2 adapter. However, I DO have one that came with my mouse, would that work? I guess I’m not certain on the mechanics of changing a USB signal into something read by a PS/2 port. Anyways, I had tried that earlier with no success. Actually, it froze up the computer mid-boot, and I had to hit the power manually.

I’ve looked through my BIOS, but I’ll check again, perhaps I missed something obvious.

As for the selection, I’ve tried Compaq Internet Keyboard, I’ve tried every generic selection, and I’ve tried them with or without Deadkeys. U.S. English for the language.

Thanks, I hope this info helps.

The little adapters don’t convert USB signal to PS/2, they’re just adapters for equipment (like your mouse) that’s designed to be able to work with both, so I’m not suprised that didn’t work.

Can you type in things at the boot screen (where it gives you all the install options, like graphical, expert, etc)?

I susupect there are some boot params you can pass it to load the right usb modules, but I don’t know what those would be. You might want to look for information on installing linux on legacy free systems.

Okay, I’ve looked on a bunch of support websites, and evidently Compaq USB Keyboards just get shafted by Redhat 7.2. I’ll probably install using a friend’s PS/2 keyboard. I’m also think about going to look for a USB to PS/2 adapter, as that’s the recommended fix for this. Maybe if I got it installed I could tweak Linux so it would play well with the keyboard, but I’m not that experienced yet, so I’ll just opt for the easy fix, unless someone wants to walk me through THAT pita.

Oh, and I tried passing it different boot parameters and it still choked at the same spot. Having visited the forums, my biggest consolation is that I’m not the only one who has had this problem.

Thanks for all your help buckgully, it would seem that the only viable fix right now is hardware. Bummer.

If you’ve got a Compaq dial-up modem in your PC, you’ll get shafted as well. (I speak from experience here.) Linux doesn’t like Winmodems (which is what Compaq had put in my PC) and they’re almost totally useless with Linux. (There are a few drivers out there for some of them.) There’s been a number of people who’ve posted questions about Linux on the board, you might want to do a search for the threads to see what else you can expect. That being said, its a great OS, smooth, stable, and none of that annoying “Play-Skool” look that XP foists on people, and more software is appearing for it on an almost daily basis.

Well, thankfully I don’t use my dial-up modem anymore (I love my cable modem). If I did have to use it, I’d probably just boot to XP and do whatever needed the Internet, be it email/SDMB/etc.
As for the Play-Skool look of XP, I just go back to the regular way Windows used to look, the Classic view. It’s a little faster and not anywhere near as annoying. Down with unwarranted foisting!

Sweet love! Okay, I borrowed a friend’s PS/2 keyboard and installed Redhat 7.2 with that. Then, when I restarted the computer, it went through GRUB and recognized my USB keyboard. So now I’m completely set! In fact, I’m typing to you right now from Mozilla, inside X-Windows. Yee-haw!

Hehe I know next to nothing about Linux, even though its my main OS (Debian, though - I have a linuxfreak SO), but thanks to said SO, I actually get happy when I see people switching to this OS. (This post looks like an emergency signal…). And Mozilla is GREAT! I love the tabbed browsing :slight_smile:

(My SO just made the comment that “USB is kinda flaky in Linux, it’s not very well supported”)

It’s too late, but that was my contribution to this thread :slight_smile: