Router can ping, computer can't

A friend asked me to take a look at their computer which is having problems connecting to the Internet. It’s a RCA cable modem connected to a Linksys wireless router connected to a WinXP SP3 laptop. After some experimentation, I found:

  • Plugging the laptop directly into the cable modem results in an in Internet connection.
  • When the router is connected to the cable modem instead, the router can successfully ping Internet addresses.
  • When the computer is connected to the router, whether wired or wirelessly, there is no ping response from anything except for the router and itself.
  • The laptop can reach the router’s admin website (i.e.
  • The router’s admin website can remotely be accessed (I had a friend who’s a little more experienced with Linksys routers connect to it as a test).
  • Plugging the computer directly into my router results in an immediate Internet connection… but it’s a D-Link.

Any ideas why the laptop can’t reach the Internet when connected to the router, when the router itself can reach it?

I’m unclear on how the router is pinging things with no computer attached to it. What interface are you using to accomplish this? What model Linksys router?

Does he have a software firewall? Check to see if you’ve blocked the web browser from accessing the internet.

If you can ping a website like Yahoo or the Google, but you can’t view them with IE, he might have used his firewall to block IE.

The router’s admin page has a diagnostic tool that can ping out. I think it’s a Linksys WRT54G Wireless router, but I can’t verify that until she gets home from work.

Windows Security Center says that its firewall is enabled, but as I mentioned, it doesn’t interfere with surfing website when the laptop is connected directly to the modem or to my router.

Oh, one thing I forgot to mention is that I did a trace route to Step one was the router, after which it died. I guess that means that the router is actively blocking traffic?

Im guessing the router is not on your ISPs mac address whitelist. Call them to verify.

Or the gateway/subnet mask is wrong on the router. Where are the addresses coming from? Is the router set to do DHCP? Are the DHCP settings correct?

Thanks, I’ll do that. But if the router’s not on their whitelist, why would mine be? I have a different ISP than her.

The router is set to DHCP and it is getting the correct gateway/subnet info from the modem. When I plug the laptop into the cable modem, it’s the same settings.

>When I plug the laptop into the cable modem, it’s the same settings.

Then thats wrong. The laptop should be getting a local non-routable address and using the router as its defaut gateway, not the ISPs gateway which it cannot route to.

So if the domain is 192.168.1.x/ and the router is then the gateway needs to be not the ISPs gatway.

Edit: Crap, as I was typing this, posts 6 and 7 were posted. Looks like the actual cause of the problem is a bad gateway address. So I’ll delete my obviously wrong idea.

Similar symptoms at a friends place turned out to be the cable modem had the PC mac address cached instead of the router and needed to be flushed by powering down for 5 minutes, try this:

  1. Power down cable modem, router and pc
  2. Leave it off for 5 minutes so it can flush its mem
  3. Power up cable modem
  4. After it’s ready, power up wireless router
  5. power up computer

Also, id verify the router is actually routing. Make sure its not in gateway mode and that its set to do NAT.

When you ping out, are you pinging a url (say, or an ip ( if you didn’t know an outside address for testing). If you’re only testing urls it could be a DNS error, try checking the localhost file.

This may sound incredibly weird, why would it be a DNS error if it works when connected directly to the cable modem? Well, the same thing happened to me, and I’m not enough of a networking guru to figure it out, but it worked out that way.

Sorry, I think I gave the wrong impression :slight_smile: I was trying to say that the DHCP settings on the router when plugged into the modem matched the setting on the laptop when it is plugged into the modem. When the laptop is plugged into the router, the setting are appropriate, i.e. the default gateway becomes and the IP address is local.

I’d done that, but only for a minute or so. I’ll give it the full five minute treatment. If it helped your friend, I’m hoping that it helps here! Thanks.

A DNS problem was actually my first thought. I’ve tried both url and ip pings. I even tried pinging each DNS. No luck.

It was me at my friends trying to get it working for her. I was going down the road of static IP and hardcoding a DNS IP address into the router config when I found some site that mentioned the cable modem cache’s the MAC address of the first device that gets attached. 5 minutes later all was working.

Would cloning the modem’s MAC address resolve the cache problem?

Looks like your router and cable modem are using the same address (

I tried that and the multi-minute reset last night. It seemed the most likely solution, but sadly, it didn’t work. :frowning:

I’ve run into that issue before, but only when the modem had a built-in router. But I’ll give it a try tonight.

Have you tried using the reset button on the back of the router?

I have the same problem with my router. I can ping anything inside of my network and nothing outside. If i log in to the router, i can then go to the diags page and traceroute or ping anything outside. Restoring factory defaults resolves the problem temporarily and you have to reapply your settings manually. loading settings from backup seems to reapply the problem as well. It appears to be a known issue with the linksys wrt54g firmware Ver.4.21.1 ( ) I am looking for a different version of the firmware to resolve the problem.

Hope this helps.

Not sure how far you want to go with this, but if I was dealing with a cranky wrt54g, I would replace its firmware with dd-wrt (if the device was the correct version). Much better firmware IMO.

Not sure if I’d do this with a friend’s router, though. Hope you get the answer to your problem!

That was my solution exactly. So far so good. The only complaint i had with dd-wrt was that a reboot resets userid to ‘root’. password remains intact. Definitely not a deal breaker.