Router IP address problem

Not sure if this should be in the “computer questions” thread or not, but since it’s about a router I’ll put it here.

I’ve just got me a brand-new router (Wireless-G compact), courtesy of the amazingly kind and helpful people at Linksys customer support, of whom I shall write more in future.

I’m running Windows 2000, and my TCP/IP settings are set to DHCP-enabled.

The default local IP address for the router is 192.168.1.1, which just so happens to be the default address for my ADSL modem. The computer can talk to either device individually, but clearly there’s a conflict when they’re connected together. I ran the router’s settings once to see what would happen, and it claimed I needed a password to get to the internet, which I don’t.

So in my very limited knowledge of networking, I figured that I should just change the IP address of one of the devices, and everything would work. Seems not.

Using the web interface on either device to change its local IP address (I tried 192.168.2.1) essentially disables my computer’s ability to see it - and I can no longer get to the web interface to change it back. I have had to hard-reset the entire device to its factory settings to talk to it again.

I’m not a computer dunce, but I am where it comes to networking. Any ideas what I should do?

With IP networking, you have two basic items of info: the IP Address itself, which must be unique, and the Subnet Mask, which determines in which IP network you reside. The Default Gateway is only needed when you’re trying to talk beyond the local network.

Chances are, you’ve got a Subnet Mask of 255.255.255.0. Those 255s (actually, it’s the 1s in the binary form) tell the computer what’s local and what’s not. So if you have your router as 192.168.1.1 with a SM of 255.255.255.0 and the modem on 192.168.2.1 with a SM of 255.255.255.0, you’ve told them they’re on different networks.

So you need to either change the Subnet Mask to 255.255.0.0, or give both devices IP addresses on the same IP network - say 192.168.1.1 and 192.168.1.250.

Instead of 192.168.2.1, try 192.168.1.2. There’s another setting in your network called a “subnet mask”, which by default is 255.255.255.0. This means all the devices in your network will have the same first three identifiers and the last can vary from 0 to 255. I wouldn’t advise playing around with this unless you plan to put more than 255 devices on your local network.

I don’t quite understand your password-related problem. If it asks for a password when you try to go to 192.168.1.1, it’s to let you access the router’s internal settings, not the internet. By default on Linksys routers (as far as I know), the access is to leave the username blank and type ADMIN for the password. On a wireless router, you should change this as soon as possible to keep your neighbors from accessing and screwing with your network settings.

Further, I don’t understand why your ADSL modem has 192.168.1.1 as an address at all. It should have some completely different number, assigned by your internet provider, and you should be able to see this number when you access your router settings under a label like “WAN IP Address” or “Internet IP Address”. Do you have the modem plugged into the “Internet/WAN” port of the router? If not, it’s possible the router is treating the modem like any other device on your LAN and trying to assign it a local-network (i.e. 192.168.1.x) address, which creates a problem if the modem insists on getting 192.168.1.1, i.e. the first available address.

Thanks for your advice so far.

Thanks Quartz, that’s one bit of ignorance fought: I didn’t know what a Subnet Mask was. Now I (sort of) do, and I’ve been able to reassign the router to 192.168.1.150 and not lose touch with it.

Bryan, I checked, and the modem does also have a network-assigned IP address, but has a NAT IP address of 192.168.1.1, because, I presume, it acts as a DHCP server on my LAN. I suspect that the router is also trying to act as a DHCP server too, which might be the problem.

I can connect to the modem via USB as well as network (the ADSL modem assigns itself 192.168.1.2 when I connect via USB), so I did try to have the ethernet going from the modem (1.1) to the router (1.150) and then feeding that via ethernet to the computer (1.5), while simultaneously connected via USB (1.2), but that went completely tits up.

Mystified so I am.

OK, if I understand your setup right you currently are connected like the following:

ADSL modem connected to outside world and internal network.
Computer connected to internal network.
New router connected to internal network, no external link.

I would suggest the following configuration:

ADSL modem connected to the ouside world, and to the WAN port on the new router.
Computer connected to the internal port of the new router.
New router will need to be configured to have an internal address of 192.168.x.y where x = 2-255, and y=1-254.

Reboot all devices, and the ADSL modem will get an external address from your provider, and will auto set its internal address to 192.168.1.1. The new router will get an address for the WAN port from the ADSL modem, and will be 192.168.1.x with x being 2 - 254. New router will also have the assigned address from above for an internal address. Your computer should get an address on the same subnet that the router internal address is on. So if you set the internal address to 192.168.2.1 the computer would get 192.168.2.x where x is 2-254.

Using this setup will get rid of any DHCP conflicts between the two devices. Also I have never setup a Linksys router where the internet connection was connected to the internal port. Not sure if wireless devices will be able to connect to the internet that way. The downside is that it is an extra hop to the internet (link between the router and the ADSL modem). Unless you have a really fast internet connection you won’t notice.

-Otanx

Otanx, thanks for your post. I suspect my initial posts must have been a trifle confusing, since I mentioned both how it is meant to be set up, and how I’d tried to troubleshoot.

The setup you described is the way I want it to be configured, and the initial manner in which I connected it - which doesn’t work and is the reason for this thread.

When I hook it up modem => router => computer, the computer can only see the router. When I run the “setup wizard” and all that, the router claims not to be able to see the internet, or it says “You need a username and password for this internet connection” - which I don’t. Furthermore I can’t see the modem settings via my browser, and nor can I ping the modem.

This happens if I leave the router with its default settings (in which it has an IP clash and claims to be acting as a DHCP server), or if I give the router a fixed IP address, numbered to avoid conflicts. There seems to be no setting by which I can tell the router to get its IP address from a DHCP server itself.

Invariably you always need a username and password, but you will only need it once since the router or modem, depending on the model, will save the username and password and do the login for you whenever the modem or router initially queries the ISP at powerup. Part of why you don’t need a password after rebooting is that the router is still holding the connection. This is part of why it sometimes takes up to a minute or so to aquire a connection after you shut off the modem or router but a connection is available immediately after a reboot of the computer.

I really don’t recall ever having a username/password. I have also completely hard-reset my ADSL modem several times and have still been able to get on the internet. My modem is one of these, and there’s no username/password dialog in the web interface. I suspect I don’t have a username/password because I buy my broadband from the phone company, so it’s tied to my 'phone number.

Anway, why should the router need the username/password, if that’s already being provided to the broadband service via the modem? Why can’t it just accept incoming data from the modem, as my computer does, and deliver it on to the computer? :confused:

Strange, that is, Jjimm.

I had initially a very similar ADSL modem from the same ISP/phone company and had to input a username and password initially, after which the modem remembered it.
I replaced it with an ADSL router that had to be fed the same information for first use, which was also retained through power cycling but needs to be re-entered on hard resets.

And can it see our Xbox 360? can it bugger.

Complete WAG in your instance, but my similar setup required me to set up the router as if it were my computer. That is, your ISP is set up to recognize your PC and allow it access to the internet through your modem. Your router is not recognized by the ISP as the account holder, so it asks for your username and password. If you set the router to have the same identification as your PC, it should work. Your ISP can probably tell you how to do this or it may be in their FAQ somewhere on their website.

When you had it connected ADSL - Router - Computer. You had the internal address on the Router set to 192.168.2.1? Make sure you set the “LAN Address” on the router to 2.1 not the WAN address. WAN should be set for DHCP. After you do that go to Start - Run on the computer, and run cmd (assuming XP) Type “ipconfig /release” then “ipconfig /renew”. After that do a ipconfig, and it should show an IP address of 192.168.2.x where x is a number between 2 and 254 (think it will be 2).

At that point you should be able to open IE and go to 192.168.2.1. That will give you the router config screen. If that works then try to go to 192.168.1.1, and you should be able to see the modem setup screen. If that works you should be able to view a page on the internet.

Now for some troubleshooting. If after changing the router IP address to 192.168.2.1 and doing the /renew you can’t get to it try the following.

  1. from the cmd prompt type “ping 127.0.0.1” should get back 4 replies.
  2. ping the address you got from the ipconfig command (should be 192.168.2.2) should get 4 replies
  3. type “ping 192.168.2.1” should get 4 replies.

If that dosen’t work post which step failed.

If you can get to the router config page, but not the modem config page try the following:

  1. in the router config screen there should be a page for MAC address clone. On the computer type “ipconfig /all” and look for a Physical Address. Will be 6 sets of 2 characters. Enter that number on the MAC address clone page, and save. Reboot the router.

Also I found this page which should help. The only difference in their example to the configuration I suggested was they suggest going to 192.168.0.1 instead of 192.168.2.1

-Otanx

Wahey! Tanx, Otanx! It’s working, and now my wife is checking her email in the garden.

I followed the Linksys instructions you linked to, and bada bing. I suspect I was part of the way there, but didn’t have the whole thing about powering down, and which order to restart all the components. Fantastic. Still don’t really understand about the subnet mask, since from earlier statements it would seem to preclude the new IP address, but what the hell, it works. Thanks to everyone for their help.

And now to the story of those brilliant people at Linksys.

I was in New York last October with some money to burn, so amongst other things, I bought the router and a wireless PCMCIA card.

Being located in the UK, I threw away the 110V adapter, thinking “well I can just buy a 240V one when I get to the UK” since it took DC via the adapter. This was my folly.

When I got back to the UK, I went to my local Linksys retailer, and they said “we don’t sell adapters”. Called a few other agents, tried online, nothing. I bought two power adapters with approximately similar ratings, but the router was very particular, and would work for about 30 seconds before dying.

So I called Linksys customer support, located in the Netherlands. I explained my problem, and told them I’d like to buy a 240V power supply. “We don’t sell them” was the reply. I asked if they had them in stock, and they said yes, they did, but they couldn’t sell them to me.

He asked where I bought it. I told him, and he said that since I bought it in the US, European customer support couldn’t help me - unless I had the receipt, which I had, of course, lost.

For want of a nail… I wasn’t prepared to buy another router, as I had a perfectly good one sitting there already, and they’re much more expensive over here. I said “look, you’ve got the power supplies, I’ve got money, I’m prepared to pay you for one.” Then I said the phrase that I think got some action:

“Can you see that my interaction with Linksys is becoming a source of frustration for me?”

The guy put me on hold while he spoke to his supervisor. Then he came back and said “OK, if you send us the unit back, we’ll send you a brand-new boxed one, with the power adapter.” “How much?” I asked. “It won’t cost you anything.”

They mailed me a UPS address label, and within a week I had the new router, with power supply, delivered by overnight courier, all at the expense of Linksys. On an American unit, with no receipt. That’s what I call customer service.

I would like to hang my head in shame and retract my earlier statement on the matter.

No problem. Glad I could help. Subnetting does get very complicated, but here is a quick run down.

You have an IP address 192.168.1.42, and a subnet mask 255.255.255.0, you also have a default gateway 192.168.1.1. What the subnet mask does is tell the computer what part of the IP address identifies the network, and what part identifies the computer on that network. If the number is 255 then that part of the address identifies the network, and a 0 is for the host part. The default gateway is the IP address of the router on the network. If data has to be sent to another network it will be sent to the defalut gateway.

Using the example above you are on network 192.168.1. You are on system 42. Now why does your system need to know this? If you are sending data to another computer on the same LAN(say 192.168.1.7) then the computer sends the data straight to the other system. If you are sending data to another network (say 192.168.53.7) then your system will recognize that 192.168.53 is a different network than 192.168.1 and will send the data to the default gatway so it can forward the data to the correct network.

Your network has 3 different networks. You have the ISP connection on the outside of the ADSL modem, then you have the network between the ADSL modem, and the router (the 192.168.1.0 network), and finally you have the internal network on the inside of the router (192.168.2.0, or 192.168.0.0 whatever you set).

Hope that was a little clearer than mud.

-Otanx

I kind of get it, but I don’t understand why the two components cannot simply have different IP addresses on the same network. And why I didn’t have to alter the subnet mask as mentioned in Quartz’s first post to set up the router a 192.168.0.1, which it now is.

Which two components are you talking about?

The ADSL modem is on two networks (your ISP, and the network between it and the wireless router)

The wireless router is on two networks (Between it and the ADSL modem, and the internal network)

The computer is only on the internal network.

Even tho the ADSL and the Router are the only two devices on the network between them it is still a seperate network. You could stick a hub or switch between them, and connect other computers.

-Otanx