No internet without router. Why?

I’ve successfully stumped tech support yet again. So now I turn to the collective genius of this board, to do what some poor gal in India, and some poor guy in Maine, could not. Again.

Here’s the problem: I have an ADSL modem, which I’ve used problem free on my desktop for a few years. About a year ago, I bought a Linksys wireless broadband router for the laptop. Phone line goes into ADSL modem, ethernet cable comes out, and into router, and another ethernet cable goes to computer. Now, I’m trying to temporarily bypass the router, and go back to the original setup of line – modem – computer.** Not working.**

Go back through router, working. Take out router, not working. Etc. Etc.

Obviously, after going through 2 tech supports, we’ve tried all the usual stuff. (Linksys gave up and said call the ISP. The ISP gave up and put me down for Level 2 support call back service – in a few days. Don’t I feel special.

Does anyone have any idea why this could be happening? Both modem and router appear to be working normally. I have 2 LAN adapters, both are working. I took the card out and opted for the integrated one. Nothing. Anyone have an idea?

You caught me at a bad time, I think I have food poisoning, but here is an educated guess from a tech: did your service uses a static IP? It could be that after you installed the linksys, the linksys installation did set your TCP/IP to “obtain an automatic IP” you will need to set the right IP in your network settings to connect again to the ISP.

Beware that some DSL modems are routers too, so you should not add another to the network.

Yikes, **GIGObuster[/b! Hope you recover swiftly! I got a touch of flu, myself…

Anyway, my guess is that at least one of your ethernet cables is a crossover cable. Try swapping it out with the others and see of that makes a difference.

Q.E.D., I just swapped out the cables - no joy.

GIGObuster, firstly, my condolences. There’s isn’t much in life that hurts quite as much as food poisoning. Get well quick!

As for your comments - yes I believe my ISP has static IP. When I check the TCP/IP properties, the settings are indeed set for “Obtain an IP address automatically”. So I changed them to manual, and input the numbers I got from “Network Connection Details” under “Local Area Connection Status”, and still nothing. (FTR - the numbers I got are with the router installed - if that makes a difference) Is there more to it than that? The tech rep guy hinted that it’s not as simple as that, although I didn’t really push the issue, as I’m no rocket surgeon when it comes to these kinds of things.

Why wouldn’t the ISP tech rep just give me the right settings to input?

Because he has no clue? Trust me, this is common.

It sounds to me like your ISP has registered the MAC address of the router for service, and is denying connections directly to your NIC, because the MAC address doesn’t match.

But this seems like something your tech support monkey should cotton onto pretty quickly, so maybe not.

Scruloose you should try then the ipconfig test:

But do it without the router, if you get a gateway number that is similar to the IP address, then there is a connection to the modem. Then, software could be the cause of not being connected.

If there is no gateway number you may have a more serious problem.

The ISP tech rep had me do those IPCONFIG tests. Just for fits and shiggles, I ran them again - same results. The ipconfig reports:
Connection Specific DNS Suffix :
Autoconfiguration IP Adress : (numbers similiar, but not the same as IP when online)
Subnet Mask : (numbers similiar, but not the same as when online)
Default Gateway :

Then, I do the ipconfig /release. Then ipconfig /renew, and I get this:
An error occurred while renewing interface Local Area Conection: Unable to contact your DHCP server. Request has timed out.

So - sounds like a problem, eh?

You need to put in the numbers that the router had, not the numbers that your computer had while behind the router.


From my personal experience, I know that to have a PC set up with a DSL connection, I had to install their software. This is so that your login information can be sent to the server. I have since purchased a router that logs into the account for me. I would suggest, with the router hooked up, see if you can locate the IP that it is connecting to then connect the PC up alone and see if you can Ping it. This can be done from a command prompt. If you are able to ping it, then the issue is probably that you are connected but because the server does not receive the logini information, it is not allowing you to connect.

If you’re running on a dynamic IP connection like the great majority of DSL users, the router is doing the grunt work of sorting out the ever-changing IP (my previous provider would often change the IP every three to four hours) and acting as what’s known as a DHCP server for your laptop.

FWIW, Windows XP (Pro version, at least) has a built-in DHCP service that’s clever enough to rapidly and automatically snuffle out the relevant settings if it’s directly connected to a DSL modem. Plug it back into the router, and it re-snuffles the router settings and off you go. (I only know this as I had to do some testing a while ago to ferret out what turned out to be a bad cable)

But, why would you want to run without a router? Aside from letting you easily share a broadband line, they do give some security by hiding your PC’s identity behind NAT, or network address translation.

With the error message you are getting, your PC is looking for a dynamic IP, not static. DHPC stands for Dynamic Host/Client Protocal. It means that your PC is asking for an IP addy from the service and is not getting a response. If your ISP does a static IP you need to go into the network control panel and set it.

You set it in
Start -> settings -> control panel -> network, highlight the tcp/ip adapter then hit properties. At least for Win98. It should be about the same path for Win XP/ME. Not sure about 2000. In the CP there is an option for “Specify an IP address”.

You’ll need other info as well. You should* be able to get that from your service provider.


*Good luck.

Did you get the whacko subnet ip address from your DCHP server? It basically means that the computer can’t find a DCHP server.

If you get a solution, let me know. My only solution was to use static ip and DNS servers, when I would really prefer to use DCHP.

odaran, there is no software that I’m aware of. I wasn’t here when they installed the DSL, so I don’t really know for sure. But I’ve been all over the machine and can’t find anything that looks like software for this connection.

gotpasswords, it’s XP Home. I’m actually just trying to troubleshoot a multi-player game issue I’m having. I’m just trying to temporarily bypass the wireless router to eliminate that as a cause of my gaming woes. I realize it’s a longshot that the router is causing it, but to have that one item remaining unverified is kinda of frustrating.

sleestak - I tried the manual input, but probably with the wrong numbers. I think I’m gonna have to wait for that Level 2 support.
[sub]Great username, BTW. Did you know that Bad Boy Bill Laimbeer was an original sleestak?[/sub]

Tabby_Cat, yup, that’s exactly what I get. Which, as it turns out, is way different than my current IP. I’ll keep you advised.

Whoops - let me correct that. Those are number I get when I’m online, throught the router. When I do the ipconfig from the command promt without the router, I get and

When on the router, I get,

I’m a tech reps worst nightmare. I know just enough to really screw things up, but not enough to know how I did it.

Ok, this is a Windows auto-configuration address. Basically, it assigns this to the network card when it can’t find a DHCP server, and you haven’t given it a static address. So your network card can’t find a DHCP server at this point.

That address is a private IP address, given to you by your router for your private network. The router has two IP’s, one private and one public. The private one can’t work out on the Internet.

The problem is more than likely the MAC address from your network card. I have a cable connection at home. The cable modem recoginizes the first MAC address that connects to it when it turns on. Every network card has a MAC address, and it’s not something you can changeon your network card. Most home routers have the ability to clone a network card’s MAC address. When I connected my broadband router, it would not work through the cable modem until I cloned the MAC address of the network card.

Best guess? As stated above, your DSL modem is expecting to be connected to a card/router with a different MAC address than you’re hitting it with. Tech support will not always be able to guess this, Comcast still denies to me that they do MAC registration. Try completely resetting the DSL modem. Unplug it, for at least 45 seconds. Then power it back up, and let it reconnect to the DSL service. At that point, plug your computer back into the modem. Then try to get a DHCP address.


I’ve got a few suggestions if you want to try them. First, are you running XP service pack 2? If so, try disabling the firewall in Windows XP rather than bypassing your router’s firewall. (Also, if you want to bypass the router’s firewall without messing around and hooking up to the ADSL modem directly, why not put your computer in the router’s DMZ temporarily to see if your gaming problems clear up?) Second, I’m not familiar with Linksys routers, but does yours have a “gaming mode” setup which will allow traffic from popular internet games to pass through the firewall? If so, enable the “gaming mode” feature and see what happens. Finally, have you checked the Linksys support site to see if there are any firmware updates for your router? They might have a patch which could solve the problems you’re experiencing.

At any rate, I wouldn’t try going without a firewall for very long. I hope you can get this resolved without a lot of headaches.

Good luck!

OK, I’m going to assume tech support didn’t do anything and start from the begining. I have had 2 linksys routers (SX41 and SR41). You probably have one of these (I’m guessing the BEFSX41).

So, assume you connected things properly (WAN plug into the modem, Port 1 into your computer using straight cables (I believe).

First, logging into the router you should have been told what kind of connection to use. I’m not at home so I’m recalling from my poor memory but there are several ways to connect to the internet. I personally have a host and domain name filled and DHCP enabled.

Next, remove all network settings in Windows. Set it to DHCP. Restart.

Go back into the router. Go to “status” and see if your router has been given an IP. It should say “WAN” with an IP. If not try clicking DHCP Release and Renew.

If you need to clone the MAC address click on the “MAC Address Clone” tab. Click the second radio button (it self detects the MAC address of your computer) and apply those chance. Try getting an IP in the Status tab again.

And if that doesn’t work, your Router/Computer/ISP is cursed.

OK, some people have misread the OP. His connection works fine through the router, it’s without the router that the connection doesn’t work.

Here’s what you do, in short sentences.

  1. Hook up the router, so everything’s working.
  2. Log into the router.
  3. Look at how it obtains an IP address. Main choices are dynamic (DHCP), static (manually set an ip address) and PPPoE.

If you’re router is set to DHCP, then I have no idea what’s wrong. But again, your router is going to have two ip addresses, one public, one private. If the “public” one is ALSO 192.XXX.XXX.XXX, then you have more intelligence in your DSL modem, and we may have to configure something there. Also, and this is a silly question, when you plug your network cable into the DSL modem, do you get link?

If it’s set to “static”, then write down it’s ip address, default gateway, and netmask, and configure your PC with those values, then take out the router and try again.

If it’s set to PPPoE, then you need to run special software on your PC to log into your ISP and establish your connection.


The ISP **Level 2 ** support guy called, and he get’s get my nod for tech rep of the year award. He seemed to be extremely sharp. Anyway, simply put, the correct IP numbers and DNS numbers had to input manually at the TCP/IP properties box. Why the first tech rep guy didn’t do this is beyond anyone’s guess. (see post #5, I guess)

This, however, shouldn’t be the case, as per him. And he is suspecting a partial corruption of the TCP/IP [sub]something something[/sub]. If he had to guess, he says it’s possibly related to the fact that I just changed out my mobo/processor under Windows XP, and I didn’t have to do a full re-install.

Then he goes on to try and troubleshoot my gaming issue. We must of chewed the fat for about 40 minutes after the problem was fixed. We need a thumbs up smiley.

Anyway - I log on to the game - and guess what? It works! I can’t friggin believe it - that did it! I should have known, because solutions to problems always seem to be: follow the path of most resistance.