Slowing down my CPU. Waaaaaayyyyy down.

While digging through some old floppies, I found a PC game that was written for the ancient 8088 processor. When I try to run it on my current (and soon to be replaced) 166Mhz Pentium, it’s ends before I can even get a chance to make a move. Is there a SAFE way to slow my processor down so that I can play it? BTW, it runs under DOS, of course.

Is there a Turbo button on your machine?

Those old games did not use the computer real time clock, they relied on their own instruction cycles for timing… Who would have thought then computers would get faster and multitask? :slight_smile:

I am trying to think what the soolution could be…

If you present computer is 35 times faster than the original but the OS gives that program only 1/35th of the time, then I guess it might work.

Now, I believe WIN9X has some way of alloting task priorities so I would look in that direction. If no one can help you I’ll try to look into it for you.

There’s a program called Moslo that is really simple to use, and should work for that game. I use it to slow down my computer to run old DOS games as well, and it seems to work pretty well.

Just go to almost any search engine and type “moslo”. You should come up with sites that have it for download.

My first computer, Leading Edge Model ‘D’, had a switch on the back that allowed you to switch between 4.77 & 7.14 Mhz. Oooooohhhhh, the neck breaking speed! I built my second computer (a 386) and it had the same problem. The game ran too fast. My current computer does not have a “turbo” switch. I’ll look for that program. Thanks for the input.

Oh, and in case you are wondering, the game is called “Dr. Sleeptite and the Nightmare Factory.” It’s a maze type game in which you must clear each screen before moving to the next level. Did I mention the killer pillows?

Emulate!

Let’s see, you’ve got a lot of cycles to burn before your current box starts behaving like a 4.7 MHz 8088…

a) Download vMac, a Mac Plus emulator for various platforms, including of course the PC running Windows. Snag a Mac Plus ROM (perhaps by indicating to me that you’d like me to see if I can arrange that) and download a fully legal and free copy of System 7.

b) Via careful shopping on the obsolete software circuit, buy and install a copy of Insignia Solution’s Entry-Level SoftPC, a PC emulator that would let you run DOS programs on a Mac. It would run on on a Plus if you had a hard drive. Install it on the virtual hard drive that you create for vMac.

c) Install your game on the SoftPC hard disk that exists as a file within your vMac hard drive.

d) The speed of even a Pentium III emulating a Mac Plus emulating a PC ought to approximate an IBM-XT.

Just start running Seti@home before you play the game. That oughtta slow it down enough.

:smiley:

I found Moslo, downloaded it, and it didn’t work! If I ran the program at warp speed and then ran it with Moslo, it locks up the computer. If I ran it with Mosolo first, the screen would go blank and lock up the computer.

I know someone who has an old Model D. I’m gonna snag it and see if I can find an RGB monitor.

try download.com they should have some slow-ing programs.

I never could get them to do much though.

You can try playing around with your memory settings in Windows. This involves messing around with .pif files, which tell windows how to treat your program.

I’m doing this from memory so it might be off. It should work in Windows 98 at least, because that’s what I have.

  1. Open My Computer.
  2. Locate the program’s executable. If you want, you can make a shortcut for it and put it on the desktop.
  3. Right click on the .exe or on the shortcut (should work for both) and select “properties.”
  4. There should be a “memory” tab in the following box (I know there is for Win 98, not sure about Win 95). Select it.
  5. See the “expanded (EMS)” and “extended (XMS)” memory options? They both should be on “auto”. Set them both to “none.” This cuts off the program’s ability to access anything beyond the original 640 k of memory.
  6. If the program is still too fast, try coming back to this screen and messing with the amount of “conventional memory” allocated to the program. Also look at the “initial environment” box and set it however you like (it determines where the program starts up).
  7. Click on the “screen” tab. Uncheck the “fast ROM emulation” and “dynamic memory allocation” boxes. This should slow things down more.
  8. Click OK.
  9. Start the program up and hopefully it should be much slower.

Like I said, I’m doing this from memory . . . every time I want to run an old DOS program I have to bumble around and relearn things. Hope it helps. Techs?
– Zilch

P.S. I take no responsibility if your computer starts displaying in Japanese. There’s no reason why it SHOULD start displaying Japanese, but I like to cover my bases.