Sony Vaio problem (won't boot)

(I searched for threads on this particular subject but didn’t find any – my apologies if this is redundant.)

My Sony Vaio (PCG-9L1L) laptop decided to stop working a few weeks ago. In the middle of use, the cursor disappeared (though I could still navigate using the Tab button), so I restarted it…and, well, it shut down but didn’t restart. Since then, only the power goes on and the CD-R drives clicks a bit, but nothing else – it doesn’t boot up.

I googled wildly for solutions and found a messageboard where several people weighed in to say that they had suffered a similar problem and solved it by removing the memory chip in the #2 slot in the base of the laptop (here is a link to one such thread).

I would like to try such a solution myself tonight, but are there any potential pitfalls I need to be aware of? Is memory chip slot #2 right next to something vital? Has anyone had similar booting problems with their Vaio and have found a different (DIY) solution?

Also: I’m posting this from a computer lab, so if I don’t respond for a while, I’m not ignoring the replies, I just don’t have access to a computer. :slight_smile:

I too had a Sony Vaio that wouldn’t start up one day, although it was a desktop and not a laptop. I tried everything I could think of, but nothing helped. Then I looked at the air vent and saw a metric asston of dust blocking the ports. So I took the computer down to my local gas station, opened the computer up and used their tire pump to blow all the dust out of the computer.

Worked like a champ afterward.

I have no idea if this will help you, nor do I know how feasible it is with a laptop, but thought I would throw it out there for ya

If I were inclined to use compressed air to blow dust out of my computer, I would use the little cans that you can purchase in computer stores. I’m not sure that I’d trust a [relatively] unregulated source like a gas station air compressor.

With regard to removing the second DIMM, the only caveats really are: 1) don’t force it in or out; if it won’t come out (or go back in), check that you’ve undone the clips and have the DIMM aligned properly, and 2) try not to touch any of the contacts on the DIMM; in theory, you could induce a current across a component that is sensitive to it and cause damage (it’s much more likely to happen with something more complex like a processor, but even then it’s not that common an occurrence).

Unregulated? It’s air.

It’s air designed to inflate car tires to 30+ PSI and bicycle tires to 70+ PSI. It’s also at a gas station, not renowned for their cleanliness. If you want to blow high pressure air into your PC in such an environment, go ahead. I wouldn’t recommend it, though.

Thanks for the replies!

I went ahead and removed the #2 memory chip: didn’t work. #1 memory chip: nope. Switched them, switched them back, took both out…nothing nothing nothing.

I’ll try the compressed air/cleaning of filthy, filthy dust out when I can.

Well, you don’t hold it right up against the thing, and I don’t think the air would be significantly contaminated, but whatever.

Air compressor tanks will collect moisture, and I have seen water literally spew out when the bleeder valve is opened. Not good for a computer.

Yes, I wouldn’t think spraying a visible stream of water into the computer would be a good thing :rolleyes:

If blowing dust out doesn’t work, are there any other avenues I could try myself?
(I’m a starving grad student and can’t afford more than $100 in repair…certainly not a new laptop).

Any beeps when you start it up? Does the screen display anything at all? Does it even lighten a bit?

Laptops do not get nearly as dirty as desktops (in my experience), and opening up the case is a lot trickier.

Do you see the harddrive light light up when you boot? Does it flash or anything?

Any chance its just a power issue? If you unplug the converter do all lights immediately go out?

Nope, no beeps. The power light goes on, the screen stays black, and the CD drive clicks around a little, but that’s it. The harddrive light does not go on, but the three lights next to it do (I’m afraid I don’t remember what they’re for – I’m not near my laptop now). If I leave it on for a few minutes, the fan starts going. But that’s it. I don’t think it’s a power issue because the same things happen (or rather, don’t happen) when I’m using the power cord plus battery, just battery, or just power cord.

(This laptop is a hand-me-down, and I don’t have any software for it, so I can’t boot from a disk or anything.)

This actually happened once before, several months ago, with all the symptoms described above. One day, though, I tried to turn it on and it worked. Booted up, nothing was lost, no error messages, everything was fine. It continued to work just fine for a few more months, until the day a few weeks ago when it didn’t. I keep turning it on and off every few days in the hopes that one day I will have another miracle and it will resurrect itself again, but no luck. (I’ve even tried prayer – so far, God has not yet responded. :slight_smile: )

I am taking it in to my college’s tech lab on Monday, but they can only look at it – they refer you to a local computer repair shop for any work that needs to be done, and like I said, I can’t afford that right now.

Ugh, I’m screwed, aren’t I?

Will it boot into the BIOS? Power up holding down F2 (might be a different key combo you can search on line).

If it will boot into BIOS there are diagnostic boot disks you can download for free and boot into, by changing the preferred boot order to the optical drive. I have had good sucess with a few different tools, such as the ultimate boot disk, but not recently, so there may be better tools out there. Maybe try to see what is available.

OK I just re-read the thread. If you’re not getting a boot splash screen at all, my suggestion probably will not help.

Are you sure it’s not a display problem? Have you tried connecting it to an external monitor (attach first while off, then power up)?

Although a display problem wouldn’t explain the cursor disappearing that first time …

I will second the idea of eliminating the possibility of it being a display problem. Attach an external monitor and try to boot up.

When you get it back from the lab, tell us what they say. One of us might be able to help.

I just ran across this problem with a slightly older Dell. Apparently the motherboard was built using defective capacitors. The network guy knew what to look for and showed them to me: several bulging caps. They had dried out and overheated, causing the tops to bulge out. Check the electrolytic caps (they look like an upright can) on your motherboard. The tops should be flat.


I’ll ask the tech lab to do this on Monday and will let you know the outcome.

I’ll check this, too.

Thanks for the suggestions!

Update: I took the laptop in to the tech lab on Monday. Apparently, they’re not allowed to open the computer up, so I couldn’t check the capacitors (though the helpful tech guy said that was definitely a possible culprit). Since I brought my own screwdriver, I opened up the bottom and had him check my harddrive – all the files are there and readable. He also connected the laptop to an external monitor to see if it was just the screen – that didn’t work, but I didn’t think it would since the harddrive light doesn’t ever turn on. He said it was probably the motherboard.

I actually have another laptop (a Mac Powerbook G4, also a hand-me-down – it’s sometimes nice being a charity case!) with a busted screen (though it works fine with an external monitor), so I’m going to get me a cheap monitor and use that one. We determined that you can buy an IGE to USB cable thingy for ~$16, and most of my important files on my PC are just Word documents, so I’m just going to transfer my data from my PC’s harddrive to my Mac (they should work on both platforms, right?).