Test poll 2

Typing my test post[poll type=multiple results=always min=1 max=2 chartType=bar]

  • It worked this time
  • Yay it worked a second time
    [/poll][poll name=poll2 type=multiple results=always min=1 max=2 chartType=bar]
  • Take 1
  • Take 2

Wait did this actually work? It certainly doesn’t look like it

Nope, didn’t work.

  • Almost heaven
  • West Virginia
  • Blue Ridge Mountains
  • Shenandoah River

0 voters

Try using the settings button.

Will @Sir_T-Cups get polls to work?

  • Reply hazy, try again
  • Ask again later
  • Better not tell you now

0 voters

Yeah that’s a big no, I don’t understand why it won’t show up. I put in the options and hit “generate poll” and it doesn’t work.

How do you get it to work in a reply?[poll type=multiple results=always min=1 max=2 chartType=bar]

  • Can I get this to work?
  • I’m guessing no
  • Here’s a third thing

WTF what am I doing wrong

Try this: instead of putting in the options first, click the gear thing and select “Build Poll,” then put in your options.

Also, put in a line break (return) before you go to insert a poll. In the above, you need a line break after “How do you get it to work in a reply?” Discourse doesn’t like not having a line break before certain commands.

This is what you get without the line break:[poll type=regular results=always chartType=bar]

  • Test one
  • Test two

And, this is what you get if you put in a line break:

  • Test one
  • Test two

0 voters

Maybe the line break thing is what’s getting me

  • Will this work?
  • Oh God it won’t work

0 voters

It was the line break! Thank you

You are most welcome!

So where’s your poll? All this build up has me sitting on the edge of my seat!

Here it is: