The AVI file that wouldn’t die

I have an AVI file (50meg) that would not get deleted or renamed due to being used by another program. No program is visibly holding it.

I tried playing other clips to release a possible hold, rebooting, logging in as a different user, looking at Services and Processes for possible clues, but of no avail.

Some potentially relevant info: it plays on RealOne but not Win Media Player, takes a while to load, was partially copied from a larger AVI file that is now gone.

I’m on Win XP Home. My C drive has 2 gig of available space.

Any suggestions?

If all else fails, boot into command prompt, remove any special attributes (ATTRIB -S -H -R filename) and delete.

BTW, you don’t have any P2P apps running in the background, do you ?

This has happened to me, for the following reason: if you have “Enable Web content in folders” set in your folder Options, the dumb Windows preview tries to run the AVI file in the preview pane on the left of the folder with an OCX call to Windows Media Player when you highlight it in the folder - and it takes a long time to initialize. Sometimes it crashes, too. If it is caused by this, the best thing to do is restart, open a different window, change your preferences, and then go to the file and delete it.

Thanks. No p2p open. Still having the problem - The “Enable Web content in folders” option is not in XP. Trying to find the equivalent.

  1. Run REGEDIT.
  3. Find key starting wit {87D62???-*}
  4. There should be subkey \InProcServer32
  5. Rename it (You can delete - but not recomended)
    e.g. \old.InProcServer32.old
  6. Close all apps and restart windows.
    That should work.

Real Player is quite invasive and often installs a background applet that hovers waiting for a real audio or video file to be played. If that applet is attached to this file somehow it might be locking it up. Try deactivating the applet. If that doesn’t work boot in safe mode and delete it that way.

This is what works for me:

Right click the file.
Click on properties.
Click on “Advanced”.
Uncheck the box that says “This file is ready for archiving”.

if you downloaded it with kazaa… fire up kazaa and delete it through kazaa’s “my files” or whatever its called. i had this problem too.

OR try this… get to anything with an “open” menu, and just find the avi file, right click on it and hit delete. it should work since xp isnt trying to load a preview, because its an “open” menu, not a normal folder.

You can also try to “cut” it and “paste” it into the trash.


Close everything - Start - Run - Browse to the file location and try deleting it from there. Actually this is similar to what Mr. Clever said above.

Those both work for me.

I have had nothing but problems and spyware with RealOne and I refuse to install it any more. With this type of problem I can generally solve it by starting in DOS mode and deleting it from the command line.

Thanks all. The one that worked–deleting through Kazaa. Something clever–it was.

Although the problem has been solved, I’ll share my experience with the same problem in case others might find it useful. Well, mine was probably caused by “Enable Web content in folders”, so maybe not exactly the same. The way I got around it was simply deleting it via a “del” command at a command prompt. Since I didn’t view it via explorer, Media Player was never called.