The screwiest router problem I've ever seen...

Hello Dopers,

So, this is a head scratcher for me, and I consider myself (relatively) tech competent…

Monday morning my wireless internet stopped working. My normal turning the modem on/off, router on/off wasn’t working. To make a long story short, several sweary and rambly calls to Bell sympatico later, I’ve managed to get it to work. When plugged DIRECTLY into my laptop, the internet works fine, full speed.

When plugged into my ROUTER, however, there is about a 30 second delay to get something to connect, if it connects at all. Furthermore, when I run a speedtest on it at http://speedtest.net, the download/upload speed is fine, but there is an enormous delay finding a server.

Plugged directly into the computer, the internet correctly finds an Ottawa server, google.ca offers me ‘local’ results from Ottawa. Plugged into the router, I’ve gotten stuff from Belleville, ON, and it tries connecting me to a speedtest server in Windsor, about a 9 hour drive from here.

This is so weird, and I’ve tried using the internet on several devices (iPad, phone, laptop, desktop) to rectify it. Nothing.

Can anyone offer me some advice on this??? :confused:

Hmm, can you check the DNS servers in both cases? Try

C:> ipconfig /all

in a command window. Sounds like the router may have oddly-configured resolvers.

Yep. Sounds like an IP settings issue on your router. It’s possible that its DHCP lease from your ISP expired and when it tried to get a new one, it got one from Belleville. And a 30 second wait indicates that the primary DNS is timing out.

If that sounds like gobbledegook, just reset your router. You’ll have to re-apply any special settings you had.

At one point, changing D H C P lease on my iPad fixed it.

I’ve flushed the router out–hell, I bought a new router–and it’s still plugging up on me when connected to the router…

Also, the router and the computer both seem to connect to the same two DNS addresses…

Try resetting the router to factory settings and see what happens.

Reset to Factory settings. Twice. Even bought a new router (same brand, though). Still doing this. Was working fine for over a year before yesterday.

As an added wrinkle, I brought it over to grandma’s house, who also have a DSL connection with a different ISP. I connected using my settings, got it to work fine with the direct connection, but NOT with the router, despite flushing to factory defaults and all that jazz…

What’s the brand and model of the router? It almost sounds like the “factory settings” are broken and trying to connect to something that no longer exists.

Have you tried changing your computer’s DNS to 8.8.8.8 and 8.8.4.4? These open DNS servers run by Google and I use it at home. If your router’s idea of DNS is broken, this should get you past it.

Assuming you’re running Windows XP, these commands will set it up. I think they’ll also work on 7:
ipconfig /flushdns
netsh int ip set dns “Local Area Connection” source=static addr=8.8.8.8
netsh int ip add dns “Local Area Connection” 8.8.4.4 index=2

You may need to adjust “Local Area Connection” to suit whatever the primary connection is called on your PC.

If that doesn’t help, you can go back to DHCP with this:
ipconfig /flushdns
netsh int ip set dns “Local Area Connection” source=dhcp
ipconfig /renew

I’m still at grandma’s, which forced me to try this on my iPad. I changed the DNS setting from 192.168.x.x (my router address) to 8.8.8.8. It’s…working!

What exactly is it doing? Besides being awesome, I mean.

Thanks a bunch. I’m registering for classes with very limited space tomorrow morning, and if my Internet wasn’t working, I’d probably be crying.

DNS is how your computer translates a domain name (“www.google.com”) into an actual computer address to connect to (“173.194.33.33”).

It sounds like whatever DNS server your ISP directed your router to use is overloaded, malfunctioning, or just shoddy. That’s actually a pretty common problem-- a lot of ISPs cheap-out on DNS.

You can use the Google DNS servers in this thread. Also, Level3 (I believe?) runs DNS servers in the range: 4.2.2.1 - 4.2.2.6 you can use, they are quick and reliable.

Added wrinkle of screwiness…changing the DNS settings on my router fixes NOTHING. Changing the DNS settings on the iPad itself (and presumably bypassing the router) has everything loading perfectly fine…

Exactly.

If you let the computer get its network info via DHCP, it will negotiate things with the router. If the router has gone off to an alternate universe, your PC will get bad info. Setting your computer for a “static” address bypasses the wonky router.

If someone cloned your cable ID and is using it in a another regional jurisdiction would it cause these sorts of odd problems?

If (per your note) a new router did not solve the problem I’d be looking at my cable modem and my ISP settings at this point.

This. Once you set your static DNS servers and reset the router, you’ll need to renew your client leases to pass along the new servers. One thing to note: some routers (like mine), will always include the (DHCP-, PPPoE-, etc.) negotiated servers in the local DHCP DNS parameters. So, for example, if you set two static DNS resolvers and the router picks up two from your ISP, it will configure local DHCP clients with all four. I suspect this is pretty rare (I have a oddball router), but something to be aware of.

Aside from the Google and L3 servers gotpasswords and Blakeyrat mentioned, OpenDNS runs resolvers at 208.67.222.222 and 208.67.220.220. Google’s are the easiest of the lot to remember, though :).

Thanks guys!

The problem was that, for whatever reason, that the router had changed the DHCP settings on its own. It kept changing my DNS servers to 0.0.0.0, but now it seems to be behaving. When I woke up the internet wasn’t working, and so I had to refresh the modem/router. Maybe it’s conking out whenever my laptop is renewing the lease. At any rate, I’m happy right now. Many thanks. :slight_smile:

yes, if there’s a 30-second delay when trying to connect to a (named) internet site, then the computer’s primary DNS is not responding in time, (or is incredibly slow) at which point the request times out and the server tries the secondary DNS.

However, I have seen where DNS order can get shuffled, and sometimes the DHCP’s secondary DNS will be used as the primary.

Most routers, if you make the router the DNS server (i.e.192.168.0.1 or whatever) it will act like one and pass on the request to its DNS servers from the Internet side.

My first thought was that the Bell DHCP was giving your router incorrect DNS information, so your router was timing out . But obviously, if it work with direct connect, that is not the case.

There is also a known DNS malware issue going on right now. You can check to see if it is affecting you by visiting this site:

http://www.dns-ok.ca/

I just found out about this now! (Sorry for the bump) I’m starting to think this was the issue.

I checked the website and I am in the clear. However, it said my DNS Address was not affected, which may simply be because I’d already switched over to Google!

I’m pretty sure the FBI just took the servers offline today so maybe, maybe not.

I’m a little surprised that no one has freaked out yet about getting their internet for several months through the FBI. I thought that was the kind of thing that makes privacy advocates heads explode.

What’s worse, the FBI or some random eastern european scumbag?