touchpad malfunction - windows 10

The touchpad on my notebook doesn’t function properly anymore. I have googled around and tried all the ‘just use this trick’ advice but no real progress. SDMB is my last resort, so please read the whole story before quickreplying …

Problems didn’t start immediately after installing Win10, but a few weeks maybe 2 months later at most. The only reason I reason I blame Win10 is that I quickly found out that a Win10 upgrade is a common cause of trouble in that area.

The original problem was that the touchpad became unresponsive to clicking, both the real buttons at the bottom and tapping the pad. MOving the pointer is no problem.

Luckily I’m so old that I more or less know how to use Windows without a mouse/touchpad and managed to roll back the driver. This helped a little: clicking by tapping the pad works again. But that’s it; the real buttons don’t work, which means I am deprived of right clicking, dragging etc.

I have tried every driver I could find (old or new, designed for Win7, 8, 10) but mostly this meant no more click functionality or in rare cases the current best: left click by tapping but no more.

Another thing I found out is that I shouldn’t hold my breath for any new update of firmware or windows to solve all my problems since my machine does not mention that it’s ‘Windows 10 ready’ or whatever such a sticker is supposed to say …

Basic technical info:

  • Dell Latitude 3340, Intel® Core™ i5
  • running Windows 10 (64bit)
  • maker of the touchpad is Alps (checked and double checked)

Please Obi Wan, you’re my only hope … my wife suggests simply I buy a new machine; I could afford that, but I refuse on the general principle that Microsoft does not dictate my behaviour as a consumer.

(On a side note: I’d also be very interested to learn a way to right click without a right click button - some guides include the instruction to ‘right click on the file and choose option X’)

Thanks in advance!

Dell systems usually have built-in diagnostics. Hit F12 as the computer is booting and select Diagnostics from the BIOS menu. One of the things that can be checked should be the mouse/trackpad/pointing stick. Does the problem happen there? If so, there is a hardware fault. If not, it’s probably a driver issue.

I can’t help with the driver problem, but shift-F10 acts like right click in some (but not all) contexts.