Unwanted search engine website loads every time Google Chrome is launched

I foolishly downloaded some software that now launches an unwanted search engine website every time I launch Google chrome.

I’ve poked around Google settings and even deleted this search engine but it still loads every time I launch Google Chrome.

Please help.

change your home page?

It’s likely its malware. RunMalwarebytes and delete anything it finds.

Maybe install IObit Uninstaller and get rid of the software and the search engine.

what operating system and version?

Thanks for the assist. I did try that to no avail.

Windows XP the highest service pack

Sorry guys for not having re-read the computer FAQ or following the directions. An up-to-date Norton anti-virus indicated the download was safe and it did not occur to me that this problem could be malware–shows what I know.

Currently running Malwarebytes and it has already found 43 incidences of malware.

Avoid the iobit stuff they love to bundle other crap.

Look for a program called adw cleaner…look for the download link at bleepingcomputer.com. remove whatever it finds then try to reset home page again.

the suggestion of malwarebytes is a good one but run tfc by oldtimer first, this will dump all temp folders reducing the number of files to scan…sometimes by several hundred thosand files.

if that fails…try looking for combofix. Also available @ bleepingcomputer.com.

I would have provided links but im on my phone

Have you simply checked in Add/Remove Programs if the “unwanted search engine” is listed there? You may just need to uninstall it.

Google the unwanted site name and read how other people have gotten rid of it. They are all different, and all require a different removal strategy.

Seconded. This kind of rubbish is often tricky to remove and Malwarebytes, although good, may by itself may insufficient.

Is it Lavasoft, by any chance?

I had the same issue when I installed AdAware. What a pain in the ass to get rid of. Add/Remove programs didn’t work. Instructions on forums didn’t do it. It was always launching update prompts after I deleted it manually or when I clicked on a file in whatever Windows Explorer is called in Windows 8 now (File Explorer, I guess).

I followed this strategy, which included several of the suggestions above and a few new ones.

It’s gone now–thanks guys!

If XP allows you, go back to an earlier date setup. That often removes imbedded scripts. I just ran into an annoying pop-up ad virus and eliminated it by stepping back in time. I tried various security software to no avail.

I see that the OP’s problem is solved, but I’m sharing this anyway – Should I Remove It? is a free download that (1) tells you what software/programs are on your computer, (2) describes what the programs do, and (3) will Uninstall for you without even having to go to the Control Panel. It also gives a percentage of users who’ve removed programs, in case you’re still not sure.

This is often a good way to remove viruses, but you need to know when you were infected. Also, malware often deletes all the backups, so it won’t work.

I had the exact same problem a month ago and I did the same thing. You have to identify the name of the application first, then remove it with Add/Remove programs.

These things get inserted when you install new software, and you need to know what they’re called in order to remove them.

AuntiePam, you have to be very careful downloading Should I remover it or it loads all sorts of crapware on your machine.

Free my ass.

These bastards are running a typical bait and switch: they run a scan that takes about 5 seconds, generate a list of problems and then tell you need to pay them to remove the problems.

Oh, and uninstalling the goddam thing looks like it’s going to be a real problem. Clicking “uninstall” in the control panel brings up a screen asking I want to allow the program you are trying to uninstall to make changes on my computer!!! Naturally I declined, and that cancelled the uninstall, apparently. I have now clinked allow changes to be made and am hoping the goddam thing goes away.

Oops- I got that allow changes box again. Clicked yes allow again. Piss me off.