Verizon DSL (& their lousy tech support), Free 10 MB Webspace, and URLs

So I’m finally getting around to making use of the free 10 MB of web space that comes with our DSL account.

Like the vast majority of ISP accounts, Verizon tosses in “personal web server space”, i.e., an FTP space to which you can upload files which in turn can be accesses by other folks’ browsers, and you can therefore operate your own web site (minus fancy cgi and minus unlimited traffic and all that, as you’d expect of free web space).

I have a similar arrangement with Earthlink which is my old telephone dialup ISP. With Earthlink, the ftp URL for uploading the files is a bit different from the http URL for viewing them – i.e., it isn’t just a matter of replacing “ftp” with “http”.

With Verizon, their incredibly badly written online help indicates that the http URL would take the form


and makes no mention of an ftp URL. I spent a couple hours on the phone with their “tech” “support” people trying to ferret out the ftp URL, and while this was happening I kept playing with the string in my ftp client, and finally accidentally discovered that the correct ftp URL was

ftp://members.bellatlantic/net// (yeah, a double-slash) using the DSL account username and password; or, to write it another way,

When I ftp to that, I get a window showing one alias to “bin” plus folders named “etc”, “dev”, “usr”, and “public_html”. The last one is the one to which I have writing privs (the others are empty and are read-only). In other words, all as expected.

So, using that, I uploaded a couple of files, created some directories, etc. (Just a few as test items). Having found it out on my own, I courteously discontinued my tech support call.

So then I go to my web browser and open up

and I do not get a directory listing; upon copying in an index file, I do not get the index page. I get an error message page from Verizon. Adding “/public_html” at the end doesn’t help. Adding the extra slash at the end of doesn’t help (I didn’t think it would).

So I call back and explain that I need the http URL. They “don’t support” the free web space feature, they just provide it, so tech support is not very cooperative, and, when cooperative, aren’t knowledgeable. Great – so I’ve got space I can ftp into, but can’t browse because no one knows the damn formula for translating the ftp URL to an HTTP URL on their server??

At this point I’ve decided that if there is an SDMB member who uses Verizon web space, I’ll get far better and faster tech support here, so…anyone know the http URL of a file in Verizon’s free web space, given the FTP URL?

I’m not a Verizon customer, but my friend is. He has his own website using their web server space. His URL, though, is different than the one you found. His is Also, for his FTP URL, it is, rather than the other one. You might have better luck with these URLs.

Try Usually, just using http://blahblah/~username will open index.htm or index.html in the public_html directory, but sometimes you need to explicitly type out the file name. You’ll never use the public_html directory in the web address.

The url should be , but it won’t display the directory, so you must point to the exact name of the file, i.e. . If you have already tried this, then I don’t know what the problem is.

BTW, I just ftp to , no prefix, and use my DSL username and password and it works fine.

I guess the first thing to do here is to thank you for getting me to get off my butt and trying this <g>. I have had a Verizon DL account for about a year now, but to date had never gotten around to taking advantage of its web page. After reading your message, I decided to try. I had a slightly different experience than you did, but the good news is that I ended up with a customized home page.

The first thing I had to do was to activate my existing DSL account for web access (which apparently you did as well, as you could see your FTP directories). I activated my account automagically via Verizon’s web pages rather than by calling anyone. (Helpful hint to those who do the same: just because that page claims that your account has been set up doesn’t mean it has. It was another ten minutes or so before things began working for me.)

Then I was able to FTP to my account page using the sequence (Actually, I think I used and the browser interface then transmorgified it to the first address). I saw the same folders that you did, but inside the “public_html” folder there was already a file called “welcome.html” containing some generic text. When I tried accessing my web page via the contents of that “welcome.html” file were displayed.

I modified that file (by downloading it using the commandline FTP command, editing it with notepad, and re-uploading it, as I don’t know ow to accomplish that sequence using my web browser), and sure enough the new contents appeared in my browser the next time I accessed my home page.

So the bottom line is, you might try generating a home page called “welcome.tml”.

AARRGGHH!!! Make that “welcome.html”.

Thanks, everyone!

Links that I had tried that did not initially work suddenly started working and I’m as confused as ever.

It does appear that they somehow prevent an URL that goes to no particular file from displaying the contents of the referenced folder. But on my 16th attempt or thereabout to load

(along with a half-dozen other variants and files I’d placed in the folder), I saw “ASCII” come up as a window title instead of •No Title• or “Error - Not Found” and sure enough there it was.

Most weird.

I have Verizon DSL and also use their personal web page service (mostly just for my eBay pics). I use a program called FTP Explorer rather then IE for ftp. It uses a simple GUI for easy drag and drop file transfers and its free!. Download it here.

Howdy, Hail Ants!

I’m on a Mac :slight_smile:
I use NetFinder, which is a drag-and-drop FTP client on the Macintosh. I also keep Fetch around because it’s a good old dog and served me well for many years.

Either way, though, my problems were not with FTP’ing the files. In the beginning, I lacked the necessary FTP URL (without which no FTP client is gonna do you a hell of a lot of good); then, for inning #2, I lacked the proper HTML syntax for accessing those same files from a web browser (or linking to them from another web page, etc), which has no bearing on what FTP client one uses.