Virtiual Dub help ...

I have some video I took with my Fuji F10 that I want to post on ‘Youtube’ for my family and friends to see. It is too big and they won’t allow that size upload.

I have down loaded the free ‘Virtual dub’ and read all I can find on it and tried a zillion combinations and I can’t get my video to lesson quality, lose some bits or bytes or what ever to make it watchable and small enough to be under the limit. I care not about audio, just want to get the video ‘processed’ in some manner.

I am on a Win - 98 box and a satellite broadband.

Any place or advice or help or whatever, a ‘walk’ through, something… All the kids can do it but this old man can’t figure it out…


Open the raw video.

Go to Video > Compression…

A window will pop up showing all the codecs you have installed. Select the one you want, let’s say XviD MPEG-4, and click the Configure button. Then you can change the compression level to whatever you like.

Afterwards, File > Save as AVI… and save the compressed video.
I think YouTube requires a specific kind of compression and resolution, but I don’t know anything about that. I’m sure it says somewhere.

Looking around their help section, I see it’s not a requirement, but they do recommend 320x240 and some form of MPEG-4 compression.

Incidentally, to resize the video:

Go to Video > Filters

Click Add…

A window pops up showing the installed filters. Click “resize”, then OK

Another window pops up. Enter the new width, new height, and resizing method. Scaling down, apart from nearest neighbor, it doesn’t really matter which you choose. Should you ever need to go up, generally stick with Lanczos. Click OK.

Click OK.

The filter’s added, you’ll see the change in the output pane.
If your goal is to reduce the file size, there are two other things you can do besides greater compression:
You can reduce the frame rate. Go Video > Frame Rate.

Check Convert to fps, then type in a number smaller than your current fps (probably 29.97).

Click OK.

You can reduce the file size this way, but the slower the frame rate, the more choppy the video.

You can make the file easier to compress by smoothing it. Most compressions work by only recording the information that changes between frames. If you minimize the motion in your videos, you can greatly increase their compressibility without sacrificing detail. There’s no single way to do this and it takes a lot of playing around to get the results you want–and maybe more time than you’re looking to spend just for YouTube.

The smoothing filters that come with VirtualDub are pretty basic and not of much use, but you can try them out. “Smoother” attempts smooth out the tone within frames without blurring the edges (stress on “attempts”). “Temporal smoother” takes each frame and blurs it a bit with a number of previous frames to smooth out subtle changes in tones (it also makes ghost images on everything moving quicker than a snail’s pace).

Using just those, don’t expect miracles in terms of image quality. You’ll want a good third-party adaptive smoothing filter if that’s a real concern.

It’s been awhile since I’ve used VirtualDub regularly so I’ll leave the specifics to Dusty, but I did want to address the above comment.

Is it that your video has no audio, or that you don’t care about compressing it? If there is audio, then you should really compress it, as well the video. Uncompressed audio can take up a LOT of space, so you will get substantial space savings by compressing to mono MP3 64khz.

Thanks guys… I’ll give it another go and let you know…

When you post an MPEG1/2/4 video to YouTube, they recompress it to Flash Video format. I’ve gotten better quality (and a must shorter time frame between the upload and when the video actually shows up) by simply encoding to Flash myself with the free Riva FLV Encoder, and uploading the .flv file.

The settings I usually use - the same ones that YouTube uses when they compress your video themselves - are 320x240 resolution, 30fps, deinterlace, 360kb/s video bitrate, and audio at 56kb/s, 22050Hz, mono.

Though I have seen it get picky about some video input formats, the program is incredibly easy to use.

Thanks, I’ll take a look at that too. Sounds good.

If you still have trouble with it, feel free to email the video file to me, and I’ll be happy to do it for you.

I only have a 850Hz CPU and it keeps defaulting to (program not responding) May have to wait until I can upgrade the computer…

If you’re referring to Riva here, that’s normal behavior for the program. My PC is more than twice as fast as yours and I still get that, even on encodes of very short videos. Though Task Manager says it’s not responding, it is working. Walk away from your computer for a while and give it a chance to do its thing. I guess there’s a possibility that it won’t work, but it can’t hurt to try.

That is one slooooow computer. Doesn’t the constant whine from the processor drive you crazy? :smiley:

I’m pretty sure you meant 850 MHz, no?