Vista takes 30 minutes plus to boot from HD or DVD

Hi, everyone. I’m begging for help here, so frustrated. I apologize in advance for the length of this post.

First some background on what I THOUGHT the problem was.

We purchased a custom system from a guy I know at work (big mistake), and it was set up with 2 SATA hard drives in RAID. When I went in to add a third drive (IDE) from my old PC, I knocked one of those touchy SATA cables loose, the one to my C: drive, and chaos ensued.

For a few hours, I was stuck in a loop of jiggle the cables, reboot, drive doesn’t show. jiggle, reboot, jiggle, reboot, etc etc. Eventually, the guy I bought the PC from suggested I pull the a battery from the mobo and reset before rebooting. Finally, that did the trick, and all was fine since then.

I generally leave the PC on, and it will sometimes reboot itself from Windows updates and whatnot. So last night, I get home and the pc is frozen in the middle of a reboot… it can’t find the operating system because the PC is once again not recognizing my 2 SATA drives.

Grrr… so here we go. open it up, jiggle cables, pull the battery… no success. Then, on a whim, I open up the BIOS when rebooting. Searching for the drives manually in the BIOS is also a no-go… but without changing anything else, I reboot the PC, and there my SATA drives are! Woot!

So, glowing with satisfaction, I watch the system boot. It hangs for a little bit at the windows logo screen with the progress bar, but, I’m not too concerned. Then it goes to black. After about 5 minutes, I get a mouse cursor. After about another 10-15 minutes, I’m still stuck there. Time to boot to safe mode.

I’m not convinced I ever booted all the way to safe mode, and what I got took 15-20 minutes. This is the first time I tried it in Vista, but shouldn’t I have gotten the windows toolbar with the start button at the bottom? All I got was the black screen with the white “safe mode” text at the top and bottom. I was able to boot to safe mode with command prompt and ran a successful chkdsk/f (it corrected a bitmap problem, no other errors found).

Still unable to boot all the way to windows normally, I decided to throw in the towel and reinstall Vista. I booted from the vista DVD about a half an hour ago and only now did I finally get the Install Windows screen. I’m worried that I’ll wipe everything on my C drive (no data, but lots of programs to reinstall) just to end up right back where I started again.

Here’s what I know about the PC:
Intel Core 2 Duo Processor (2.4 GHz)
Windows Vista
2 GB DDR2-667 MHz dual channel SDRAM (4x512MB)
2 SATA Hard Drives (including my Windows drive)
1 IDE Hard Drive

I would really really appreciate any ideas. Did I mess things up by pulling that battery? Is this a virus? Did it overheat and mess up the mobo/processor? I’m a little out of my depth here.

Thanks again…

Continuing to work on this issue… I got into the “Repair Windows” section of the DVD and it doesn’t see my windows installation. When I use the “Load Drivers” button, it shows me my drives… it sees my IDE drive, but thinks both of the SATA drives are removable disks with nothing currently in them.

Disconnect the IDE and see if it makes anything better.

Thanks for the suggestion, but no real change to report.

If I try to go straight to “normal” Vista, I hang at black screen with cursor.

Booting the Vista DVD, I gave up after anging at the progress bar screen for 10+ minutes.

Safe mode is still taking its slow-ss time as I’m typing this.

See if there are updates for the Motherboard BIOS online and if so update the BIOS.

Thanks, I’ll see if I can hunt down some floppies, otherwise I won’t be able to get any new software onto the PC.

Have you checked the RAM? Pull it out, put it back in, try different DIMMs, etc… Trouble shoot to eliminate possible problem sources, ya know.

If you can get the install DVD to work, I would try to install windows on the IDE drive (disconnect the SATA drives first). If that boots, you can use that as a temp install to update the BIOS, and test devices, etc.

WAG: IDE/sATA controller is shot.

I haven’t messed with the RAM yet, but I think you may be right about the sATA controller. I put a fresh IDE drive in (lots of un-backed-up data on the one I had in there), and I have the PC running successfully on a new Vista install there. It sees the ATA drives, and the file structure, but its ability to actually read files off of them is spotty.

I’m trying to get the BIOS updated. The fix notes for the latest BIOS state “Fix press SATA channel IDE Auto-Detection in setup will hang”, so maybe that’s part of it. But I’m getting this annoying “Onboard BIOS is not award BIOS!” error when I rry to use the flash utility. Gonna hit google again…

DO NOT PROCEED if you are getting message like that from your BIOS update ultity or you can make the mother board useless. You should not need to google it. Your motherboard manufacturer’s website should have a list of the latest & correct BIOS flashes that will work with your model MB.

I’m on the manufacturer’s website. According to my startup text, my mobo is a ECS Nforce 570 Slit-a, ver 5.1, which led me here. The 8/7/07 BIOS release there is the one giving me that error message.

A google search didn’t turn up anyone with similar problems, so I guess the next step is to crack the case again and see if the mobo itself is labeled differently. Any other ideas on how I’m failing to do this correctly would be appreciated- this is the first time I’ve tried to flash my BIOS.

Try downloading the Belarc diagnostic utility. It’s free and will give you a comprehensive read out on your BIOS type and date.

You might also try installing the slightly older 2007/06/22 BIOS update in case the latest one needs this intermediate update before it will install.

Try downloading the Belarc diagnostic utility. It’s free and will give you a comprehensive read out on your BIOS type and date.

You might also try installing the slightly older 2007/06/22 BIOS update in case the latest one needs this intermediate update before it will install.

Is this RAID 0 or RAID 1? If the latter, the hang may simply be the RAID correcting itself after your adventure with the cables and as such you should just leave it - it may take a very long time indeed. Overnight should be sufficient.

Thanks, I ran Belarc, and got this:

Board: C19-A_SLI
Bus Clock: 266 megahertz
BIOS: Phoenix Technologies, LTD 6.00 PG 09/09/2006

Looks like the guy who built this PC used these guys for the BIOS. Can’t figure out for the life of me how to determine if this is appropriate for my mobo, and if so where on their site to update the bios (or if not, how to correct it).

I cracked the case, and the mobo is in fact stamped as a ECS Nforce 570 Slit-a, ver 5.1

The drives aren’t actually in raid anymore, not for over a year. When I had the cables adventure, it was only one of the RAID drives that came disconnected, and they were no longer synched. Rather than wipe everything and start over, I took them out of RAID.

So, and update… right after the clean install on the IDE drive, I was able to play an MP3 off of one of the SATAs. Since then, best case scenario is Windows Explorer crashes and the drive disappears until a reboot. Worst case, I’ve had a few BSOD crashes when I tried to read either of the SATA drives. I’ve since unplugged them.

Phoenix makes the AwardBIOS so this is not surprising. It’s still an “Award” BIOS.

Go over the step by step procedues for the BIOS flash utility and see if it’s possible you’re missing a step as BIOS update uitlity procedures must be followed to the letter before they will operate… Also your MB manfs website apparently wants you to uxe the BIOS flash utility they link to, not the one inlcuded in the original software set on your hard drive . I assume this is the precise one you are using.

I get “Onboard BIOS is not Award BIOS!” as soon as I try to load their BIOS flash utility, WinFlash. Sort of at a loss for what else to do at this point…

All I can suggest is calling ECS support at this point
Support Phone Number: 1-510-226-7333

One of the cool things about raid is it self corrects most of the time. Many sata controllers also support hot swapping and unplugging a drive would do little.

SATA Raid controllers can be fickle beasts and short of totally reparitioning drives can be a royal PITA to circumvent. If the raid was a mirror you could pull one out and repartition it and try to reinstall it as a stand alone drive. This will tell you at least if the problem is bad drives or a driver issue.

Is the Sata cable directly connected to the power supply, or is it a molex plug with a Sata adapter on the end of it? I had a problem with my mobo not recognizing Sata hds and it turned out to be the molex - Sata adaptor. A Bios update helped too, apparently it was a known issue with the mobo.