Win2K: BIOS Upgrade kills computer, help sought

OK, so the computer isn’t killed, but it won’t boot up. Obviously, I would like to fix that.

Environment: A 5 year old 200 MHz Pentium MMX, running Win2K in an NTFS partition on the Primary IDE Master.

Current Situation: When powered on, the computer completes its POST test, and the BIOS screen is available. Once completed, the computer successfully loads the SCSI BIOS that runs an external CDRW drive. After that, the screen goes black, and the boot process hangs. If I set the BIOS to boot from the internal CD-ROM drive, with the Win2K Pro CD loaded, the SETUP process starts, displays the message that “Setup is inspecting the hardware configuration…” and then hangs. I can boot the machine with a Win98 Boot disk, but of course, I can’t mount the NTFS disk with the Win2K operating system.

Last Good Operation: The computer has been running Win2K for over a year. It has had some unusual Shutdown behavior, though (With Advanced Power Management unchecked, the computer would not power off, but display the “It is now safe to turn off your computer” message, with APM checked, selecting Shutdown would cause a restart).

What happened between then and now: After reviewing the thread Computer won’t power down Win98SE yesterday, I decided to investigate how to fix the Shutdown problems. Reviewing the Microsoft knowledge base, it looked like third party drivers may have been the problem. So I did some testing in Safe Mode, and the shutdown behavior was identical (in my mind, eliminating third party drivers). The next most likely problem I ran across was an out-dated mobo BIOS. I checked the manufacturers website, and determined that my BIOS was not the latest/greatest for my machine, and decided to update the BIOS. I downloaded the BIOS update, copied to floppy, and booted to the floppy, and the update appeared to complete successfully. When the computer restarted, I removed the floppy, and received a message after the BIOS loaded to the effect “CMOS checksum bad failed - Run Setup”. I restarted and entered the BIOS setup, and reviewed the entries, everything looked OK to me (see next paragraph). Each restart since, and I have not seen the CMOS checksum error again. But right after the CMOS/BIOS settings are displayed, the video screen blanks to black, and nothing in the boot process proceeds.

One thing that looked unusual - in the previous BIOS setup, the Primary IDE Master was shown as Auto-configured, showing the count of Cylinders, Heads, Sectors, and showed the Max Capacity as 8063 MB. In the current BIOS setup, the Primary IDE Master is shown as Auto-configured, but doesn’t list the Cylinders, Heads, or Sectors, and shows the Max Capacity as 12049 MB. That makes some sense, as the drive is a 12 GB drive, but it has two partitions, one 8 GB and the other 4 GB, with the operating system on the first partition. If I select User Defined for the Primary IDE Master, the default settings become as they were (with Cylinders, Heads, Sectors, and Max Cap at 8063 MB. But it doesn’t affect the boot up problem.

So then I noticed the thread BIOS problem. Help (if there can be anything I can do!). Now, if I had seen this first, I may not have even attempted to update the BIOS. My problem wasn’t that big of a deal.

So today, I have reset the CMOS. I first tried the jumper solution, changing the jumper as shown in my manual. When I started the system, it just beeped once each second, but displayed nothing on the monitor (no POST test, nothing). After a minute or so, I powered off, reset the jumper to normal operation, and powered up. The CMOS didn’t appear to reset (the time, for instance, was still correct). So I tried the battery method. I removed the mobo battery and unplugged the PC for an hour. Replaced the battery and the power cord, powered up, and the system forced me into the BIOS/CMOS setup page. I set the time and date, but most other settings were as they were before. Same bootup problem exists.

So I removed all my ISA and PCI cards. No change. And that is where I am at right now.

I am speculating that the computer is not properly recognizing the Primary IDE drive, or at least having trouble with the boot sector on the first partition.

I think I need to get to some utility that will recognize NTFS partitions, but since I can’t boot to the Win2K CD, I am not sure how to proceed. I am open to suggestions. And btw, I don’t have a Win2K Emergency Repair Disk for this system. I do have access to another Win2K system, though, if that helps me any.

So, dopers, any idea what the problem may be, or how I might go about resolving it?

Oh, man. At first glance, it looks like you may be in for it. If your BIOS is corrupted, there probably isn’t any way to fix it at home except by trying the seriously bad-assed BIOS hot-swap.

I had the displeasure of performing this tedious operation once, and somehow succeeded. It reminded me a of a combination of open heart sugery and bomb disposal.

There are other solutions, however. Somewhere long ago I saw someone advertising pre-flashed replacement BIOS chips. You might want to look into that.

What leads you to conclude that the BIOS may be corrupted?

I am thinking that it isn’t, mainly because I can access the BIOS setup and modify the CMOS settings. I can also boot from floppy on a Win98 Startup disk (not that it helps me any, since my HD system is NTFS). I can apparently read from my CD-ROM drive, since the Win2K setup program starts (but then hangs). This all leads me to believe that the BIOS is not corrupted, but perhaps misconfigured.

My advice is to try and flash back to your old BIOS.

Barring that, see if your BIOS has a “Force ECSD” or “Force ESCD” (something like that) feature which basically makes the BIOS redetect all your hardware settings.

All is not lost – as long as you can boot off a floppy you should be able to get that old BIOS reflashed or at least a version which will allow you to boot normally. It’s when you can’t even post that you have to ditch the BIOS chip for a replacement.

Good luck!

OK, I don’t know how to go about flashing back to my old BIOS. I suppose I’ll search through the software that came with the computer five years ago to see if I can find something like that.

I did look through the BIOS settings and did not find anything referencing ECSD. I did attempt “Reset to Default Values”, with no luck (and no obvious settings were changed - I think I have the default settings).

A couple of further questions, though.

Thinking that maybe the BIOS update file was somehow corrupted, I went my other Win2K system, formatted a floppy, downloaded the BIOS update, extracted the files, copied them to floppy. I put that floppy in the dead computer, started it up, and after the POST test, I got a “NTLDR is missing” message. Looking at the two floppies in DOS, they look identical (the first floppy containing my first BIOS update attempt). The computer will still update the BIOS with the first floppy, giving me a brief message first that Windows 98 is starting, so I assume the problem with the second floppy is that it was formatted with Win2K. Is that right? If this is the case, should I attempt to recreate the second floppy on a Win98 machine (I happen to have six computers here at the house)?

Also, when I boot the (dead) PC with the Win98 startup disk and run FDISK, it sees my second (physical) harddrive, and it shows that it is NTFS. But the first drive shows as EXT DOS. Is that what I should expect?

All advice is welcomed.

Bump. (my last response posted, but failed to bump the thread).

Well, someone did the bios update thing in another post & all they had to do was take out the battery for a few minutes & put it back in & all was well again.

Do you have access to a Windows 2k install CD?

handy, yep, I know, and that raised my hopes, but it did not help my problem.

sweepkick yep, I sure do.

After doing more research, I found a Q article on the MS knowledge base that talked about the system hanging due to having some “flexible drives” being treated as fixed disks by the BIOS. The examples were Iomega Zip and Jazz drives. I have an Iomege Zip drive in the system. I couldn’t determine how to disable in the BIOS, so I simply disconnected it. Still no progress.

Then I found numerous articles, both on and off the MS knowledge base, that talked about what to do if W2K Setup hangs during hardware inspection. Most suggested running the debug version of NTDETECT.COM. So, I took my Win2K CD, created four W2K boot disks, then overwrote NTDETECT.COM with NTDETECT.CHK. When I boot off the floppy, the system STILL hangs in the hardware detection phase, without ever listing any hardware devices. Something still ain’t right.

Oh, and I also found a Western Digital Data Lifeguard floppy. I was able to boot off that disk to run the Hard Drive utilities. Both harddrives tested clean with no errors (Read/Verify test to every sector). I am now thinking that the fixed disks are OK, and something else is keeping the boot process from continuing.

Do a google search on whatever motherboard you have and the words BIOS and FLASH and you should find a site out there with the various BIOS iterations for it. You may have to search for the particular motherboard chipset and the words BIOS and FLASH.

Sorry, but your descriptions of what’s on what floppies is confusing. In my opinion, the BIOS you flashed too isn’t playing nice with your hardware and the only fix will be to find a BIOS that does. Juggling around the various boot floppies/drives won’t help if you have a bad BIOS. I’m no expert though.

Perhaps you might take your problem/questions to and post in the appropriate forum there. That is a very helpful and well-populated site.

Pull the battery and all the power, put the jumper in reset modce, let the thing sit overnight.

You never should have powered the thing up with the CMOS jumper in reset mode. That can break things according to some manuals that I have read.

Reflash the BIOS.

Hi AZ,

Strange problem indeed.

Do you get any error messages whatsoever when you try to boot from the HD, or just the black screen?

One thing you can try is booting off of the Windows 2000 install CD and selecting “R)ecover” instead of install. From there you can go into a recovery console (hit ‘C’) and see the files on your “C” drive. If you can see the files… I’d go ahead and run FIXMBR to re-write the Master Boot Record of your hard drive and reboot. Failing that, reboot into the recovery console again, and type FIXBOOT to rewrite the boot sequence files for W2K.

If you cannot see the files on your “C” drive in the recovery console, there might be an issue with the way your new BIOS reports the geometry of your drive to the Operating System.

You’ll need the Administrator password for your machine to enter the recovery console. If you don’t have it or forgot it, let me know.

No. It looks like you fubared the primary drive while flashing the BIOS. Did you use a floppy formated under W98 or DOS? The missing NTLDR (NT loader IIRC) reinforces my suspicion.

dietrologia, I have done such google searches, and I can only find a few references to the motherboard chipset with BIOS and FLASH in the search. The manufacturers site (Gateway) only has the latest BIOS available for download. I read somewhere else that it is dangerous to attempt to downgrade a BIOS. And further, that whatever may be the problem, starting with the right BIOS is the first step. Thanks for the reference to the other Tech board. I’ll try that. I may have got this past the point where the SDMB can help.

XPav, powering up with the jumper in CMOS clear was consistent with the motherboard manual. It reads, “To update the flash BIOS, power down the system and move the jumper shunt from Pin 2 … Start up the system and the CMOS is reset to default values. Then, shut down the system again and replace the jumper shunt to its normal operating position. This procedure should be done whenever the system BIOS is updated.” Although I am getting desparate, so I very well may try your suggestion.

sweepkick, I do not get any error messages. When the computer first powers up and sends a signal to the monitor, I get the Gateway BIOS flash screen, with the instructions to press F1 for setup, press tab for system messages. When I press tab, I get to view the POST test. Memory checks OK, and it reports that NVRAM is OK. If/when my SCSI card is in, it then loads the SCSI BIOS, which appears to succeed (I’ve tried it with the SCSI card out, and it just skips this step, otherwise same issue). After that, there is a quick message that I can’t catch as it goes by too quickly, but I can see PRI, so I assume it is a message about my primary IDE drive. It then brings up a CMOS/BIOS summary, reporting the main BIOS settings. If I pressed tab earlier, it holds on this screen, and I have to press ESC to continue. If I am attempting to boot from the harddrive, right after I press ESC, the screen goes black, and the system hangs.

If I attempt to boot from either the Win2K CD or the Win2K boot disks, I get the message that “Setup is inspecting the hardware configuration” and it hangs very quickly. So I cannot try either of your following suggestions, as I cannot even reach the menu on the Win2K CD.

And I do have my administrator password, if I can ever get to a point where I need it.

Urban Ranger, you may have hit on something. When I first flashed the BIOS, I simply followed the installation instructions. They said to copy the flash BIOS files onto a floppy (but didn’t specify that it should be formatted any specific way). I am quite sure the floppy I used had been formatted by Win98 (or something earlier). When I came back later and tried to reflash the BIOS with a floppy formatted under Win2K, I got the “NTLDR is missing” message. As I mentioned early on, something about how the drives are seen by the BIOS seems unusual, such that it is seeing my Primary IDE Master as the full physical drive, instead of the first partition.

Also as I mentioned, when I do flash the BIOS (boot off the floppy with the flash update), after the POST test, I briefly get a “Starting Win98” message, which tells me that the flash update uses some Win98 shell to launch the flash update process. I can verify that the BIOS update instructions say that the BIOS is for all operating systems.

If we assume that you are right, and that when I first flashed the BIOS with a disk formatted for Win98, that it somehow mangled the boot sector (or something) on the primary drive, any idea how I might go about recovering either the disk or the system? Frankly, I am more interested in recovering the data on the HD than the system itself (obviously, it is a bit out of date anyway).

The Western Digital Data Lifeguard floppy has a “BIOS check”, and it reports that for both IDE Drive 1 and IDE Drive 2 that the “BIOS is properly controlling this drive in LBA mode”. On Drive 1, it reports two partitions. The “System Type” for the first partition is reported as “EXTND CHS NTFS/HPFS” while the second is reported as “NTFS/HPFS”. IDE Drive 2 has one partition, with system type “NTFS/HPFS”.

At this point, I have a few options on how to proceed, and I’d be interested in opinions on which one makes the most sense.

Option 1: Continue trying to recover the system. To do this, I would remove every peripheral I can, such as removing all the cards (which I did previously), and remove the CD-ROM, and the primary master HD, leaving only the floppy drive and the primary master slave HD (video, keyboard, and mouse are all onboard). Then try to run Win2K setup and hope the system no longer hangs. If it still hangs, then try loading some generic BIOS and hope I can regain the boot process. If I can get setup to run, I can then load the operating system on the second drive (there should be space available). At that point, I could then try to add the first drive and see if I can access the file system.

Option 2: Focus on recovering the data on the HD, not the system. I can take one of my other desktops, which are currently all running Win98, and load Win2K. This will take some time, as I will need to move all the data first (ok, so I may not need to, but I traditionally avoid OS upgrades for clean installs). The remove the first HD from my dead system and try to add it to a different Win2K system. Hopefully, I can then access the file system. Once I’ve recovered the data, I can then go back to my dead system and try to load Win98 (as I said, I’ve been able to get to the Win98 startup disk to boot the system, it just didn’t help me get to the NTFS data). Once I have Win 98 up, I can hopefully find a way to get back to Win2K.

Thoughts? Sorry for the long posts, I sincerely appreciate all the tips so far.

More Bios, just about any computer:

Before you take any real drastic action try booting with floppy the try this command


This will often fix a corrupted or damaged master boot record.

will only take a minute to try and won’t hurt anything if that is not the problem.

Firstly, to make the problem smaller. It has nothing to do with Win2K. Its a BIOS/Hard drive problem.

  1. You can’t make a Win2k boot disk. They don’t work. Your Win98/Win2k boot disk worrying is irrelevant. The BIOS is OS independent.

  2. “Generic BIOS”. No such thing. Use only the BIOS that Gateway says too. Downgrading bioses isn’t a problem, I’ve done it before.

I suspect the settings for your drive aren’t correct. If clusters/heads/sectors aren’t correct, the drive will work erraticly, and changing the CHS will result in the drive being unreadable. Keep it on AUTO – it should say 12GB.

Unplug all the drives save the CD-ROM, see if the Win2K CD will boot. If so, plug in the HDs one at a time. If it stops booting on the primary, then that’s the problem. I don’t think the drive has been damaged, it just has the wrong settings. Try AUTO BIOS, try changed LBA and LARGE and try some combinations to see if there is a problem.

You can read NTFS drives from DOS boot disks by using the free version of NTFSDOS Professional. This would let you copy files off your main HD, but not write anything to it.

You also might want to test your RAM. Memtest86 is a good free tool.

Chanticleer, Are you suggesting that FDISK on a Win98 startup disk will be able to fix a corrupted master boot record on an NTFS volume?

XPav, what you saying makes sense to me. Unfortunately, I cannot find an older version of BIOS, Gateway is the only source I’ve located. If someone wishes to look for themselves (to prove me wrong), the motherboard part number is MBDSAC092ABWW. There is also a reference to LAWMAN, which I think may have been the OEM manufacturer for Gateway. The flash BIOS that I now have loaded is version 0AAES054, found here (note: following link may attempt to start the download - just cancel). On that page, my motherboard is listed as a supported product. The previous version I was successfully running was 0AAES038 (I’m not absolutely sure of the last digit, I thought it was a 6, but I cannot find any documented references to OAAES036, and I can to 0AAES038, I just can’t find the BIOS image anywhere).

I’ll try your last suggestion (unplugging all drives except the CDROM and try booting the Win2K CD). Right now, I have all the cards removed, and the system unplugged, battery out, letting the CMOS clear again. I’ll now unplug the two HDs and the floppy, and then try to boot up here shortly.

Number, your link to NTFSDOS Professional looks extremely useful if I just want to recover the NTFS volume from one of my Win98 machines. Thanks for the link. Question: If I am able to access the NTFS harddrive from another system, will I run into problems accessing the datafiles due to Windows security issues? Is there anything I need to know about accessing the files from another Win2K system? Like do I need to exactly recreate the user logons to access the files? Or will I be fine as long as I am administrator on the system that I am using?