What ate my Windows ME Explorer?

I’m having problems with Windows ME, and tech support doesn’t seem to be getting back to me. I thought I’d turn the question to the computer geeks of SDMB, in hopes of an answer.

Every time I try to load my Windows Explorer, the “find file” function, or the help function, I receive the same error message – it informs me that Explorer has provoked an error in “<unknown>”, and that if the error persists, I should reboot the computer.

[li]I first tried rebooting the computer. Predictably, no success.[/li][li]I tried scanning the disk. No errors found.[/li][li]I tried uninstalling recently-added programs. The result – I lost a lot of data. No other changes.:mad:[/li][li]I tried defragging the disk. It told me I couldn’t do that until I’d used scandisk to fix the errors. I tried scandisk again, and still no errors. [/li][li]I can access these files through dos-shell, though I’d prefer to have access to explorer, help and find. Anything I can run through my desktop works fine.[/li][li]I tried drastic measures – I’ve tried booting up the computer with the recovery disk. It never autoboots this disk – either when I start up the computer or when I put it in my DVD drive. I can’t start it up from dos-shell, and of course I can’t load it up through explorer because I don’t have access to explorer.[/li][li]Once it said that Explorer had provoked an error in “kernel32.dll”, not “<unknown>” like usual. I have no idea what “kernel32.dll” is, but since it’s managed to crash almost every application I’ve ever loaded onto my computer, I consider it the prime suspect. [/li][li]Unfortunately I can’t delete or copy my roommate’s copy of it over it in dos-shell, because “the file is in use.” I discovered that this evil Hewlett Packard machine doesn’t let me exit to genuine dos, only dos-shell, so I can’t access kernel32.dll without windows running.[/li][/ul]

I’m at my wit’s end, and have exhausted my limited computing knowledge. Does anyone have any insight into fixing this?

Use System Restore and go back to a date and time before the weird stuff happened.

Start, Programs, Accessories, System Tools, System Restore.

You can destroy IE and install it again, but that does require a fair bit of Windows knowledge. Another option is to repair your copy of IE. I think you can do it by Add/Remove Program.

The best option of course is to ditch IE. I suggest Mozilla

It’s not Internet Explorer he’s having a problem with - it’s Windows Explorer.

Gah, Millenium Edition…any other company and there’d be enough fodder for a class action lawsuit…

To get the repair disk working you’ll probably have to change your bios settings. To do that, shut off your computer. WHen it starts up, usually before the bios logo fades, you’ll have to hit a key. Which key it is depends on what motherboard you have–usually it’s either f1 or del. From there, you should be able to change your startup options. Make sure the cd-rom (or, in your case, it’s a dvd rom) is the first on the list. Save your changes and exits. Should work now.

I appreciate the suggestions, but so far nothing has worked.

Duck Duck Goose, I did try to restore the system through the start menu. I received exactly the same error – “Restrui has caused an error in <unknown>.”

slortar, I went into BIOS on matt_mcl’s suggestion, set my first boot option to my DVD/CD drive, with no result whatsoever. It did not boot. I am beginning to think there is also a problem with my recovery CD.

Strangely, the last CD of the recovery system works fine – but that only recovers individual applications.

For the second time, I got the error message as “Explorer has caused an error in kernel32.dll” instead of “<unknown>”. I have no idea what kernel32.dll is, but it’s been responsible for dozens of crashes since I got my computer, and I’m guesing it’s somehow at fault here. Actually, the DLL files have been a problem in general.

Does anyone know what a DLL file is, and why they would be interfering with my computer’s normal operation? And is there any way to keep them from operating while I run Windows, so I could replace them with others from another computer? They don’t show up as background programs when I press CTRL + ALT + DEL.

Thanks in advance.

I’ve had this same problem with Win 2K Pro. There are several Microsoft KB articles with instructions that did exactly zero to help my problem.

Probably no help but go to http://support.microsoft.com and try out Q255758, Q314867, Q326612, Q301961, Q319124, Q323045.

I still can’t use the search feature of Windows Explorer or properly access Control Panel and several other things. Best of luck and if you get it solved please post your procedure.

FTR I don’t think these will help but they may get you pointed to something that may be of assistance.

NP: Corrosion of Conformity - Deliverance