What is wrong with my computer's search indexing?

I had a hard time deciding where to post this so I’ve settled on GQ as it should have a factual answer.

When I try to search, nothing comes up.

Windows search service shows as stopped, and gives “system could not find the path specified” when I try to start it. Path to executable is C:\Windows\system32\SearchIndexer.exe /Embedding, and the file exists.

in regedit,
data directory is C:\ProgramData\Microsoft\Search\Data\
default data directory is %ProgramData%Microsoft\Search\Data
SetupCompletedSuccessfully is 0

Does anyone have experience with this problem? What is windows referring to with the path not found error?

Google “SearchIndexer.exe system could not find the path specified”. You aren’t the only one with that problem. You might want to add the version of Windows.

I’ve searched it multiple times and tried multiple fixes posted, non of which worked. That’s the reason I came here. Windows 7 by the way.

I think I may have found a/the issue. The registry value Local_Machine/SOFTWARE/Microsoft/Windows Search/Gathering Manager/Applications/DefaultApplicationsPath refers to a non-existent drive G. I want to return it to C, but am having (I believe) permission errors in trying. The error simply says “Error Writing value’s new contents”

To fix the permission error I followed This guide and then changed the value. This removed the error in running the search indexer. Jesus Christ.

Searching finally works.

Gotta love computers. You had to do a search to find out how to fix your PC’s inability to do a search.

Glad you fixed it.