What the heck is a "Glimpse Error"?

I was trying to search for the word “lipogram” on A Word A Day (in the words and quotes archives only) , and I got this back from the search engine:

Glimpse error
The search parameters caused an error in the call to Glimpse.
Please try your search again with different parameters.

Output from Glimpse:

Can anyone tell me what this means?

Oh, and I also got it when I tried searching for other words; just in case the word “lipogram” caused the search engine to hang. And just in case I was searchng using the wrong index, I also tried my search using the “whole site minus words and quotes”… same thing. Does anyone know what it is, or is the search engine just not working? :confused: :confused:

P.S. I’ve used this search engine before with no problem at all, until now…

Glimpse is an indexing system that allows you to do text searches in a group of files.

The most likely cause of that error is that there were 0 matches for the word you searched for, and the programmers of the A Word A Day site didn’t properly code for that condition. I was able to get the site to produce that error every time I entered any obscure (but correctly spelled word), that was unlikely to be in any of their files. On more common words, it brought up matches every time.

Thanks for the help, DMC… I’ll go try that now, in fact. Hey, it worked! Cool!