What's wrong with my computer? Help please!

I’ve been having strange problems with the newer of my two computers for a few months now. There is a variety of problems, but they all seem to be tied to my CD-ROM drive. I thought it was a hardware problem with the drive itself but it has been replaced and I still have the same problems. I wonder if anyone has encountered the same problem.

First, I guess I should provide the basic info on my system - it’s an 800Mhz PIII with 256MB of RAM, a 20GB hard drive, a 48X CD-ROM drive, and a GeForce256 3D card. I’ve had it since June of last year.

The problems first showed up when I was trying to play The Sims. When I started the game up you could hear the CD drive spin up to verify the presence of the disk, and then it would slow to a stop, and a few seconds later it said the disc was not in the drive. Occasionally it would work, and the music during the loading screen would skip around, but once the game started everything would be fine - and then the game would hang and I would hear the music from the autorun menu playing, and I would see that it autoran the CD again while I was playing, like I just put it in. It seemed to me like the CD drive was malfunctioning, or maybe it’s connection to the motherboard, but I checked the seating of the cables and it seemed fine. I found later that I could get it to recognize that the CD was in there more consistently if I opened up My Computer (which got the CD drive to spinning) right before I clicked on the Sims icon. I disabled autoplay and I got rid of the problem of it reopening windows while the game was already running, though the music on the load screens still skips.

Oddly enough, all the problems aside from the music skipping went away with The Sims - it can always detect the disc now. The problem has moved on to OTHER games. No One Lives Forever, which used to run flawlessly on this machine, now refuses to believe I have the right CD in the drive when I try to start it, none of the tricks I picked up with the old Sims problem seemed to fix it. The computer also now has problems playing games that (I think) are reading the in-game music straight off the CD, this seems to be mostly with older ones…the music in Diablo is always skipping, same thing with Master of Orion 2 and Starcraft - in Starcraft the voices during the cinema screens skip too.

The worst thing about this is it keeps me from playing Black and White on my better machine - when I put it in it always gives me an error (Fatal Exception? Or maybe it’s an Invalid Page Fault) when the CD drive spins up, I’m assuming to verify the presence of the CD - I was able to install the game fine, though.

I’ve already replaced the CD-ROM with a new one of the same kind, nothing has changed. I was hoping that would do it, I thought this was a hardware problem (I already reinstalled the CD-ROM drivers to no effect) because the CD drive often made weird noises on the games where it skipped or had problems recognizing the CD - it would spin up very fast and then suddenly slow to a stop, followed by a couple of clicking noises. Sometimes it buzzed. But it does that with the new drive as well.

I’ve got a few hypotheses on what might be causing the problem, though I admit I’m not much of a hardware guy.

A) a faulty cable between the CD-ROM drive and the motherboard. I just recently considered this, I hope this is the fix, it sounds plausible and would probably be easy to fix.

B) something wrong with the motherboard itself, maybe with the jack the CD-ROM drive plugs into or it’s controller. This would be bad, unless I could move the CD-ROM to another controller…

C) some esoteric software problem - I’d lean towards this more if the error messages I got trying to start B&W were the rule and not the exception, but I can see how some kind of hardware failure while the B&W software were trying to read the CD would cause a software error.

Anyway, does anyone have an idea what this problem might be? It’s really beginning to annoy me. I’m probably going to get a new computer this June (just like the last two Junes) but I still want this one functioning properly.

Dunno, but you’re playing Black & White? In this thread–


Asmodean says, of the on-line version of Black & White:

Is there a connection?

I’m leaning towards esoteric hardware problems, myself. You see, here’s the problems I’ve been having.

Upon entering Windows 98, my system will sometimes (apparently not always) check to see what’s in my DVD-ROM (IDE device). Sometimes this causes my computer to spontaneously reboot, sometimes it gives me the BSOD. Sometimes nothing happens either because it doesn’t check the drive or, for some reason, it does but doesn’t fell like screwing around at the time. I’ll also get the BSOD or, less frequently, a spontaneous reboot when I check a CD/DVD that’s in the drive or go to Windows Explorer/My Computer (especially when trying to access the Worms: World Party CD, go figure). The drive has also quit playing audio CDs. Note: En/Disabling DMA in the system control panel does nothing.

Now the reason I consider it a software problem is that when I boot into Win2K (one of the few joys of having a dual boot system), things are more or less peachy keen (though I haven’t tried audio CDs yet).

I’m going to do a format/reinstall of my Win98 drive some time this week and keep you updated.

Badtz Maru

What operating system?
I found that the restore function had to be disabled on one computer running Win ME, or it would start flaking out. It can be disabled from System. Make sure that your AGP aperture is set to 128MB. Check that the cdrom is not on the primary IDE controler either. Memory managment should not be set to a fixed amount. Defragment the hard drive, it helps alot. There are so many things that could be the problem, I only listed a few.

That actually sounds like a error with windows to me. Black and White was never actually finished though, so it could be one of the numerous errors they left in the game to meet a release date:)

I’m running Win98.

The problem starting B&W was there from the first time I tried after installing it - I have never gotten it to run on that system, so I don’t think it’s related to the bugs that show up after some amount of play (which I’m beginning to see on my secondary system I have been playing it on).

Next step is going to be trying a different cable. If that fails to work, I’m going to try taking the one working CD drive from my other computer (wife broke the other one trying to get a stuck CD out) and popping it in to see if that helps.

I may end up upgrading the OS if none of that helps.