Why am I connected to my wireless network, but not getting any Internet?

The question is pretty simple. My wireless network claims I’m connected, and says that there’s 50% signal strength (about all I can hope for). Other laptops say something similar (I connect my desktop PCs through wires). But none of them can actually access the Internet. It’s as though they aren’t connected at all. What’s going on?

AFAIK, the signal strength indicator is ONLY an indicator of how strong the signal is between the wireless hub (i.e., your router or other central point) and the computers. It is NOT an indicator of whether there is actually a connection to the internet.

So you need to see whether the thing that connects your whole network to the internet (the router) is actually connected and communicating with your ISP. It could be a problem with the router itself, or with the modem (cable or DSL) that brings the internet into your house.

It’s two separate things. You do have good connectivity to your network, which is all hat your signal strength is saying. You might want to check your modem (maybe shut it off and back on again).

There are a myriad of things that could be going on here. The first thing to do is unplug the modem and router. Plug the modem back in, and wait until it shows that it is connected. Then plug the router back in. Also, restart your computer.

If that doesn’t fix it, let us know.

Along the lines everyone else is saying, your wireless connection is separate from your internet connection (unless you happen to be using a wireless router/gateway product).

To troubleshoot try plugging your laptop into the DSL/Cablemodem device. Can you get to the internet now? If not, then call your ISP as there is probably something wrong with your connection (this is the most frequent problem).

If you can get connection then the problem is probably the interface between your DSL/Cable Modem and your wireless access point. Do you have the Access Point connected to your ISP access device plugged in right (on my Linksys AP there are 5 connections…you should be going from the WAN port of the AP to a LAN port on your ISP access device). Is your AP set up for DHCP or static addressing (you should be able to access the device by opening a browser and typing in the IP address of the device in the address area of your browser)? It probably needs to be set up to receive a DHCP address on the WAN port AND give you a DHCP address on the wireless side as well, unless you know how to set up static addressing.

If all that is right or you have any questions come back…put in the model number and manufacturer of the AP and it will help in troubleshooting.


Okay, I think it must be a problem between my router and my wireless hub, because my wired connections are still fine. I’ll do the basic stuff–turning it back on and off–before I look at anytihng more complex. Thanks, guys.

It’s a DWL-G122, D-Link router, for what it’s worth.

How often do you turn off the DSL/cable “modem” and the wireless router? If you leave these things on 24/7, it’s a good idea to turn them off every so often as the wireless routers tend to accumulate failed connections and get “clogged up” internally. DSL modems also can suffer in a similar way - if there’s noise on the line, the DSL will negotiate a lower speed to keep the connection alive, but not all devices are equally good at re-negotiating back to the faster speed once the line has cleared, so your connect speed keeps getting gradually slower.

My standing recommendation to anyone that wants to leave their connection running all the time is to go to the hardware store and pick up a digital lamp timer for about $20 and plug the router and cable/DSL modem into it. Mine’s set to turn on at 3:01 AM, and turn off at 3:00 AM - a net one-minute shutdown at 3:00. I haven’t had any “sync, no surf” problems in several months this way.

One thing I always when I am having Internet problems but I see a strong signal: I go to the router’s administration page, usually at

That will at least tell you that your network is working, HTTP is working, and you might even be able to do something useful from the admin page.

Are you sure of that model number? When I do a google search I get this (which is a wireless USB card).

I don’t use a lot of D-Link equipment but according to one forum I just browsed the default IP address on the LAN side SHOULD be /24. When your computer attaches to the wireless side do you know what IP address/gateway you are getting (you can get this by opening a command prompt and typing ‘ipconfig /all’ at the prompt). Whatever is in the gateway section type ‘ping’ and the address of the gateway…if you get a reply then you are attaching properly to the AP. For drill type something like ‘ping yahoo.com’ and see if you resolve the address. If not then open a browser and type in http://<whatever the gateway IP is>…this should take you to the AP’s configuration utility.

If you have turned it off and on once and it’s still not working it’s probably something in the configuration of the AP…or your cable modem/DSL device isn’t giving it an IP address. What you can do in that case is put your PC/Laptop back directly connected to the cable modem/DSL, open a command prompt and type in that ‘ipconfig /all’ command again. Write down the gateway and DNS information and then put that information into the AP’s WAN parameters section and see if that works.

Hope all this helps.


Ah hah! It worked. Thank you all for the quick fix.

My cable modem has a habit of telling me I’m connected, but dropping the signal to Time-Warner.
I have to reboot the router/modem about twice a week, which is better than untold amounts with the Motorola PO Junk we had before. Try recycling always as a first measure before freaking out or calling the ISP.