Why am I getting blue and grey circles for threads I've never read>

989 going once . . . 989 going twice . . . Sold!

Have you tried logging out, then logging back in? Maybe that would knock loose whatever is stuck.

Or not.

I took a screenshot of it, but I have no idea how to post it.

I logged out and it’s gone now. Good idea, mbh!

When in doubt, re-boot.

I’m running into a similar issue in a thread I posted in Site Issues. Though, in my case the numbers go away if I refresh the forum (which Discourse calls a category) page. I’ve reported it as a bug.

They appear to be the same numbers you get when you actually follow a thread. But I have the “automatic follow” feature turned off.

Maybe someone’s laundering dots.

It’s happening again, this time to the thread for Critical Race Theory, which by coincidence (or is it?) actually has 55 real posts, just like the Money-Laundering Thread had when the blue dots started. It’s currently showing a blue dot with 300. I’ll take a screen shot of it, but again, I don’t know how to post them.

Went back and it’s showing 440. Can I e-mail a screen shot to a mod? would that help @codinghorror ?

Hmm. I’m not seeing these number dots when I surf the SDMB with my iPhone, only when I do it on my Chromebook.

Now I’m starting to get blue dots with the current number of posts on threads that I’ve never posted to. Again, on my Chromebook, not my iPhone.

It doesn’t impair functionality, I can still read those threads if I wish; just that Discourse is telling me that i’ve posted to those threads when I haven’t, which undercuts the value of the blue dots.

Good news! We are consolidating the grey (old unread) and blue (new unread) circles in the very near future. A case of TMI.

Note that seeing an unread count (white number in blue circle) doesn’t mean you have posted to the topic. It means you are tracking the topic; click or tap the bell icon to change your notification state.

That still doesn’t explain how a thread can have several times more unread posts than it has posts, total.

No, I’m saying i get blue circles for threads I’m not tracking, and showing hundreds of new posts even though there may only be a couple of dozen posts to that thread.

That can happen when a lot of the topic posts have been deleted or merged with another topic. Anyway, click the bell, like I said, to change it.

I will try that next time, but that’s not what I"m saying was happening.

There would be a thread on the main page, that I had never read, in the column on the right, with 50 posts. And a blue dot by the thread name, saying there were 110 unread new posts.

I would go off and read a different thread, and when I came back to the main page, the same thread would still show 50 posts total. And a blue dot showing 220 unread new posts.

I would go read a different thread, come back to the main page, and that thread would still show 50 posts total, with a blue dot showing 330 unread new posts.

That wasn’t happening because of a merger of threads.

The number that the blue dot increased by was always the same for that thread the increment could be different for different threads.

I took a couple of screen shots, if that would be of any help.

It only happened on my Chromebook, not my iPhone.

That’s not impossible: it could be deleted (or even auto-deleted) spam posts that are causing it the bubbles.

However, it seems to be completely ignoring settings. I get them even though I’ve followed exactly 1 “topic” since I got here. Sometimes it’s in a thread I’ve posted in, sometimes not.

It seems that somewhere along the line, the setting for whether or not you followed a thread is getting ignored occasionally. It seems like it would be a race condition situation.

For me, refreshing the page usually fixes it. But it is weird…

Note that if you read a topic for more than 4 minutes, it will be set to tracking state, under the presumption that probably care about this topic if you spent at least 4 minutes reading it. You can configure this behavior in your user preferences.

And yes, a ghost spammer post that was posted, then deleted, could perhaps cause this. You’ll need to check with staff if you want to be sure.

No. I have this disabled. That’s my point. It seems like my setting in this regard is being ignored occasionally.

Also, sometimes it’s a topic I’ve never even opened.

Is it an old topic, that predates the migration? Then it is imported state from vBulletin.