Why Can't I Get 'Re-Captcha' To Work For Me?

I just recently tried to send an email to a site I was interested in. They had “Re-Captcha” there to make sure I wasn’t a mailbot. I get all that. There was a picture of a couple of numbers on an address sign, and I typed the text in just as I saw it.

The only thing is, it failed for me repeatedly! I tried spacing the numbers. I tried typing them in as words. Nothing worked. Now I think I am banned from the whole site (which is really a bummer for me–I really wanted to be part of the site).

Does anyone know what gives? And could it be a software issue for me–or a problem at the site itself?


Are you, in fact, a human?

ETA: I’m assuming you used the little rotate button if you couldn’t quite make out the current blorb of text?

They should have given you two images of numbers, and asked you to fill in both of them (one is the actual test for you, and the other is using you to calibrate that test for future humans). If for whatever reason you were only entering one (it didn’t show up on the page, or you didn’t notice it), that’d be a fail.

Also, there’s usually a button to load a different image. Sometimes you can’t figure out the text in one image but the second one is clearer.

I don’t think they do that anymore. These days it’s mostly (single) house numbers from Street View:
ReCAPTCHA demo (refresh a few times until you see an actual captcha instead of the “nocaptcha” images test).

I have the same problem. Many time I enter the numbers very carefully and Captcha rejects it. I find the audio Captcha easier and use that if its offered.

I had that problem before once or twice, and it turned out to be a browser issue. I switched to IE for just the registration process, and it worked.

Were you doing this at work? A couple of places I’ve worked have had odd proxy servers that don’t seem to like captchas. I could never get them to work on the office network. If I dropped off and tethered to my phone they’d work first time.

This happens to me constantly, on Firefox. I suspect browser also, but haven’t checked into it.

It is frustrating as hell.

I just tried my old Internet Explorer program, as Personal suggested. Doesn’t work. Also, aceplace57 brought up a good point–use the audio feature. That actually was one of the first things I did. And I already know that is pointless too.

I am at my wits’ end.

I do have a slightly older computer (“couple” years old). Could that have anything to do with it?

Anyways, thanks, all, for your help, in any event:).

Can you share the link with us?

You could also try e-mailing them about your difficulties with the Re-Captcha, if you’re having trouble there are probably others with the same problem.


I generally find sites that do things like this (re-captcha), especially ones that don’t work well or with all browsers, aren’t worth joining. Their content is seldom that valuable or unique.

I concur that their ReCaptcha does not work, I tried it 5 or 6 times. I’m on Firefox 29.0.1 on PC.

You might try emailing webmaster@unsealedfiles.com about it. Most properly run sites have a webmaster account.

Not that it matters at this point. But I tried emailing webmaster@unsealedfiles.com and it doesn’t work.

But you’re all right. Any site that apparently just doesn’t care if you try to contact them, is not worth bothering with:).

One last thing though, you all can help me with. If I had the postal address to http://www.unsealedfiles.com/ I could simply send them a letter (that’s right, you heard it here first, I still use snail mail).

I scoured the site for a postal address, but couldn’t find one. But some of you might be more resourceful than me.

Why don’t you just ask them on Facebook? They’re active there:

Or here’s the mailing address of the guy who manages the domain name (not necessarily the website):