Why does my computer not allow Ebay?

My computer will not access either Ebay or Amazon. If I try to load the page, it just says ‘done.’

I have Firefox, but it won’t do it in IE, either. I have a Dell with WinXP.

It does allow me to go to secure sites, and it only seems to be these two as far as I know. I’ve tried clearing my history, went through my security settings, it just doesn’t make sense.

Help, please?

I would try to lower your security settings and make sure it allows all cookies. Also make sure you have flash and shockwave as well as java installed. If both browers dont work try a spyware scan.

Is it your PC, or a company PC? I could see a company electing to block eBay, but blocking Amazon seems a bit odd.

Another possibility is that someone (either someone with access to your PC, or via malware) edited your HOSTS file. If this is your PC, (don’t do this on a corporate PC) head over to \windows\system32\drivers\etc\ and open the file called “hosts” with Wordpad. (It has no extension, so you’ll get a “How should I open this?” window.)

Most people’s HOSTS file has essentially nothing in it - about fifteen lines of instructions and one line reading: localhost

If you find anything like www.amazon.com
then you’ve found the problem. The address is “localhost” - another name for that computer, and will prevent any access to Amazon. Delete that line, save, and you should be able to go shopping again. (A reboot may be needed) Don’t make any changes to that localhost line, and don’t delete the file.
ETA: It’s worth noting that some folks set up extensive hosts files to block known adware/malware sites.

Microsoft has a decent tutorial on how to edit and work with the file, and fix other common browser issues.

Company computer, but seeing that I am the grand pooh bah when it comes to all things computery (yeah, the blind leading the blind, hush.) No one else has access to it, it goes into lockdown in 4 minutes.

I tried what chris said, checked cookie level, made sure I had flash, shockwave and java, to no avail. Checking yours now **gotpasswords.

I have a whole shitload of stuff under there. I guess I’ll start happily deleting. Any idea why?

Ok, problem fixed, that was easy, everything works just grand. Still curious as to why it happened in the first place…

It depends. Is the list associating hosts to Some malware / spyware cleaners have an “innoculate” option that appears to just take a widespread ad hosting domain (like, say, doubleclick.com) and set the IP for that to That effectively tells your computer “that URL is equal to localhost”, which (assuming your computer isn’t actually a web server) nullifies getting content from that domain. I’ve done that myself (both with blocking tools and manually editing the hosts file) since I prefer the icon to advertising.

If you have a list of hostnames and actual IP addresses, your company PC may have pre-filled that file with machines on your internal network. The hosts file can speed up name lookups (since your browser doesn’t have to resolve the URL’s IP through a domain server). Although in my experience, most office networks are using DHCP (or something simlar), which dynamically shuffles IP adresses around, which would make the hosts list useless.

They were all I do have malware/spyware cleaners that quarantine, perhaps like that?

My company PC is basically a home computer, remember I’m the grand pooh bah? I am the network.

Heh, that reminds me, I’ve always told the boss, if I die, good luck.

You may have also gotten infected with some malware that set legitimate sites to be blocked by your hosts file. As malware goes, that’s fairly innocuous but still annoying. I’ve had that happen once or twice. What’s worse is when it hijacks, say, Google.com and redirects to their own shitty search engine that has even more fun malware.