Why does this PC lose a static network drive, and get it back after ipconfig /flushdns?

Mrs. Napier’s WinXP (SP3) laptop can’t navigate to or map the one network disk drive she wants to use for backup, unless she runs ipconfig /flushdns first. Then it works, for hours maybe, but not for days.

This is a static IP addressed drive. I thought the dns cache was about tracking DHCP-allocated addresses, and you flush it to deal with obsolete data.

The drive lists her as a user with her regular Windows password, and she’s never asked to authenticate anyway - I don’t think it can be an authorization problem. She always uses it as a mapped logical drive, and we never have to remap it. But we can’t even see it in Network Neighborhood unless we flush.

She can reach all the other static IP drives and other static IP things on our network, and I can reach all our drives including the one in question.

The only combination that doesn’t work is her PC and the drive I bought specifically to let her back up and have peace of mind. Therefore, it is actually making things worse!


The next time she has the problem, do an ipconfig /displaydns and see if something else with the same name is showing up with a different IP. It might be a name conflict of some sort.

I tried ipconfig /displaydns and see two addresses associated with the host name of this drive, neither of which is correct. In fact they’re both different in every octet from each other and from my private network (192.168.1.x).

Another clue discovered since the OP (o so long ago): when we boot the laptop it can access the network drive just fine through Explorer, but as soon as she accesses her C: drive or her portable USB hard drive, she loses contact with the network drive.

Also, I meant to say, that on her laptop I can browse to the network drive’s configuration page with IE. So, the connection is there, literally. It is just unusable as a disk drive and invisible in network Neighborhood.

Also, tried going to these two IP addresses with Safari on my Mac, and get “404 Not found”.

Try mounting the drive at the IP instead of the name. For instance, when I had a static IP, I would go to \\MyDocs instead of \emac\MyDocs. The latter uses the DNS, but the former doesn’t.

Obviously, it’s a workaround, not a fix, but it should work based on the information you have given.

BigT, thanks - but I don’t quite understand. How do I mount a drive at an IP?

Trying what I think you mean, and using my work computer with its own IP address, if I put \\MyDocs into the Windows Explorer address bar, and hit Enter, nothing seems to happen for a couple minutes, and then I get “Windows can’t find…”. Should this work using the system’s own address? Or am I just misunderstanding what to do? I can’t try it on the home system just now.

Another clue surfaced: apparently, this network drive and laptop worked fine together until I enabled our home wireless network. But, I am trying to connect the laptop by hard wired ethernet. Also weird, it keeps establishing a wireless connection, even though I keep disabling the radio. Is it possible to force it to use the wired connection? How?

ipconfig /displaydns will be a red herring, unless you actually have registered the network drive in your local DNS server. What BigT is asking you to do is map the network drive (I’m assuming it’s a NAS appliance of some sort) as \192.168.2.x\sharename. If your work computer is not sharing MyDocs, that’s why you get an error.

Can you give us some more details? How is the drive advertising itself by name? Can you put a static entry in your local hosts file if you must use a name?

Here’s where I struggle to keep up, as I only partly understand what you say and ask - sorry!

I don’t know what my local DNS server is. I have a home network including a central switch, a PC and a Mac, 2 to 4 fileservers, and a router whose WAN port connects to a cable modem. I always guessed the DNS server is a function provided by my ISP, and that I only used DNS for things outside my private network, and this is typical of small home network setups - am I right?

I don’t know exactly how the fileserver or drive in question advertises itself by name. It’s a Western Digital Mybook. I configured it with a name, a static IP, and a list of users and group accounts, in what I suppose is a typical simple configuration. From either of the computers (at least, if Mrs. Napier’s computer has just booted), it appears with its name.

Here’s how I set it up for Mrs. Napier: On her computer, a Dell WinXP laptop, I originally used Windows Explorer Tools > Map Network Drive, and browsed to it, and called it the S: drive (its name starts with S and this helps Mrs. Napier remember where it is supposed to appear). BTW, once it has disappeared, this doesn’t work, as I can’t browse to it either.

>put a static entry in your local hosts file if you must use a name…
We are only trying to access it as Mrs. Napier’s S: drive. I have poked around a little when I was wondering why I couldn’t, for example, just type its host name into my web browser to go to its config page, and IIRC I got tired of figuring out how to edit the hosts file on my Mac (which required getting a special editor because just using a text editor while logged into the root account wasn’t good enough).
But, I don’t know that we “must use a name”. What I intended was that I could map the drive with Explorer Tools > Map Network Drive, and it would stay that way for her, or worst case I could show her how to do that if it doesn’t persist. Note that once it disappears, Mapping it doesn’t work anymore either.

Sorry. your use of “ipconfig /flushdns” made me think you knew more about the subject than you did.

Here’s the deal. Assuming you are using a typical configuration, your router or router/modem acts as its own DNS server. It uses both the DNS server from your ISP, but it also loads all the names of the devices you have connected to it. And everything that has a name also has an IP address. Somehow your DNS in your router is assigning the wrong IP address to the name. (I give my guesses for why in the last paragraph.)

Unfortunately, I don’t know how to tell you to get the IP for your drive. But if you had it, you could bypass the DNS problem altogether. Just replace the first part of the address (after the \) with the IP address. You say you gave the device a static IP. That’s the IP I’m saying to type into the address.

I also think it’s possible that you have your computers set up in a weird way. The typical connection would be to have a modem hooked up to the phone line, cable, or statelite. It would have a wireless router hooked up to that. Everything else is directly connected to the router. (Wireless connections will do this automatically if you have a wireless router.) In some configureations, the modem and router are the same unit. But, other than that, any other configuration is asking for trouble.

If the network is set up that way, then all I can think of is something wrong with one of the individual components (Mac, Laptop, Drive, Router). But, unfortunately, I wouldn’t know how to diagnose it over the Internet. The only thing I can recommend is a malware scan on her PC, as the part about accessing the C-drive seems weird.

I like using this one. You just boot from the CD. This will make sure no malware is running during the scan.

I used to have a 1TB Mybook World. After about 4-5 months started having problems similar to yours. Eventually after a while it died completely and couldn’t communicate with the network at all.

I hated the damn thing. It didn’t support gigabit ethernet and there weren’t any settings to tweak.

I now have a homemade NAS using the drive from the Mybook and FreeNAS on an old computer.

BigT, thanks. I understand better now. I can dig into how to find what my router has loaded regarding names and addresses.

I know the IP for the drive. “That’s the IP I’m saying to type into the address.” I understand what you meant me to type, just not where to type it. The address bar of Explorer, for example, or the pane that accepts drives to map if I don’t browse to it? I’ll try that. I’ve always browsed to drives to map them so I don’t remember that bit, is all.

> The typical connection would be to have a modem hooked up to the phone line, cable, or statelite. It would have a wireless router hooked up to that.
-Yep, I have that so far, and the router supports wireless and hardwired.

>Everything else is directly connected to the router.
-I have about 15 hard wires going into my switch, with only 3 ports on my router. I have network jacks in most rooms, and several hardwired drives including the one I’m discussing, and several security cameras, and two wireless access points hardwired in to extend my wireless network, and sometimes other devices like data acquisition engines. The router has not nearly enough ports. How can three lousy ports provide service to an entire house with various accessories?
Besides, I had the network set up this way before broadband came to my area, and added a router and a satellite modem first, then replaced the satellite modem when cable came here. Everything else seems to work fine, it’s just this one PC and this one drive, as far as I can tell.

> (Wireless connections will do this automatically if you have a wireless router.)
I do have a wireless router plus the two extra access points, and public and private guest networks. The wireless network serves DHCP in a small limited range as well as static IP. We often have guests who connect wirelessly for Internet access, and that part seems good too.

>In some configureations, the modem and router are the same unit.
Not here. There’s but one port on the modem.

Dog80, I don’t think the drive is any problem, though admittedly I can’t tell for sure. But it always works with my other computers (my Mac and a couple of PCs that I retired a short while ago), and it always works with Mrs. Napier’s as long as she hasn’t accessed any local drives since booting. Did your problems limit themselves (at first) to a single computer?

We are doing this now, and it seems to work robustly, and does not break whenever we access another resource. It may be a satisfactory workaround indefinitely.

Does the fact that it works help choose a strategy for fixing this?

Thanks, BigT