Why have my Start Menu icons disappeared...

…and been replaced by black boxes???

This just happened today. Rebooted, same thing. Ran a completely up-to-date virus check, nada. Can’t find anything in Windows Help or with a search engine.

Running Windows 98.

Just for clarity: the words are still there (Programs, Documents, Search, that sort of thing), but the icons have blacked out?

I don’t have a definite answer, but try fiddling with your colour settings, resolution and the icon size (via the “Taskbar & Start Menu Settings” option).

I see mattk, like myself, is a great advocate of the scientific method.

“Fiddle with the setting a bit, maybe it works” :smiley:

Sadly, that’s usually what gets Windows to work again.
I have experienced ruadh’s problem myself, especially after a long session of multi-tasking, or playing a game and then returning to Windows. However, a reboot always solves the problem in my case.

Ok, another completely irrational WAG: have you tried a cold reset, ruadh? That is, with the power switch off/on instead of just a software reset?

Absolutely, Coldie!

Booting up in Safe Mode, then rebooting in normal mode can sometimes help. I’ve tried the usual round of Window 98 Annoyances and Windows Help Net sites, but there’s nothing on missing start menu icons.

If re-booting doesn’t work


1: If your desktop is cluttered with icons try putting some into a desktop folder. Reduce desktop icons to only those needed. reboot

2: Change system video resolution and color depth settings and refresh - reboot

3: Delete and re-install video drivers.

If none of above work you likely have some sort of windows file corruption issue to deal with.

Could be the Windows shell icon cache is corrupted. This keeps copies of the icons around so it doesn’t have to get them from the disk everytime it needs them. It can get messed up for no particular reason, and can lead to corrupted icons. So if you have TweakUI installed, you could try the option in there to “Rebuild Icons”.

Here’s some more detailed info:

TweakUI fixed it. Cheers to all.