Why is the "num lock" light on my computer lit every time I turn it on?

This has always puzzled me. Every computer I’ve owned has had the “num lock” or number lock indicator lit when I turn it on. I usually turn off “num lock” but when I restart my computer, voila!, it’s lit again. Anyone know the reason for this?

The bios for my computer has a feature which allows you to chose if you want auto num lock detection. My WAG? Automaticly sets it because thats what most people use.

Unless you are still using an original 83-keu IBM PC keyboard, which might be a pain because they don’t really talk to anything AT or newer but they had GREAT feel and I miss them but the AT keyboard had real good feel too and will work with anything EXCEPT a PC so I always keep one handy for when I get sick of crappy new keyboards, (deep breath) why would you want your NUM LOCK off?

You could change to Windows NT, which always turns NUM LOCK off, whatever your BIOS settings, which is stupid.

Now, the important question is: What is the point of the SCROLL LOCK key? Users of Framework, the only program I’ve found that uses it, are exempted from replying, although we could get together in IMHO and get nostalgic for software that worked and did everything we needed it to and which had 64k of space in every spreadsheet cell.

(Framework is still being made, still DOS-based for speed, and able to be put on certain handhelds, in case anybody was interested.)

I had pretty much the same problem, but with the caps lock. I looked through config.sys and autoexec.bat, I found a line telling my computer to turn on caps lock, and I deleted that line. This may have been there for some reason I can’t fathom, and deleting it may have caused some problem I’m not even aware of, but as far as I can tell it didn’t have any unintended effects. But just to be safe, I hereby disclaim any liability for whatever may happen if you start screwing around with your autoexec.bat or config.sys.

I have the same problem. Do you have kids too?

Cant you just tilde that instead of risking deleting it? I think that would work.

As a programming student (therefore I know enough to sink myself in any debate with someone who knows what the hell they’re talking about) I do know for a fact that it’s on because most people use it that way. In part because most business\retail users use it. Ever see a clerk enter a UPC code on this config? I can’t blink that fast.

Hmm. Can anyone tell me what line(s) I should add to my config.sys and/or autoexec.bat to get my NumLock to come ON whenever I boot up? The damn thing is off all the time, and it’s really annoying. Thanks.

Autoexec.bat: I believe you add NUMLOCK = ON and that works. It’s either that or NUMLOCK=TRUE. Try both. Conversely, NUMLOCK=OFF should turn off your numlock at boot.


Go into your CMOS setup (usually accessed at cold boot time by holding down the DEL key until it hiccups). There is a setting in most CMOS options to have NUMLOCK default to on or off as you desire.

Of course, this may be overridden by other programs after boot.

I don’t know if this works in 95/98/ME, but in NT/2000, you have to change the in the registry key:

HKEY_CURRENT_USER\Control Panel\Keyboard\InitialKeyboardIndicators the value from 2 to 0.

And of course, before you play with your registry, be careful, back it up, say a prayer, send me cash, etc. etc.

Easiest way is to turn numlock at startup off in the bios, if you are not familiar with the bios then ->Include the command NUMLOCK = OFF somewhere in your CONFIG.SYS file (on its own line)