Win 7 network problem - can't see NAS in Explorer

Computer: Windows 7 Home Premium
Router: Asus RT-N66U
Network Storage: QNap T212 2-bay NAS

NAS Name: HOMENET
NAS Local IP: 192.168.1.50, Fixed

Problem:

When i want to use the NAS from my local computer, i usually just navigate to it through the Network section of Windows Explorer. It shows up as HOMENET, and i can just drag and drop files back and forth, like any other drive.

Now, HOMENET has disappeared from Explorer, and i can’t get it back. I’ve tried to map a network drive, both from Windows Explorer, and from the software that came with the NAS. I’ve also tried navigating to the NAS in Explorer, using \HOMENET and \192.168.1.50, but when i try that i get:

When i try to have Windows diagnose the problem, it can’t find a solution. The error number is 0x80004005. I’ve looked it up, but haven’t found a solution.

When i click on Network, it does show HOMENET under “Other Devices,” but when i double-click on the icon, instead of opening the folders, it redirects me to the NAS IP address in my browser.

The odd thing about all this is that i can see and use the NAS from the computer in every other way. I can access it through my browser just fine. I can access it via FTP using Filezilla. I can ping it from the command line. I also have PureSync synchronization software set up to back up my local files to the NAS, and the sync still works fine.

The only place that can’t work with the NAS is Windows Explorer.

Also, my own computer appears in my Network places in Explorer, as DESKTOP. Now, when i click on it, Explorer tells me that \DESKTOP is not accessible. How can my own computer, the one i’m actually using, not be accessible on its (my) own network.

It’s not clear to me exactly when this problem began, because i’ve been busy and haven’t tried to access the NAS in about a week. I ran some Windows updates recently, so i guess it could have been that.

Anyway, if anyone has any suggestions, i’d be happy for the help.

I don’t have any real suggestions, but I would start by rebooting both the NAS and the computer.

Check your DNS settings on both devices.

That was the very first thing i tried. No dice.

They’re both currently set to obtain a DNS server address automatically. That’s always worked fine in the past. The NAS shows its current DNS address as the IP address of my router (192.168.1.1). A check of “ipconfig /all” on the computer shows the same address in the DNS Servers section.

Would setting the DNS values manually fix the problem? If so, do you have any advice? Would i just set both of them for the IP address of of the router? That seems sort of redundant, considering both devices are automatically using that address anyway.

Also, if DNS settings were really the problem, wouldn’t that also cause problems for all the other programs that, at the moment, can see the NAS just fine?

Did you (or an update) mess with File and Printer Sharing? Maybe try the troubleshooting steps here?
http://windows.microsoft.com/en-us/windows-vista/troubleshoot-file-and-printer-sharing

It sounds like the network is working fine, but the SMB protocol is acting up.

Good. I feared a DNS hijack.

I wonder if the IP address has changed and Netbios hasn’t updated itself? Have you tried IPCONFIG /FLUSHDNS and NBTSTAT -rR (please note the switch is case sensitive)? This flushes the local DNS and NBT caches. I suspect the latter is the more important command. You might also add ARP -d * (again, the switch is case sensitive).

How would DNS know about the computers on your home network?

I looked at the information there, and tried following the steps, but nothing seemed to work. Network discovery is on, as are all the other settings that should be, as far as i can tell.

I did, in my searches, find this. It looks like the problem i’m having, and they have a hotfix available, but they say not to use it unless you have the specific problem described. Do you think i should give it a shot?

I’m getting to the stage where i’m just going to say “Fuck it,” and use my FTP client to move files around. It works fine, and i can drag and drop just like in Explorer.

Hmm. I can’t say since I don’t have the same problem, but in my experience most hotfixes are pretty harmless and can be uninstalled from Add/Remove Programs if it doesn’t work…

For what it is worth. I have a similar problem with my home network. My desktop did not equate tera1 with 192.168.1.14 which is the IP address of my NAS named tera1. I fixed this problem by adding tera1 to the host file on my desktop and configuring my router’s DHCP to always assign 192.168.1.14 to the nas.

I know it’s a few months since i started this thread, but i wanted to give an update, in case anyone else comes across this problem.

As i said in a previous post, i pretty much gave up for a while, and just decided to use my FTP client to access the NAS. But i was still irritated at not being able to see my network in Explorer, so when i had some spare time this week i did some more internet searching and some more messing around.

In the end, the fix was ridiculously simple.

  1. Go into network adapter properties

  2. Uninstall Client for Microsoft Networks

  3. Install Client for Microsoft Networks

Done, and i can now see my NAS again, and drag and drop files to it from Explorer. I don’t know what was wrong with the network client, but reinstalling worked.

I spent a week on this issue.