Win2k3 (x64), iSCSI and NFS

Okay, sysadmins, ever see this issue before?
We have a Promise vTrak M500i connected via iSCSI to a Windows 2003 R2 (x64) box. The Windows box mounts the vTrak without any problems.

We also have a few Ubuntu machines that connect to that vTrak via the Windows server and Server for NFS service (comes with Win2K3 R2 and replaces the old Services for Unix). The problem we’re running into is that each time we try connecting to a folder on that volume with NFS share permissions, we get “access denied by server” messages.

Looking at the System event log, however, we get the following error message: “Server for NFS failed to initialize on volume with drive letter X:.” X corresponds to the mount letter for the vTrak. These messages correspond to our connection attempts.

We’ve rebooted the server and the vTrak; we’ve uninstalled Server for NFS and reinstalled it; we’ve removed and added back in the iSCSI connection, and yet the problem continues. Searching for this same error in Usenet and the web gives us no information (except one HP pdf document that doesn’t apply in our case). So now, one step away from calling Microsoft, we’re not sure what else to try.

Anyone ever see the event log error before? Or have any other suggestions–or maybe better luck with Google-Fu powers?

Try installing Samba on the Linux boxes instead. I remember having a fair few problems with NFS and NT.

We’ve discussed doing that, Quartz, so that may be the end result once we get tired of futzing around with it. I should have mentioned, though, that it was working before, for about a year. I originally thought it was a Windows update that caused the problem, but an uninstall of the updates applied around the report of the problem failed to fix anything.

NFS still works on that system; in fact, I can create another share on a different volume and I’ll be able to mount it without any problems. It’s just this one iSCSI-attached volume that’s presenting the problem. If it weren’t for me taking over the project from someone who left, I’d jump to Samba right away; however, since I don’t know why he did it this way, I’m going to try to fix it first, and then make plans to migrate the connection later.

Have you tried looking on ?