Win98 error

Well, it’s been too long since I used to do this sort of thing for a living: I’ve got a problem that has exhausted my troubleshooting skills.

If I try to execute a program from the Run line or if I click on a link in IE that would normally launch a helper app (like Media Player for MPEG files), I get this message:

Searching the KnowledgeBase at turned up this article, but that article uses a (very) slightly different wording of the error message. In the version I get there is a discernable blank space where the wording given in the article says “it.”

The troubling part of this is that Windows seems to be reading what I type in on the Run line as a URL, which leads me to believe it is a file association problem.

I am really hoping to avoid being in an upgrade situation here if I can avoid it, so I’m hoping y’all can help.

Win98, IE 5.5, other reference available upon request

The first thing I would try is repairing IE. Go to Start|Settings|Control Panel|Add/Remove Programs, select Microsoft Internet Explorer 5.5 and Internet Tools and hit Add/Remove. This will bring up a dialog box with three choices. Choose Repair Internet Explorer and hit OK. This will reinstall IE’s files and then prompt you to reboot. It doesn’t change any of your settings and is pretty safe.

If that doesn’t work you might want to try the procedure in this article. I’ve never used it, but it sounds like it might pertain to your problem. Be sure to back up the registry beforehand.

IIRC, the Run box only executes programs, so make sure you enter the proper path for a program. If you aren’t sure, search for it with Explorer.

Thanks for the replies.

Number, I tried the Repair thing last night to no avail. That Reg fix looks like a possibility, though the symptom it describes is not what I’ve got, at least it tells me whereabouts in the registry to look for possible things to smack around.

Urban, I’ll try that, but I don’t expect any difference. Anything that’s in the Windows directory shouldn’t need to have its path specified. For example, I’ve always been able to open the Run line and type “command” to get a DOS window. Now I get the error. Like I said above, if typing in the path gives me what I want, at least that will tell me a little more about what’s wrong.

My computer’s at home, on the other end of a workday from me, so it will be this evening before I can try anything. I’m still open to any suggestions from other Dopers, as well.

You can reinstall w98 on top of itself & it should keep your programs.

Do a virus scan too.

Usually I would just type SFC in the run box, thats the system file checker for W98 but I don’t know what you can do if you can’t use the box.

You can try the tips that you will find in this magazine article :,4149,243552,00.asp

Odieman, when I follow that link I go to an article on one of their download products. Can you verify that that is what you meant for me to find?

I tried SFC, handy, and it found that my user.exe file was corrupted. Unfortunately, when it replaced it, I couldn’t even start Windows, much less access my Run line. So I put the backed up version back in place and now I’m back to where I started from.

I am starting to think that the reinstall solution is all I have left.

“I am starting to think that the reinstall solution is all I have left.”

Worked for me.

Also, kinda fun, is SCANREG RESTORE…from a DOS prompt.

I dont remember if W98 uses it, but it can restore a previous registry.

I forgot the exact syntax, I think its (this is on the DOS prompt, boot to Dos): scanreg /restore

Yeah, I’ve thought of that too. I have kept one of those rb*.cab files set aside from before I started having problems.