Windows media player question.

Windows media player seems to play every other track in my playlists (in other words it skips every other track, playing only half of the tracks in the list), even though I don’t have shuffle selected.
How do I stop it from doing this?! I didn’t ask it to do this. And I certainly don’t want it to.

Dis you try playing the ones it’s skipping? This is just a WAG but maybe the ones it’s skipping are incomplete/bad/moved files.

I can’t believe I only got 1 reply to this question after all this time!..

The ones it’s skipping are not incomplete or bad. I can play them if I click on them. It would be a major coincidence if “incomplete or bad file” was the reason when you consider how uniformly it skips them (i.e. it plays one, skips one, plays one, skips one, plays one etc…)
…so, I am reviving the question (by posting to it) and asking again… for some more informed replies.


I am assuming that this happens with your Audio CDs and not mp3 files.

In that case it may be a bad CD or Bad CD drive:

1> List of CD Drives with known problems with WMP - here

2> Try this if your CD Drive is not listed above: Turn on Error Correction in WMP’s Tools:Options:CD Audio menu [this is under WMP’s Tools:Options:Devices menu for the specific drive in WMP8 and newer]. If that doesn’t help, switch to using Analog playback using WMP’s Tools:Options:CD Audio menu Tools:Options:Devices on Windows XP) . Note that this will disable visualizations (unless you are using Windows XP).

It’s with mp3s that it happens. My CDs play fine (except I have to play them on analogue which means I don’t get the theraputic graphic equalizer or the bass and treble)

PING! I just had an idea. I will create my own mp3 player! that way it will do exactly what I want it to do (or more acurately it will do what my programming abilities will let it do)

(this does not mean I do not require more replies. I do)

Nitpick :

The mp3’s are on your hard drive or on a CD ? If on CD, I can see the problem.

They’re on the hard drive.
It is beginning to look like this is not a well known ‘bug’. people are clutching at straws.