Wireless LAN driver help please


Dell Alienware m17x r3 laptop running windows 7 home premium.

base model with intell i7 core, radeon graphics card(s) and I just recently installed a 2nd hard drive

Due to glitches, hang ups, and generally derpy behavior, I decided to try to “repair” windows through the recovery partition. It didn’t work because I didn’t have a factory image on the disk…in the recovery partition.

No matter, though! I have the disk(s) that came with. Windows 7 Home Premium sp1 and the m17x r3 resource DVD with presumably my drivers on it.

You must do one driver at a time, In a special order, which You must look up on the Dell site.
Done, except the wireless controller. I can plug in to the router, but I cannot even see wireless connections much less connect to them.

Allow the computer to put to sleep is off, I have tried to install all the drivers on the resource disk, and they all say that there is nothing there for the driver to run and it will not be installed.

Why is every laptop like this? Hp Dell Sony Viao, I have had problems with all of them, the drivers for the wireless card are buried deep on their websites, buried under tons of other crap. Hard to find, must stand on head to install. Don’t forget your VooDoo doll, or it still won’t work.
Any help for me out there?? Thanks

Not buried at all. Found it in about 2 minutes…


Choose the network category and find your driver (while hardwired to your router, of course). Hope this helps!

Been there, and downloaded it. Get the same error, that there is no hardware for this. The software will not be installed.
The good news is, after installing the belkin wireless usb and letting it update it evidently found what it needed to find ((The built in wireless card)) and automatically installed the drivers.
Now all I need to do is find the software that came with my laptop that I would like back.
Thank you Orionizer.

Sorry, I must have misread your OP - I thought you were saying the drivers were buried and you couldn’t find it.

Glad you got it sorted out, though!