Write-protected USB: how to un-protect?


for some reason, USB pen drives that have entered in contact with my university’s lab computers tend to become “write protected” (or to be perceived as so by other computers). Is there a way I can un-protect the stupid drives from a different computer using Windows XP? I can’t see anything in the right-menu.

Any ideas why this would happen?


Not sure why it would happen, but the usual way to un-write-protect a drive in XP is to right click on it (either a short cut or under “my computer”), select properties, and on the general properties tab make sure the “read-only” box is unchecked (no solid box either which would indicate some sub-folders are write protected and others aren’t))

Is there a switch on the USB drive? I had a user with this problem and she had accidentally switched it to read-only. Not all flash drives have one, though.

I’ll kill whomever designed this thing. Oh, wait, no, it’s illegal.

There was no “read-only” under General (I’d already looked) and no physical switch I could see. I’d looked. And looked again. Nope, nothing.

But the USB has a sort of pivoting cover (it’s one of those keychain drives, with a logo on the cover) and I wondered… yep, turning it one way makes it “write protected”, turning it the other way makes it behave properly :smack: Well, at least I can stop blaming the university’s IT…