WTF is happening with/did I do to Google Maps?

Whenever I got to Google Maps lately, I end up on some form of “https://www.google.com/maps/preview,” which generates a non-functional crappy map. I can revert to the regular map by clearing recent history (cache/cookies/etc.), but the useless preview comes back the second time I go to maps.googl. As far as I know I didn’t respond to Google’s nagging and try out their new interface; it just keeps defaulting to it. None of my other machines are having this problem (the problem machine is FF 27.0.1; NoScript and Ghostery are not blocking anything).

Any thoughts?

That’s their new map. For some reason it automatically started working on my pc at home, but not at work. I have no idea why. All I know is that I wish it would come with some sort of tutorial or something. Even tool tips would help. I have no idea what those three pictures (in the bottom right, above the “1 km”) do. In the old maps, I could easily right-click a spot, and then click on “Directions to here” or “Directions from here”, and other options. Now I have no clue.

Works the same way in the new maps.

It’s non-functional for me. Well, I can control-scroll to zoom in and out, but the search bar doesn’t search and the icons in the lower right don’t do anything. I have no right-click menu and I can’t drag the map around. If it’s working elsewhere, I’ll assume it’s a troublesome extension, but in the meantime is there any way to get the original map interface back?

What browser are you using? That could have something to do with it. I’m using chrome. To go back to the classic maps, you should be able to click the question mark icon at the bottom, and then select “return to classic google maps”

I will never stop complaining about “improvements” that are worse than the original, in just about every software I’ve ever used. Sure, it involves job security for some people . . . but needless frustration for the rest of us. Oh, and no manual or tool tips? That’s par for the course.

Click on the ? in the bottom right, then choose “Return to Classic Google Maps”

My favorite example is the clock in the lower right corner in Windows. In the Windows 3.1 version, you could easily set it to show not just hours and minutes, but seconds too. (Very convenient to look at and time how slow things are going.) They took it out in Win 95, and never even enabled it as an option. Why? Does it kill that much screen space? Does it use that much power?

Fukkity fuck. I can disable all add-ons, then it works (and much slower than the original map), and the question mark works. But though it swtiches back to the original there, when I reload with extensions the ‘preview’ map is back, and the question mark doesn’t work.

I disabled the obvious extensions, now it’s a matter of hunting and pecking. What a pain in the ass.

If anyone else stumbles on this thread with a similar problem: it was the add-on Smart Video for Youtube (a handy tool to return to buffered videos) that was preventing me from getting to the options. I disabled it, returned to the classic map, re-enabled it and all is well.

Left some negative feedback about the amount of space they decided to take up with information I’m not looking for. If I wanted to know about a location, I’d be searching on the web, not in a map. And what’s with all the white space? I like a clean layout, but not when it’s blocking the freakin’ map. :mad:

There is a tutorial that pops up every time I’ve opened it on a new computer.

My main complaint: I can still double click to zoom. But double right click to zoom out is gone. Yeah, scroll wheel works, but that’s less precise and sometimes skips zoom levels, so it’s that or clicking zoom or +/-

From the description, it sounds like what Youtube Center does. It adds an icon in the upper right and I disable stupid Dash preloading. No conflict with Maps as far as I see.

That would spoil the fun of the masturbatory twit nerds who create the “enhanced new surfing experience”, along the likes of the highway repair workers chuckling at the long lines of stationary traffic behind the orange cones.

Click on [maps labs] lower left, right above copyright. Then enable [Go to Beta], and come back and report what happens. . Mine is not fukt up yet, so I’m afraid to diddle with it.

Streetview is more awkward as well. The wheel to rotate the view doesn’t rotate freely any more, so if you’re somewhere with no empty space to grab and turn the view yourself, you can only turn at set increments. Not what I’m looking for. And it seems to stick more as you try to move along roads. The huge nonsense they’ve got covering the top left of the map is just irritating.

Can anyone tell me how to get the topographic overlay back? I liked looking at contour lines and elevations.

And you’re limited on the size of the simultaneous plain map to refer to, as well. It’s now just a thumbnail-sized one in the lower left-hand corner. I used to expand the plain map as a viewing pane across the whole bottom of the screen, and it was easy to drag “pegman” several streets or cities away in big jumps. Now you’re limited to dragging him only a couple of blocks away at most.

Oh, and I’m still pissy that there is no way to access the Dragon Warrior overlay from a few April Fools’ ago.

Google has never had contour lines or elevations—though you can see shaded relief by choosing the Terrain option.

For topo maps, best to use http://www.mappingsupport.com/p/gmap4.php
Zoom in pretty far, then choose t4 in the upper right corner.

That’s what I meant.

Super! Thank you! That’s not only what I wanted, it’s way better than I expected! Mil milion gracias! Hot dog, that’s the happiest I’ve been all day!

Thanks for the kind words about Gmap4 and its ability to display really nice topographic maps. I am the developer.

Here is a related feature I recently added.

  1. Change the basemap to the Google aerial
  2. Click the scale symbol at the bottom of the map so it shows miles/feet
  3. Zoom in so the scale says 200 ft
  4. Open the menu that lets you change the basemap, look at the bottom of the list, click USA_contour_lines.

The contour (i.e. topo) lines appear on the aerial.

Click USA_contour_lines again to turn that overlay off.

The Gmap4 homepage has a FAQ, examples, quick start info (in the Help file) and more to quickly get you up to speed.

Gmap4 default map: http://www.mappingsupport.com/p/gmap4.php

Gmap4 homepage: http://www.mappingsupport.com/p/gmap4.html

Joseph, the Gmap4 guy
Redmond, WA