XP locking up when idle - PC geek calling for reinforcements!

OK, I’m about as PC geeky as they come but I’m having a doozy of a problem with my PC at home.

When XP is idle for about 10 minutes, it locks up. Sometimes I can catch it before it locks up solid and the mouse will still work but everything else is unresponsive. 3 finger salute does not work, and neither does the power button. Only a hard reset will get me out.

This only happens when idle. Last night I left Everquest running for 8 hours without any keyboard/mouse activity with no problem. There has to be a process running that only kicks in when the PC is idle, but I can’t figure out what it is.

What say you all? I’m about at the end of my rope, and a reload in imminent unless I can get this figured out today.

My troubleshooting so far…

  • Checked system resources, I left Process Monitor running, and no CPU/memory issues.
  • I disabled all power saving in windows and the BIOS.
  • Disabled all unneeded services, including Indexing. Also shutdown all processes except Microsoft specific things.
  • Disabled System Restore on all drive.
  • Checked power/temp in the BIOS right after a lockup. Temp is low 40’s and no real issues with the voltage.
  • removed that MS patch that screws with XP (811493? something like that)
  • Assume all up to date drivers.
    My system:
    Athlon 1900+
    MSI MB
    3 hard drives (JBOD on MB RAID controller - HPT 370)
    1024 meg Crucial PC 2100
    XP Pro SP1/most hotfixes
    SB Audigy
    ATI 9700 non-pro (flashed with 9700 Pro bios)
    Antec 400W power supply
    tons of fans
    CD-ROm (master on Primary IDE)
    CD-R (master/secondary)
    6 USB devices with powered USB hub.
    3com 10/100 NIC

This might seem funny, but try turning off the screensaver. Stranger things have happened than a buggy screensaver.

In my case, the few times XP has locked up mysteriously and repeatedly it was ultimately traced in those individual circumstances to

1: Overheating motherboard

2: USB device conflict

3: Bad memory

4: 3rd party driver for Logitech “ifeel” mouse
In your case it sounds (possibly) like the power down hibernation mode is not being properly implemented. If you have already played with the BIOS power and windows power applet settings I would look at the BIOS and Windows options section(s) controlling how the hard drives are supposed to behave in idle and how quickly they are supposed to spin down. Also see if there are any MB BIOS patches. You are likely not the only one having this problem with this MB .

As a side note some users of NAV 2003 have reported this “lockup in idle” behavior.

Usually the first thing to check is you computer getting hot from heat. That you can do by opening the case & pointing a big fan at it.

Thanks for the suggestions all.

I don’t think it is a heat issue. Like I said in the OP, I checked the heat, plus I have 4 fans running in the case including a 5" fan pointed at the video card/CPU.

Also, the screensaver was turned off as part of my troubleshooting. I forgot to mention that.

Does anyone know of any other XP processes that kick in when idle?


I found some in the Support Center by searching it for: idle

Pick a task
Synchronize offline items while your computer is idle
Run a scheduled task when the computer is idle
Allocate system resources for an MS-DOS-based program

Hmmm, I seem to recall there’s a finder or indexer process which runs when idle (or at least did on older windows systems). You can disable it from the drive properties dialog, the one with the space free pie chart, and it’s the checkbox at the bottom “Allow indexing service …”. Try switching that off on all drives.

Some questions: Has it always done this, or is this a recent development ? Do you have an up-to-date Virus Checker running ? Have you run ad-aware, or similar spyware remover, on it ?

It certainly sounds like some power-saving mode kicking in for some reason, maybe not a software one but a physical one. Perhaps the hard-drives spin down when idle and don’t spin back up again properly (not easy to test this tho’). If it’s not that then I’d be suggesting virus or spyware.

Dodgy memory is also a possibility, but I’d expect this to happen when busy rather than idle. Is it part of a network ? What’s the internet connection like, could that be the cause ?

That’s all I got for now,



Yeah, it’s that damn System Idle Process. It’s always hogging up all of my resources.



I also forgot to mention that I’m spyware and virus free as well.

That’s it. I’m stumped and it’s not worth wasting any more brain cells on it. I see a format coming in the very near future.

Thanks to all for the suggestions.

Do yo have virus scanning set to background scan when the PC is idle? That would be my bet.

Create a Restore Point, then restore to an earlier registry that works.

We have been having the same type of problem with EQ.
A couple of things that seem to be helping.
They all seem to come down to something running in the background, and EQ not being willing to share resources.

  1. Turn of the virus scan
  2. If you have a firewall running, that can cause conflicts.
  3. Make sure that your virus protection software isn’t autoupdating.
  4. Make sure that Windows isn’t Autoupdating (This one has been the problem for a couple of my friends)

I think it’s obvious: Your computer is jealous. Whenever your attention wanders (i.e., the computer goes idle), you are not paying attention to the computer. Windows XP, which is simply the conscious manifestation of your computer’s psyche, goes into a hissy fit and locks up the system tighter than Dick Cheney holding on to a subpoena’d document.

I would look into your power-saving settings, like SpaceDog suggested. See if the screensaver/standby mode is set to kick in at 10 minutes. Try setting it to 15 minutes. If the lock-ups happen at 15 minute intervals, you’ve found the culprit.

I think some hardware can’t recognize the “wake-up” signal used to bring the computer out of sleep mode.

Just a closure bump.

I found the cause to my lockups… I checked the voltages on my +5v rail, and it was way out of spec (down to 4.50v). Aha says I, and proceed to try another power supply.

It took some serious pulling to get the power supply plug out of the MB socket, and when I tried to put in a new power supply I noticed that the new PS would not fit in the MB socket. A quick glace with a flashlight confirmed why… my MB socket had several charred pins as well as some meltage.

My old power supply showed the same meltage. My trusty Antec 400W power supply had killed my motherboard, or my motherboard had killed my power supply but either way my beast is dead until I can scrape up the cash to get a new MB/PS. I only hope that my processor/memory didn’t get damaged.

Now, how my PC managed to hold on as long as it did and why it worked right up until I disconnected the power I’ll never know. Why it only locked up when idle is another mystery.

Thanks to all who gave some really excellent advice.