Yet another strange monitor problem

Well, probably a registry problem.

I used to have a CTX 17 inch monitor, but some time ago it went pffft. I replaced it with a Mac multiscan 17 monitor with a plug adaptor. Now, whenever I run a DOS app that runs full screen, or the power saving turns the screen off, about 80% of the time the display comes back in the wrong mode. I normally run 1024x768, 16 bit color. After the screen restores it is in 640x480 with the virtual desktop much larger than the physical desktop. Moving the mouse to the edges of the physical desktop changes the part of the virtual desktop shown. Icons and the start button still work, but it’s rather hard to read like this. Thinking that the Mac monitor might be part of the problem, I switched it with a ViewSonic 17EA. Same problem.

Has anyone seen anything like this before? What can I do about it? (Reinstalling Windows is NOT an option.)

Motherboard: Mitac 5114VU
Video: AGP controller (integrated VT82C8501), supporting 2.0 AGP interface and 64-bit graphics acceleration
Processor: AMD K6-III 533MHz
OS: Windows 98/SE
Possible extenuating circumstances: ATI TV Wonder VE (worked fine with the CTX)

Please don’t suggest looking through the registry for CTX. Directx matches thousands of keys.

Not sure I quite understand the problem, but you may want to check in your control panel and see if any of the accessibility options are running. It almost sounds like you’ve got some soft of magnafier running. BTW you suggest that this happens often. How do you chage it back each time.

I don’t have the accessiblity options installed. The only way to get it back to normal is to reboot.

Let me try to restate the problem. After the display is restored icons, toolbars and open windows are much larger. The display is much larger than what will physically fit on the screen. Moving the mouse cursor around the screen causes the part of the display shown on the screen to change.

I hope this is clearer.