The Straight Dope

Go Back   Straight Dope Message Board > Main > General Questions

Reply
 
Thread Tools Display Modes
  #1  
Old 09-21-2007, 09:46 PM
ambushed ambushed is offline
Charter Member
 
Join Date: Apr 1999
Posts: 2,661
Why is Google's main page in a foreign language?

I just opened Google's main search page and here's what I found:

Quote:
Originally Posted by Google
Google Malti

Web Stampi Gruppi Direttorju

Filtex Bil-Google Inhossni XXurtjat

Tfittxija Avvanzata
Preferenzi
Għodda Lingwistika

Kullma trid tkun taf fuq Google - Google.com in English
WTF?

It happens every time, too. I've never visited any site in that language (whatever it is). I'm an English-only kind of guy. I looked at my Google cookies, but the strings therein are impenetrable.
Reply With Quote
Advertisements  
  #2  
Old 09-21-2007, 09:53 PM
Q.E.D. Q.E.D. is offline
Charter Member
 
Join Date: Jan 2003
Location: Richmond, VA
Posts: 22,536
Go to the main page and click the middle link just to the right of the Search text bar ("Preferences" in whatever language you have set currently). The very first dropdown menu is for the language setting. Pull it down and locate the entry for English (it will be the word of English in the currently set language) and click it. Then click the button near the top right of the page, which is Save Preferences (The button text will also read in the current language).

Last edited by Q.E.D.; 09-21-2007 at 09:54 PM..
Reply With Quote
  #3  
Old 09-21-2007, 10:17 PM
thelurkinghorror thelurkinghorror is offline
Guest
 
Join Date: Jun 2006
Maltese. Clearly the Knights of Malta have chosen you to deliver the Holy Grail to save the world.
Reply With Quote
  #4  
Old 09-21-2007, 10:21 PM
ambushed ambushed is offline
Charter Member
 
Join Date: Apr 1999
Posts: 2,661
Quote:
Originally Posted by Q.E.D.
Go to the main page and click the middle link just to the right of the Search text bar ("Preferences" in whatever language you have set currently). The very first dropdown menu is for the language setting. Pull it down and locate the entry for English (it will be the word of English in the currently set language) and click it. Then click the button near the top right of the page, which is Save Preferences (The button text will also read in the current language).
Sure, I know how to fix it. But these settings were all set to "English" already!
Reply With Quote
  #5  
Old 09-21-2007, 10:21 PM
Q.E.D. Q.E.D. is offline
Charter Member
 
Join Date: Jan 2003
Location: Richmond, VA
Posts: 22,536
Or you can just click that link that says "Google.com in English. After some experimentation, I see it does the same thing as the instructions above, only easier.
Reply With Quote
  #6  
Old 09-21-2007, 10:23 PM
Q.E.D. Q.E.D. is offline
Charter Member
 
Join Date: Jan 2003
Location: Richmond, VA
Posts: 22,536
Quote:
Originally Posted by ambushed
Sure, I know how to fix it. But these settings were all set to "English" already!
Huh. Did you try clearing your cookies?
Reply With Quote
  #7  
Old 09-21-2007, 10:26 PM
ambushed ambushed is offline
Charter Member
 
Join Date: Apr 1999
Posts: 2,661
Quote:
Originally Posted by thelurkinghorror
Maltese. Clearly the Knights of Malta have chosen you to deliver the Holy Grail to save the world.
A blessing! A blessing from the Lord!
Reply With Quote
  #8  
Old 09-21-2007, 10:27 PM
ultrafilter ultrafilter is offline
Guest
 
Join Date: May 2001
Are you connected through a proxy or doing something else that would change your IP address? Google seems to be smart enough to redirect you to their homepage for the country they think you're visiting from.
Reply With Quote
  #9  
Old 09-21-2007, 10:28 PM
Sunspace Sunspace is offline
Charter Member
 
Join Date: Jun 1999
Location: Near the GT eeehhhh...
Posts: 26,625
If it's not Google's own settings, check your browser preferences.

Your browser can be set to 'prefer' pages in specific languages, and if the webserver has a page in one of the preferred languages, it will serve that page up instead of the site's default page. Usually there's a list of languages, ordered by preference. The browser negotiates with the webserver something like this: "I'll take French if you have it, if not I'll take Esperanto, if not I'll take UK English, if not I'll take any other form of English, if not I'll take whatever you have."

Maybe someone was using your browser in Maltese and forgot to set it back.
__________________
Rigardu, kaj vi ekvidos.
Look, and you will begin to see.

Last edited by Sunspace; 09-21-2007 at 10:30 PM..
Reply With Quote
  #10  
Old 09-21-2007, 10:33 PM
ambushed ambushed is offline
Charter Member
 
Join Date: Apr 1999
Posts: 2,661
Quote:
Originally Posted by Q.E.D.
Huh. Did you try clearing your cookies?
No, but as indicated in my OP, I examined them (for whatever that was worth). But how could the cookies have been changed to Maltese, since I've never done anything that could even remotely have anything to do with Malta or the Maltese language?

If it was some kind of malware attack (which I tend to doubt with all the anti-virus and anti-malware programs on my system), that'd be a rather silly thing for a virus to do, don't you think? Of course, there have been intentionally silly viruses...
Reply With Quote
  #11  
Old 09-21-2007, 10:35 PM
ambushed ambushed is offline
Charter Member
 
Join Date: Apr 1999
Posts: 2,661
Quote:
Originally Posted by ultrafilter
Are you connected through a proxy or doing something else that would change your IP address? Google seems to be smart enough to redirect you to their homepage for the country they think you're visiting from.
Nope. Nothing like that at all. Plain, vanilla Internet setup.
Reply With Quote
  #12  
Old 09-21-2007, 10:39 PM
ambushed ambushed is offline
Charter Member
 
Join Date: Apr 1999
Posts: 2,661
Quote:
Originally Posted by Sunspace
If it's not Google's own settings, check your browser preferences.

Your browser can be set to 'prefer' pages in specific languages, and if the webserver has a page in one of the preferred languages, it will serve that page up instead of the site's default page. Usually there's a list of languages, ordered by preference. The browser negotiates with the webserver something like this: "I'll take French if you have it, if not I'll take Esperanto, if not I'll take UK English, if not I'll take any other form of English, if not I'll take whatever you have."
Good suggestion. I'm using FireFox and when I looked at the "Languages" settings in the "Advanced" page, it has only two entries: English/United States [en-us] and English [en].

Quote:
Originally Posted by Sunspace
Maybe someone was using your browser in Maltese and forgot to set it back.
I'm the only user on this, my home machine.
Reply With Quote
  #13  
Old 09-21-2007, 10:43 PM
Sunspace Sunspace is offline
Charter Member
 
Join Date: Jun 1999
Location: Near the GT eeehhhh...
Posts: 26,625
Quote:
Originally Posted by ambushed
Good suggestion. I'm using FireFox and when I looked at the "Languages" settings in the "Advanced" page, it has only two entries: English/United States [en-us] and English [en].

I'm the only user on this, my home machine.
Hmm. Okay. Your Google prefs aren't set for Maltese, and your browser's not set for Maltese. I dunno than.
Reply With Quote
  #14  
Old 09-21-2007, 10:51 PM
Sunspace Sunspace is offline
Charter Member
 
Join Date: Jun 1999
Location: Near the GT eeehhhh...
Posts: 26,625
Another thought. Did you inadvertently simply go directly to the web address of a Maltese Google page?

The URL of the main Google page in any language is

http://www.google.com/intl/<language_code>/

where <language_code> specifies the desired language. For Maltese it's "mt", so the address of the main Google page in Maltese is

http://www.google.com/intl/mt/

Alternatively, the Google page for Malta itself is

http://www.google.com.mt/ .

Last edited by Sunspace; 09-21-2007 at 10:51 PM..
Reply With Quote
  #15  
Old 09-21-2007, 11:04 PM
ambushed ambushed is offline
Charter Member
 
Join Date: Apr 1999
Posts: 2,661
Quote:
Originally Posted by Sunspace
Another thought. Did you inadvertently simply go directly to the web address of a Maltese Google page?
Another good suggestion. But I'm afraid that couldn't happen because I used a pre-set button to go to Google's main page, and did not type in the URL myself.

Note, by the way, that it's working fine now.

Last edited by ambushed; 09-21-2007 at 11:05 PM..
Reply With Quote
  #16  
Old 09-22-2007, 07:19 AM
Joey P Joey P is offline
Charter Member
 
Join Date: Jun 1999
Location: Milwaukee, WI
Posts: 21,614
Okay, my guess, though it's probably way off.

Every once in the a while someone on the board posts the instructions for doing google in another language (Swedish Chef, Pig Latin, Yiddish, I see Maltese on the list) is it possible you were playing with that and somehow made it your homepage?

Oooh, one more. Is google in your favorites? if you start typing something that's in your favorites it will come up in the URL bar. For example if I type in my URL bar "the str" it will automatically pop up as "The Stright Dope" and come to this site. It you had google.com/intl/mt in your favorites it might automatically come up when you start to type google. Hmmm, maybe?
Reply With Quote
  #17  
Old 09-22-2007, 09:36 AM
robcaro robcaro is offline
Guest
 
Join Date: Nov 2001
I live in Colombia and have never had a problem bringing up Google in English. I do, however ask Google to present searched items in English and Spanish. That seems to work OK. I get more English language searches than Spanish.
__________________
A committee is a thing which takes a week to do what one good man can do in an hour. ~Elbert Hubbard
Reply With Quote
  #18  
Old 09-22-2007, 10:27 AM
Derleth Derleth is offline
Guest
 
Join Date: Apr 2000
It has to be IP address weirdness. Somehow, your Internet connection is getting routed through Malta in such a way that Google thinks you want to be spoken to in Maltese, my precious little falcon. It shouldn't be possible, but neither should it have been possible to get out of Casablanca.
__________________
"Ridicule is the only weapon that can be used against unintelligible propositions. Ideas must be distinct before reason can act upon them."
If you don't stop to analyze the snot spray, you are missing that which is best in life. - Miller
I'm not sure why this is, but I actually find this idea grosser than cannibalism. - Excalibre, after reading one of my surefire million-seller business plans.
Reply With Quote
  #19  
Old 09-22-2007, 11:09 AM
Sunspace Sunspace is offline
Charter Member
 
Join Date: Jun 1999
Location: Near the GT eeehhhh...
Posts: 26,625
It could be aliens. Maltese aliens. In which case you may be lucky, because Maltese women can be hot (at least, the one I knew slightly back in Oshawa was).
Reply With Quote
  #20  
Old 09-22-2007, 07:44 PM
ambushed ambushed is offline
Charter Member
 
Join Date: Apr 1999
Posts: 2,661
Quote:
Originally Posted by Joey P
Okay, my guess, though it's probably way off.

Every once in the a while someone on the board posts the instructions for doing google in another language (Swedish Chef, Pig Latin, Yiddish, I see Maltese on the list) is it possible you were playing with that and somehow made it your homepage?
Sorry, nope.

Quote:
Originally Posted by Joey P
Oooh, one more. Is google in your favorites? if you start typing something that's in your favorites it will come up in the URL bar. For example if I type in my URL bar "the str" it will automatically pop up as "The Stright Dope" and come to this site. It you had google.com/intl/mt in your favorites it might automatically come up when you start to type google. Hmmm, maybe?
Nope, I didn't type anything at all. I merely pressed the Google search button on my browser.

Thanks for your suggestions, however.
Reply With Quote
  #21  
Old 09-22-2007, 07:46 PM
ambushed ambushed is offline
Charter Member
 
Join Date: Apr 1999
Posts: 2,661
Quote:
Originally Posted by Sunspace
It could be aliens. Maltese aliens. In which case you may be lucky, because Maltese women can be hot (at least, the one I knew slightly back in Oshawa was).
The Maltese Women on Mars have told me I must not tell anyone of their existence or they'll XXurtjat me all over again, so mum's the word...
Reply With Quote
  #22  
Old 09-23-2007, 08:34 AM
glee glee is offline
Guest
 
Join Date: Aug 1999
Quote:
Originally Posted by Derleth
It shouldn't be possible, but neither should it have been possible to get out of Casablanca.
[Sydney Greenstreet ON]Would you like to buy an exit visa?[Sydney Greenstreet OFF]
Reply With Quote
  #23  
Old 09-23-2007, 07:40 PM
ZipperJJ ZipperJJ is offline
And Finn The Human
Charter Member
 
Join Date: Aug 2001
Location: Northeast Ohio
Posts: 19,105
FWIW, this has happened to be before too. Only it wasn't the Google homepage, it was during some sessions in Google Webmaster Tools or AdWords (or both, I forget). I was "stuck" in Korean. Better yet, I was logged in so my account profile decided I always wanted to be in Korean and set me up as such, even on a different machine.

Anyhoo, I did some searching on Google message boards and I guess this happens to other people from time to time, and the best way to "reset" it is to specifically add ?hl=en to the URL (or just hl=en if there's already a ? in the URL) to force Google into being English.

It also hasn't happened to me since...this was maybe a year ago.
Reply With Quote
Reply



Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Send questions for Cecil Adams to: cecil@chicagoreader.com

Send comments about this website to: webmaster@straightdope.com

Terms of Use / Privacy Policy

Advertise on the Straight Dope!
(Your direct line to thousands of the smartest, hippest people on the planet, plus a few total dipsticks.)

Publishers - interested in subscribing to the Straight Dope?
Write to: sdsubscriptions@chicagoreader.com.

Copyright 2013 Sun-Times Media, LLC.