Ack, WinXP doesn't recognise my memory stick

I plug it in, it announces a USB device has been found, identifies it as such but then doesn’t show it in “My Computer”, how so? :confused: My PC at home does ok, just not any of the newer PCs here in work.

This happened to me – check it out:

Are you on a network? Some network administrators disable access to external memory devices to protect against viruses and prevent unauthorized downloading of data. I consulted for at an office once where even the a: drive had been disabled.

Do’h! :smack: “… consulted at an office …”

This used to happen to me…I had to log off and then log back on to the computer so that the drive is visible in “My Computer.”

I don’t know what changed, but I no longer need to do this.

On my older P2 (with Win98 IIRC) at work it loaded up no problem, recognised and all.

With Win2000, I had a similar problem. For some reason it was getting a drive letter that conflicted with a CD drive. But under Win-XP, it gets a letter at the end of the alphabet and my computer recognizes it immediately. When I called the manufacturer, the help guy told me how to assign a drive letter that didn’t conflict. I asked him why that info wasn’t included in the (very meagre) instruction sheet and his answer was that it would confuse the user. What a load.

Eventually, it stopped working in my wife’s computer (gives a disk full error when it is 99% empty), but after I reformat it, works, or seems to, in mine. But the computer will not boot with it installed. It is obviously a device that has not been perfected. Or the OS is not, or something.

This happened to me before… XP would recognize the USB “mass storage device” but would then FUBAR everything… it had something to do with mixing up drive letters and previous USB “mass storage devices”.

I can’t find it right now… but the solution in my case was to type some obscure command (possible a registry key) into the Start/run box, then go to Control Panel/system/devices manager/view/show hidden devices… and then delete everything under USB. Then when I reinserted the USB “mass storage devices”, they showed up one by one and I got it to work again. Have you used other USB memory sticks in the past? Digital cameras count too.

In my case I had this universal 12 in 1 card reader which opened up 12 lettered drives… which is what screwed everything up. Plus my digital camera, plus my 1gig memory stick…

I think whatever I typed into the run box enabled the “show hidden devices” option but I can’t remember at the moment.

In any case, I’d recommend deleting your USB drivers and/or googling on such.

Good luck.