Using Jump Drive w new XP

I love my portable jump drive, which fits nicely on my keychain.

At work, I just upgraded Win98 to Win XP, which is great, 'cause now I can take certain files (like my MS Access project) back and forth between work and home using the data stick.

However, when I plug the jump drive into the usb port at work (with the new XP home), the drive does not show up under “My Computer”. The “du-duh” sound I hear when I plug it in confirms (to me) that the PC recognizes that removable hardware has been added, and in the lower right-hand corner of the screen, the “SAFELY REMOVE HARDWARE” icon in the sys tray is there where LEXAR JUMPDRIVE USB DEVICE is listed under the stop device window.

So… any ideas on how I can find out how to access the drive and it’s files since it’s not showing up under My Computer? (when I go to open a random MS document, the drive isn’t available either)…

Thanks for any help!

I have seen a situation with XP where USB drives “hide” under shared network drives.

For example, assume your PC has an internal hard drive C:, an internal CD-ROM drive D:, and you have mapped E: to \someserver\someshare. Now you plug in the USB drive and it’s not visible in Explorer even though you got the duduh noise, etc.

Try disconnecting the mapped E: drive. After you do, the USB drive will suddenly appear as E: It appears the code which assigns the drive letter for the USB drive doesn’t check for mapped drives before it makes its decision. I’ve also seen the same effect where the old DOS SUBST command was used to allocate the E: drive letter

If you’re not already using E: as a mapped network share or SUBSTed drive then I have no suggestions.

Thanks LSLGuy – that was EXACTLY it. I disconnected the mapped E drive via right-click and immediately the removable drive pooped up as Removable Disk (E:).

I never would have tried that, thanks again.

Damn, that should be “popped up”… and apparently my parens turned into a smiley.

When I’ve had this problem, its usually been the case that the
(A) Computer you are working on has a manually-assigned drive to a specific letter, such as “F”
(B) Your jump-drive has a specifically-assigned letter to it in its setup.

I.E. if you have an “F” drive assigned on your computer, and your jumpdrive wants to be “F” drive, it won’t show up because the network assignment takes precedence.

In order to see the drive, you need to right-click on the assigned network drive, and click on “Disconnect”. This should make your jumpdrive apear.

If this is the case, you’ll need to check the way your jumpdrive is set up, and see if you can assign it a letter further down in the alphabet.

Above all, check with your system administrator before messing with your drive settings!

If this isn’t the case, then you might want to check your disk management to see if your jumpdrive appears. In XP, right-click on “my computer”, and choose the “manage” option. Under Manage, expand the items under the “Storage” option, and enter “disk managment” In that category, see if you see your jumpdrive. If so, you could assign it a letter. Again, check with your SA before doing this, and/or check with the jumpdrive manufacturer before you mess with its settings.

If you have anything vital on the jumpdrive, you might want to copy it someplace secure before messing with these settings.

Good luck.

Darn it! I took too long to post!

Well, Noelq, maybe you can answer me this.

Although the drive is now “there” for me to see, the drive appears empty and I cannot save anything to it (or drag/drop a file into it).

I get the “Cannot find the specified file. Make sure you specify the correct path and file name”

It’s probably something to do with E: being set up prior to as a network something or other… driving me crazy though.