Advanced search: how to make it 'and' keywords, not 'or' them?

It appears that the advanced search form:
now results in a search that ORs the keywords, and doesn’t AND them. How can I force it to AND them? I do not see any sort of help on the page to describe this.

It wasn’t ORing them before, was it? Is this a setting that didn’t make it from the old server, or am I misremembering?