Calling all techies: WinME DMA help requested. I'm stumped.

Here’s the situation:

I’m running Windows ME (and please, let’s not debate WinME: good or bad: It supports DMA and that’s all that’s relevant for this) and I just got a Sony DRU500-A DVD-RW for a birthday/Hannukah present.

It suggests that DMA be enabled for best performance.

I go to my control panel, go to system, go to Device Manger and check. NONE of my IDE devices have DMA boxes listed (the CD-RW, the DVD-RW or the HDDs). It’s not that they’re ghosted, they’re not even listed. I know for a fact that the MB is

I check the System devices under Device Manager and sure enough, there’s a Direct Memory Access Controller device. I remove it, reboot and it reinstalls.

Still no check-boxes.

I go to the MB manufacturer’ page (It’s an Intel D850MV) and update all my bios/device drivers. No luck (but in the BIOS it shows that all devices have DMA enabled.

Back to Windows, I check an app that came with the MB, “Intel Application Accelerator” and it shows the following (and I’m sorry to say that I’m out of my depth at this point). For each device, I get something like:
DMA SW Mode Support: Not Supported
DMA MW Mode Support: 0 - 1 - 2
UDMA Mode Support: 0 - 1 - 2
Current Transfer Mode: UDMA
Transfer Mode Limit: No Limit

I have no idea what most of this means.

Note that the last one “Transfer Mode Limit” is the only one I can change and I can switch it to a bunch of different DMA modes or UDMA modes. I’ve tried switching it to various DMA or UDMA modes and I still don’t get the check-box. And at this point I’m not sure I need it. I mean, per the utility, everything’s fine.

Is everything fine? Do I need that DMA check box, if this other utility says it’s working? Any ideas what (if anything) I can/should do? I’m stumped.



AFAIK, your IDE devices always use DMA. They don’t use the PIO (programmed I/O) modes anymore.

DMA is apparently displayed elsewhere on this board.
DMA info

Dru500a has a couple of firmware updates. Why dont you try them?

the dma settings should be in the device manager under 'IDA/ATAPI Controllers" and check the ‘advanced settings’ of the ‘primary IDE channel’ and the ‘secondary IDE channel’ choose ‘DMA if available’ on all and reboot. check again and it wilkl report the status. your dvd is probably on the secondary channel, and should report that it’s using DMA. good luck!

Just to clarify the board post I referenced.

The DMA settings for this MB and chipset are apparently no longer listed in the system hardware chain but are accessible through an applet called the “Intel Accelerator” that should be on your PC somewhere. Possibly as an separate applet under the Control Panel applets.

Astro: that looks like it’s exactly what’s going on! Thanks to you (and everyone else) for the help!