Can you print from Collabora on Chrome OS?

I talked my mother into getting a Chromebook to replace her old Windows 7 laptop and I’m trying to set it up for her. Had a hard time getting it to work with her printer which is too old to work off the network. I got it working by telling Chrome OS it was an HP and then trying similar sounding printer drivers until one worked so we can now print from Chrome.

Collabora will be her main app for word processing but it seems to have its own printer dialogue which doesn’t see the printer I set up. The only options in the printer dialogue are print to PDF and search for printers. Print to PDF works as expected but search just hangs.

Do I have to do something with Collabora to tell it what printers are installed?

Probably dumb question, but have you rebooted since installing the printer? I had a similar problem, where one application didn’t see a newly installed printer (although this was on Windows). It turned out that that application was always running in the background, and apparently only built its list of printers when it started up. Killing the background app solved it; rebooting would have done so as well.

Thanks. Yes, rebooted the computer and the printer.