Cannot drag-and-drop text into a reply window. Also (c) and (r) trouble

@codinghorror , I just noticed this: I cannot drag-and-drop text from another place into a reply that I am composing. Copy-and-paste works fine, but not drag-and-drop. While creating this thread, I see that I also cannot drag-and-drop text into the Title text box.

I happened to notice this while trying to insert an oddball character. This MacBook has a special-character app and Firefox has a menu item to open it. In this app, I cannot copy a character to the clip-board, but I can drag it. Thus, I could not insert the special character by either method.

As for that special character, BTW: I was trying to insert the Registered Trademark symbol, (r). As you can see here, typing (r) doesn’t seem to work. Nor does (c) give me a Copyright symbol. IIRC, these two substitutions used to work, but never entirely consistently.

Hmm, you’re right about drag-and-drop.

® and © work but (r) and (c) do not. (First two generated by option-r and option-g respectively).

Thanks for the report, @Senegoid. I am a developer at Discourse and looked into this issue. It’s a side effect of an open source library we use to allow drag-and-dropping files into our composer. For some reason, it was blocking text dragging. I wrote a fix and contributed it to the library (called Uppy, link to the fix). We need to wait for the library to release the fix before we can include it in Discourse, so I suspect it will take a couple of weeks before it makes it way here. (But eventually, it will!)

Thanks again!

It’s my understanding that (R) and (C) were disabled because they (especially C) were messing with letter-ordered lists, giving us

Perhaps so, and if so, it’s probably for the better. What was worse (and I mentioned it in a post a while back), if you tried to override the substitution of (c) with © by scattering backslashes around, that worked or didn’t work very inconsistently.

You may wish to try ® instead to get ®.

Also, ™ gets you ™, and © gets you ©.

(These are part of HTML.)

This issue is now fixed, thanks again for the report.

Yes, that’s correct, use the HTML entity or the emoji symbols in those cases… feel free to Google as needed.