Can't connect my android phone to a public network

I recently got a new Samsung Epic 4G. I love this phone, but today while at work I couldn’t get it to properly connect to the public wifi we have.

The wifi we use is the kind where you connect to the network, and then the first time you go to load a website, you get redirected to a login page where you have to accept the terms of service, at which point you then can browse to your heart’s content.

My phone would say it was connected to the network just fine, but if I tried to load a website, it would attempt to redirect to the login page, but then I’d get the error:

And then the browser window would say

Other devices (laptops, a coworkers iPhone) were connecting just fine, so the network itself was fine. It seems there must be a setting of some kind that isn’t configured right. I may have to talk to the IS department, but…well…I can’t imagine they’d care all that much that I can’t connect to the public wifi with my phone.

Edit: When I get the chance, I’ll try to connect it to a different public wifi and see if it works. It connects just fine to my home wireless, so obviously the wifi works on the phone itself.

Is this phone Eclair (Android 2.1) or Froyo (2.2)? If you’re not sure, from the home screen, hit Menu, then Settings, scroll to About Phone on the bottom, and from there pick Software Information. The first entry should say Android Version.

Also, did it definitely say http://hospitalnameguest.hospitalname.org/login.htm or may it have been https?

There isn’t a ‘Software Information’ under About Phone, but there is a firmware version that says 2.1-update1, and under Build Version it says Samsung Eclair.DG27, so I’m going to go out on a limb and say I have Eclair 2.1, :p.

And you you’re right, the re-direct site for the login is an https.

Android phones log on on just like notebooks and have more or less the same setup options re security, protocols etc. Some corporate and institutional wireless networks have windows centric login interfaces and security protocols which can give Droids and Macs a bit of bellyache in terms of getting automatically logged on. If I were you I would not waste a lot more time on it until you talk to the IT department. I imagine there are specific settings for your network you have to configure to get logged on.

Are you using the stock browser or have you tried some others from the market? I’m using xcsope on my phone now. Try that or dolphin hd and see if it makes a difference.

I suspect it would work with 2.2, then, from what I’ve read. You can try exporting the SSL certificate for this site, either a root CA or a self-signed certificate, as a .pfx (PKCS#12) format file, and import it on your phone, something like this: Adding .cer certificates on your Android Phone

Or you could try rooting and flashing a froyo ROM. :wink:

I’ll try that certificate fix, thanks!

And I probably will flash Froyo once I’m able…the Epic has only been out a week, and a method to root it reliably was only recently put out, and AFAIK there aren’t any custom ROMs out for it, yet. It probably shouldn’t take too long, though, since it’s very similar to the other Galaxy S phones that are out.

There are supposed to be official Froyo upgrades for the Epic 4G in the near future, actually. Engadget link

Ok, that certificate fix won’t work…the network doesn’t seem to use certificates…at least, not that I can tell. I looked in the certificate manager in windows afte connecting a laptop to the wireless and there’s nothing there that would be for here…I figure I’ll have to go check with IS…I don’t have high hopes that they’ll have a lot of knowledge about connecting Android devices to their network, but we’ll see.

Ok, update: it does use a certificate, the name jsut wasn’t what I thought it would be. I found it, but the fix linked to by teletype won’t work because it wouldn’t let me export it in the other format, I could only keep it in the cer format.

I tried another link that claimed to be able to take the exporter .cer certificate and make it a downloadable link for an android phone, uploaded the .cer, and downloaded it to my phone using just the cell signal, but still nothing.

I don’t see what IS might be able to do, so I guess just hope the Froyo update fixes it?

If you can get the logs when this problem happens, I am sure we can get a better idea.
Preferably, a dumpstate/bugreport.
Steps:http://developer.android.com/guide/developing/tools/adb.html#commandsummary

If thats too much trouble(setting up the SDK is easy, but not fun), I will upload an app that can save these logs to the sdcard tomorrow.

I had seen something similar, because the dns property was not being set correctly.
After I set it manually, it could connect fine. Like:
http://groups.google.com/group/android-porting/browse_thread/thread/39f181f549be3506?pli=1

Does this happen only when you are using a proxy?
-> There are some issues with using a proxy for https, which were fixed pretty late in Eclair.

Sorry for bumping this thread after a few weeks, but I was away from my main work site for a while and onlyrecently have been back enough to decide I need WiFi again, :stuck_out_tongue:

I looked at those links and…they are way over my head. I have no idea WTF they are talking about.

I don’t know if the wifi here uses a proxy or not…how would I determine that?

You can use an application available in the market called - Whatismyip quick proxy check.
Sometimes, when this happens on my phone I turn the airplane mode on and off and it fixes stuff.